libxmlrpc: bump to 1.39.11
Previous version patches are still needed, but they have been
upgraded to apply cleanly.
This also reverts aa9fde1c45
, as that
patch is already on upstream.
Signed-off-by: Alvaro Gamez <alvaro.gamez@hazent.com>
[Thomas: fix the AR/RANLIB problem by adding another patch.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
496b15eac0
commit
f9349058f7
@ -19,7 +19,7 @@ Index: b/lib/expat/gennmtab/Makefile
|
|||||||
+ $(CC_FOR_BUILD) -c $< -o $@ $(CFLAGS_FOR_BUILD) $(INCLUDES)
|
+ $(CC_FOR_BUILD) -c $< -o $@ $(CFLAGS_FOR_BUILD) $(INCLUDES)
|
||||||
|
|
||||||
gennmtab:%:%.o
|
gennmtab:%:%.o
|
||||||
- $(BUILDTOOL_CCLD) -o $@ $(LDFLAGS) $^
|
- $(BUILDTOOL_CCLD) -o $@ $(LDFLAGS_ALL) $^
|
||||||
+ $(CC_FOR_BUILD) -o $@ $(LDFLAGS_FOR_BUILD) $^
|
+ $(CC_FOR_BUILD) -o $@ $(LDFLAGS_FOR_BUILD) $^
|
||||||
|
|
||||||
include depend.mk
|
include depend.mk
|
||||||
|
@ -12,15 +12,15 @@ Index: b/src/Makefile
|
|||||||
===================================================================
|
===================================================================
|
||||||
--- a/src/Makefile
|
--- a/src/Makefile
|
||||||
+++ b/src/Makefile
|
+++ b/src/Makefile
|
||||||
@@ -56,7 +56,7 @@
|
@@ -57,7 +57,7 @@
|
||||||
TRANSPORT_MODS += blddir/lib/curl_transport/curltransaction
|
TRANSPORT_MODS += $(BLDDIR)/lib/curl_transport/xmlrpc_curl_transport
|
||||||
TRANSPORT_MODS += blddir/lib/curl_transport/curlmulti
|
TRANSPORT_MODS += $(BLDDIR)/lib/curl_transport/curltransaction
|
||||||
TRANSPORT_MODS += blddir/lib/curl_transport/lock_pthread
|
TRANSPORT_MODS += $(BLDDIR)/lib/curl_transport/curlmulti
|
||||||
- TRANSPORT_LIBDEP += $(shell curl-config --libs)
|
- TRANSPORT_LIBDEP += $(shell curl-config --libs)
|
||||||
+ TRANSPORT_LIBDEP += $(shell $CURL_CONFIG --libs)
|
+ TRANSPORT_LIBDEP += $(shell $CURL_CONFIG --libs)
|
||||||
|
TRANSPORT_INCLUDES += -Isrcdir/lib/curl_transport
|
||||||
endif
|
endif
|
||||||
ifeq ($(MUST_BUILD_LIBWWW_CLIENT),yes)
|
ifeq ($(MUST_BUILD_LIBWWW_CLIENT),yes)
|
||||||
TRANSPORT_MODS += blddir/lib/libwww_transport/xmlrpc_libwww_transport
|
|
||||||
Index: b/config.mk.in
|
Index: b/config.mk.in
|
||||||
===================================================================
|
===================================================================
|
||||||
--- a/config.mk.in
|
--- a/config.mk.in
|
||||||
@ -68,29 +68,3 @@ Index: b/lib/curl_transport/Makefile
|
|||||||
# We expect that curl-config --cflags just gives us -I options, because
|
# We expect that curl-config --cflags just gives us -I options, because
|
||||||
# we need just the -I options for 'make dep'. Plus, it's scary to think
|
# we need just the -I options for 'make dep'. Plus, it's scary to think
|
||||||
# of what any other compiler flag would do to our compile.
|
# of what any other compiler flag would do to our compile.
|
||||||
Index: b/src/cpp/test/Makefile
|
|
||||||
===================================================================
|
|
||||||
--- a/src/cpp/test/Makefile
|
|
||||||
+++ b/src/cpp/test/Makefile
|
|
||||||
@@ -20,7 +20,7 @@
|
|
||||||
LIBS := $(shell $(XMLRPC_C_CONFIG) client --ldadd)
|
|
||||||
|
|
||||||
ifeq ($(MUST_BUILD_CURL_CLIENT),yes)
|
|
||||||
- LIBS += $(shell curl-config --libs)
|
|
||||||
+ LIBS += $(shell $(CURL_CONFIG) --libs)
|
|
||||||
endif
|
|
||||||
ifeq ($(MUST_BUILD_LIBWWW_CLIENT),yes)
|
|
||||||
LIBS += $(shell libwww-config --libs)
|
|
||||||
Index: b/tools/common.mk
|
|
||||||
===================================================================
|
|
||||||
--- a/tools/common.mk
|
|
||||||
+++ b/tools/common.mk
|
|
||||||
@@ -15,7 +15,7 @@
|
|
||||||
CLIENT_LDLIBS += $(shell libwww-config --libs)
|
|
||||||
endif
|
|
||||||
ifeq ($(MUST_BUILD_CURL_CLIENT),yes)
|
|
||||||
- CLIENT_LDLIBS += $(shell curl-config --libs)
|
|
||||||
+ CLIENT_LDLIBS += $(shell $(CURL_CONFIG) --libs)
|
|
||||||
endif
|
|
||||||
ifeq ($(MUST_BUILD_WININET_CLIENT),yes)
|
|
||||||
CLIENT_LDLIBS += $(shell wininet-config --libs)
|
|
||||||
|
28
package/libxmlrpc/0006-fix-ar-ranlib-handling.patch
Normal file
28
package/libxmlrpc/0006-fix-ar-ranlib-handling.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
Fix detection of AR and RANLIB
|
||||||
|
|
||||||
|
The configure.in script assumes that ranlib and ar are necessarily
|
||||||
|
prefixed by ${ac_tool_prefix}, which is the value of --host. However,
|
||||||
|
it's not necessarily the case.
|
||||||
|
|
||||||
|
So instead, use AC_CHECK_TOOL to check for AR, and AC_PROG_RANLIB to
|
||||||
|
check for RANLIB.
|
||||||
|
|
||||||
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||||
|
|
||||||
|
Index: b/configure.in
|
||||||
|
===================================================================
|
||||||
|
--- a/configure.in
|
||||||
|
+++ b/configure.in
|
||||||
|
@@ -621,10 +621,8 @@
|
||||||
|
BUILDDIR=$(pwd)
|
||||||
|
AC_SUBST(BUILDDIR)
|
||||||
|
|
||||||
|
-AR=${ac_tool_prefix}ar
|
||||||
|
-AC_SUBST([AR])
|
||||||
|
-RANLIB=${ac_tool_prefix}ranlib
|
||||||
|
-AC_SUBST([RANLIB])
|
||||||
|
+AC_CHECK_TOOL([AR], [ar])
|
||||||
|
+AC_PROG_RANLIB
|
||||||
|
|
||||||
|
dnl =======================================================================
|
||||||
|
dnl Output our results.
|
@ -1,20 +0,0 @@
|
|||||||
Fix build with gcc6
|
|
||||||
|
|
||||||
Downloaded from
|
|
||||||
https://build.opensuse.org/package/view_file/devel:libraries:c_c++/xmlrpc-c/narrowing.patch
|
|
||||||
|
|
||||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
||||||
|
|
||||||
Index: xmlrpc-c-1.33.18/src/cpp/base64.cpp
|
|
||||||
===================================================================
|
|
||||||
--- xmlrpc-c-1.33.18.orig/src/cpp/base64.cpp
|
|
||||||
+++ xmlrpc-c-1.33.18/src/cpp/base64.cpp
|
|
||||||
@@ -14,7 +14,7 @@ using namespace xmlrpc_c;
|
|
||||||
|
|
||||||
namespace {
|
|
||||||
|
|
||||||
-char const table_a2b_base64[] = {
|
|
||||||
+signed char const table_a2b_base64[] = {
|
|
||||||
-1,-1,-1,-1, -1,-1,-1,-1, -1,-1,-1,-1, -1,-1,-1,-1,
|
|
||||||
-1,-1,-1,-1, -1,-1,-1,-1, -1,-1,-1,-1, -1,-1,-1,-1,
|
|
||||||
-1,-1,-1,-1, -1,-1,-1,-1, -1,-1,-1,62, -1,-1,-1,63,
|
|
@ -1,2 +1,2 @@
|
|||||||
# Locally computed
|
# Locally computed
|
||||||
sha256 8ae6ed4ec57d50ed132b1150fc5258346eef3e291501a564f14fa97586902f98 xmlrpc-c-1.25.30.tgz
|
sha256 2e56cdcdd5c5fa564bcdc7a56bca108a88f5b78b34ccc85558366efabdc8b8e8 xmlrpc-c-1.39.11.tgz
|
||||||
|
@ -4,7 +4,7 @@
|
|||||||
#
|
#
|
||||||
################################################################################
|
################################################################################
|
||||||
|
|
||||||
LIBXMLRPC_VERSION = 1.25.30
|
LIBXMLRPC_VERSION = 1.39.11
|
||||||
LIBXMLRPC_SOURCE = xmlrpc-c-$(LIBXMLRPC_VERSION).tgz
|
LIBXMLRPC_SOURCE = xmlrpc-c-$(LIBXMLRPC_VERSION).tgz
|
||||||
LIBXMLRPC_SITE = http://downloads.sourceforge.net/project/xmlrpc-c/Xmlrpc-c%20Super%20Stable/$(LIBXMLRPC_VERSION)
|
LIBXMLRPC_SITE = http://downloads.sourceforge.net/project/xmlrpc-c/Xmlrpc-c%20Super%20Stable/$(LIBXMLRPC_VERSION)
|
||||||
LIBXMLRPC_LICENSE = BSD-3c (xml-rpc main code and abyss web server), BSD like (lib/expat), Python 1.5.2 license (parts of xmlrpc_base64.c)
|
LIBXMLRPC_LICENSE = BSD-3c (xml-rpc main code and abyss web server), BSD like (lib/expat), Python 1.5.2 license (parts of xmlrpc_base64.c)
|
||||||
|
Loading…
Reference in New Issue
Block a user