package/frr: bump to version 8.2.2
Drop patches (already in version) https://frrouting.org/release/8.2.2 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
148e2115c0
commit
f799da6f74
@ -1,29 +0,0 @@
|
||||
From bacabf2476553d0e873b827359e1c8a4216c2f8c Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Thu, 16 Dec 2021 20:10:26 +0100
|
||||
Subject: [PATCH] configure.ac: fix enable_bmp typo
|
||||
|
||||
enable_bmp doesn't exist, use enable_bgp_bmp
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Upstream status: https://github.com/FRRouting/frr/pull/10236]
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 1bcc42ef8..c7a5f1286 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1806,7 +1806,7 @@ if test "$enable_bgp_vnc" != "no";then
|
||||
fi
|
||||
|
||||
bgpd_bmp=false
|
||||
-case "${enable_bmp}" in
|
||||
+case "${enable_bgp_bmp}" in
|
||||
no)
|
||||
;;
|
||||
yes)
|
||||
--
|
||||
2.33.0
|
||||
|
@ -1,31 +0,0 @@
|
||||
From 3942ee1f7bc754dd0dd9ae79f89d0f2635be334f Mon Sep 17 00:00:00 2001
|
||||
From: David Lamparter <equinox@opensourcerouting.org>
|
||||
Date: Wed, 10 Nov 2021 15:30:07 +0100
|
||||
Subject: [PATCH] lib: fix elf_py TLS section handling
|
||||
|
||||
... need to ignore TLS sections, their address is effectively
|
||||
meaningless but can overlap other sections we actually need to access.
|
||||
|
||||
Signed-off-by: David Lamparter <equinox@opensourcerouting.org>
|
||||
|
||||
[Retrieved from:
|
||||
https://github.com/FRRouting/frr/commit/3942ee1f7bc754dd0dd9ae79f89d0f2635be334f]
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
lib/elf_py.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/lib/elf_py.c b/lib/elf_py.c
|
||||
index 1c306893ad8..f230add6957 100644
|
||||
--- a/lib/elf_py.c
|
||||
+++ b/lib/elf_py.c
|
||||
@@ -636,6 +636,9 @@ static Elf_Scn *elf_find_addr(struct elffile *ef, uint64_t addr, size_t *idx)
|
||||
Elf_Scn *scn = elf_getscn(ef->elf, i);
|
||||
GElf_Shdr _shdr, *shdr = gelf_getshdr(scn, &_shdr);
|
||||
|
||||
+ /* virtual address is kinda meaningless for TLS sections */
|
||||
+ if (shdr->sh_flags & SHF_TLS)
|
||||
+ continue;
|
||||
if (addr < shdr->sh_addr ||
|
||||
addr >= shdr->sh_addr + shdr->sh_size)
|
||||
continue;
|
@ -1,3 +1,3 @@
|
||||
# Locally calculated
|
||||
sha256 9d82c11b304ab89a30627fcbb4150f51e639f473f8563976e14101e796240599 frr-8.1.tar.gz
|
||||
sha256 33e974e2a622618e139983f65d93e92e7f1a735936ef18b18244403b15be002f frr-8.2.2.tar.gz
|
||||
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
FRR_VERSION = 8.1
|
||||
FRR_VERSION = 8.2.2
|
||||
FRR_SITE = $(call github,FRRouting,frr,frr-$(FRR_VERSION))
|
||||
FRR_LICENSE = GPL-2.0
|
||||
FRR_LICENSE_FILES = COPYING
|
||||
|
Loading…
Reference in New Issue
Block a user