package/libblockdev: bump to version 2.26

- Add upstream link to first patch
- Drop second patch (already in version)

https://github.com/storaged-project/libblockdev/blob/2.26-1/NEWS.rst

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Fabrice Fontaine 2022-02-03 18:17:15 +01:00 committed by Peter Korsgaard
parent ed81b96cc5
commit f54f61eb3a
4 changed files with 4 additions and 34 deletions

View File

@ -8,6 +8,8 @@ so let's provide a simple replacement function that falls back on
strerror().
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
[Upstream status:
https://github.com/storaged-project/libblockdev/pull/701]
---
configure.ac | 2 ++
src/plugins/crypto.c | 7 +++++++

View File

@ -1,32 +0,0 @@
From aad927a81fd9067865dc391c5bbff12ac51a0002 Mon Sep 17 00:00:00 2001
From: Manuel Wassermann <manuel.wassermann97@gmail.com>
Date: Thu, 1 Jul 2021 04:45:49 +0200
Subject: [PATCH] exec: Fix deprecated glib function call Glib will rename
"g_spawn_check_exit_status()" to "g_spawn_check_wait_status()" in version
2.69.
[Retrieved from:
https://github.com/storaged-project/libblockdev/commit/aad927a81fd9067865dc391c5bbff12ac51a0002]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
src/utils/exec.c | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/src/utils/exec.c b/src/utils/exec.c
index 317fb5525..8faeb289c 100644
--- a/src/utils/exec.c
+++ b/src/utils/exec.c
@@ -236,7 +236,12 @@ gboolean bd_utils_exec_and_report_status_error (const gchar **argv, const BDExtr
/* g_spawn_sync set the status in the same way waitpid() does, we need
to get the process exit code manually (this is similar to calling
WEXITSTATUS but also sets the error for terminated processes */
- if (!g_spawn_check_exit_status (exit_status, error)) {
+
+ #if !GLIB_CHECK_VERSION(2, 69, 0)
+ #define g_spawn_check_wait_status(x,y) (g_spawn_check_exit_status (x,y))
+ #endif
+
+ if (!g_spawn_check_wait_status (exit_status, error)) {
if (g_error_matches (*error, G_SPAWN_ERROR, G_SPAWN_ERROR_FAILED)) {
/* process was terminated abnormally (e.g. using a signal) */
g_free (stdout_data);

View File

@ -1,3 +1,3 @@
# Locally calculated
sha256 555aa42a2db39649ad83253bdc902ab5bd63d39c123e0c8055c4de7fe7571668 libblockdev-2.25.tar.gz
sha256 c4c0e10b35ac632bda8ce6d200b5601184984dec387fe59185921eb42432e069 libblockdev-2.26.tar.gz
sha256 97bdc721d875501b6243a456333fdfdb1ab64d31c4da2554de845caf4674b946 LICENSE

View File

@ -4,7 +4,7 @@
#
################################################################################
LIBBLOCKDEV_VERSION = 2.25
LIBBLOCKDEV_VERSION = 2.26
LIBBLOCKDEV_SITE = https://github.com/storaged-project/libblockdev/releases/download/$(LIBBLOCKDEV_VERSION)-1
LIBBLOCKDEV_LICENSE = LGPL-2.1
LIBBLOCKDEV_LICENSE_FILES = LICENSE