package/freeipmi: bump to version 1.6.9
Drop patches (already in version) and so autoreconf https://github.com/chu11/freeipmi-mirror/blob/freeipmi-1-6-9/NEWS Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
f92c093c7a
commit
f53928c2cb
@ -1,49 +0,0 @@
|
||||
From 6295c96ae54cb16efe41e53f526a4dc19cd719f2 Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Sat, 30 Oct 2021 00:26:40 +0200
|
||||
Subject: [PATCH] fix build on musl
|
||||
|
||||
musl doesn't provide getmsg or putmsg even if stropts.h is available
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Retrieved from:
|
||||
https://git.savannah.gnu.org/cgit/freeipmi.git/commit/?id=6295c96ae54cb16efe41e53f526a4dc19cd719f2]
|
||||
---
|
||||
configure.ac | 1 +
|
||||
libfreeipmi/driver/ipmi-sunbmc-driver.c | 4 ++--
|
||||
2 files changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 562dd624e..711b27674 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -479,6 +479,7 @@ AC_CHECK_FUNCS([flockfile fputs_unlocked fwrite_unlocked])
|
||||
AC_CHECK_FUNCS([iopl])
|
||||
AC_CHECK_FUNCS([asprintf])
|
||||
AC_CHECK_FUNCS([cbrt])
|
||||
+AC_CHECK_FUNCS([getmsg putmsg])
|
||||
|
||||
dnl sighandler_t apparently not defined in Apple/OS X
|
||||
AC_CHECK_TYPES([sighandler_t], [], [], [[#include <signal.h>]])
|
||||
diff --git a/libfreeipmi/driver/ipmi-sunbmc-driver.c b/libfreeipmi/driver/ipmi-sunbmc-driver.c
|
||||
index 05caca8b6..4ae8c5719 100644
|
||||
--- a/libfreeipmi/driver/ipmi-sunbmc-driver.c
|
||||
+++ b/libfreeipmi/driver/ipmi-sunbmc-driver.c
|
||||
@@ -423,7 +423,7 @@ _sunbmc_write (ipmi_sunbmc_ctx_t ctx,
|
||||
assert (ctx->io_init);
|
||||
assert (ctx->putmsg_intf);
|
||||
|
||||
-#if defined(HAVE_SYS_STROPTS_H)
|
||||
+#if defined(HAVE_SYS_STROPTS_H) && defined(HAVE_PUTMSG)
|
||||
memset (&sbuf, '\0', sizeof (struct strbuf));
|
||||
|
||||
/* Due to API differences, we need to extract the cmd out of the
|
||||
@@ -573,7 +573,7 @@ _sunbmc_read (ipmi_sunbmc_ctx_t ctx,
|
||||
return (-1);
|
||||
}
|
||||
|
||||
-#if defined(HAVE_SYS_STROPTS_H)
|
||||
+#if defined(HAVE_SYS_STROPTS_H) && defined(HAVE_GETMSG)
|
||||
if (getmsg (ctx->device_fd, NULL, &sbuf, &flags) < 0)
|
||||
{
|
||||
SUNBMC_ERRNO_TO_SUNBMC_ERRNUM (ctx, errno);
|
@ -1,50 +0,0 @@
|
||||
From 47249279f3ef2c1fcfc312294f1c98c35232aed0 Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Sun, 2 Jan 2022 10:37:00 +0100
|
||||
Subject: [PATCH] check for inb and outb
|
||||
|
||||
Check for inb and outb before using them to avoid the following build
|
||||
failure on uclibc-ng:
|
||||
|
||||
/home/buildroot/autobuild/instance-1/output-1/host/opt/ext-toolchain/bin/../lib/gcc/powerpc-buildroot-linux-uclibc/10.3.0/../../../../powerpc-buildroot-linux-uclibc/bin/ld: ../libfreeipmi/.libs/libfreeipmi.a(libfreeipmi_la-ipmi-kcs-driver.o): in function `_ipmi_kcs_test_if_state':
|
||||
/home/buildroot/autobuild/instance-1/output-1/build/freeipmi-1.6.8/libfreeipmi/driver/ipmi-kcs-driver.c:537: undefined reference to `inb'
|
||||
|
||||
Fixes:
|
||||
- http://autobuild.buildroot.org/results/13f58266f7747c183033c811a4e8ca6fa30b6f4d
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Upstream status: https://github.com/chu11/freeipmi-mirror/pull/50]
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
libfreeipmi/driver/ipmi-kcs-driver.c | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 711b27674..bcc4156ff 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -476,7 +476,7 @@ AC_CHECK_FUNCS([memcpy mempcpy memset mlock])
|
||||
AC_CHECK_FUNCS([getline getprogname])
|
||||
AC_CHECK_FUNCS([strerror strerror_r])
|
||||
AC_CHECK_FUNCS([flockfile fputs_unlocked fwrite_unlocked])
|
||||
-AC_CHECK_FUNCS([iopl])
|
||||
+AC_CHECK_FUNCS([inb iopl outb])
|
||||
AC_CHECK_FUNCS([asprintf])
|
||||
AC_CHECK_FUNCS([cbrt])
|
||||
AC_CHECK_FUNCS([getmsg putmsg])
|
||||
diff --git a/libfreeipmi/driver/ipmi-kcs-driver.c b/libfreeipmi/driver/ipmi-kcs-driver.c
|
||||
index c212887c0..a9d4b2e96 100644
|
||||
--- a/libfreeipmi/driver/ipmi-kcs-driver.c
|
||||
+++ b/libfreeipmi/driver/ipmi-kcs-driver.c
|
||||
@@ -162,7 +162,7 @@
|
||||
#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
|
||||
# define _INB(port) inb (port)
|
||||
# define _OUTB(data, port) outb (port, data)
|
||||
-#elif defined(HAVE_IOPL)
|
||||
+#elif defined(HAVE_INB) && defined(HAVE_OUTB)
|
||||
# define _INB(port) inb (port)
|
||||
# define _OUTB(data, port) outb (data, port)
|
||||
#else
|
||||
--
|
||||
2.33.0
|
||||
|
@ -1,5 +1,5 @@
|
||||
# Locally computed:
|
||||
sha256 4aa46a269ecc1bbff9412451f17b5408f64395e7dc45b713edf5eb5362700a71 freeipmi-1.6.8.tar.gz
|
||||
sha256 f25e1c35f3d0f1b5a99cc31ecc2353ca83ed46a15163842fba870127dc9c8206 freeipmi-1.6.9.tar.gz
|
||||
sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 COPYING
|
||||
sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 COPYING.bmc-watchdog
|
||||
sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 COPYING.ipmiconsole
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
FREEIPMI_VERSION = 1.6.8
|
||||
FREEIPMI_VERSION = 1.6.9
|
||||
FREEIPMI_SITE = https://ftp.gnu.org/gnu/freeipmi
|
||||
FREEIPMI_LICENSE = GPL-3.0+, BSD-like (sunbmc)
|
||||
FREEIPMI_LICENSE_FILES = \
|
||||
@ -14,8 +14,6 @@ FREEIPMI_LICENSE_FILES = \
|
||||
COPYING.sunbmc COPYING.ZRESEARCH
|
||||
FREEIPMI_DEPENDENCIES = host-pkgconf
|
||||
FREEIPMI_INSTALL_STAGING = YES
|
||||
# We're patching configure.ac
|
||||
FREEIPMI_AUTORECONF = YES
|
||||
# Disable checking for /dev/urandom and /dev/random through AC_CHECK_FILE
|
||||
FREEIPMI_CONF_OPTS = --without-random-device
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user