package/libglib2: update atomic patch

Commit 929bffbf4b forgot to update patch
number
Moreover, replace it with a new iteration to follow upstream request [1]
and avoid the following build host build failure with br-autobuild-1:

/usr/bin/ld: cannot find /usr/lib64/libatomic.so.1.2.0: No such file or directory

Fixes: 929bffbf4b
 - http://autobuild.buildroot.org/results/a12b9c4436594818f4ce128595b429adf7d90e31

[1]: https://gitlab.gnome.org/GNOME/glib/-/merge_requests/3606

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr: mention upstream commit now it's merged]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
Fabrice Fontaine 2024-05-03 20:31:32 +02:00 committed by Yann E. MORIN
parent 5b016de048
commit f5257789d6
2 changed files with 52 additions and 45 deletions

View File

@ -1,45 +0,0 @@
From d1814dbd3a88c95a43d4c9805bb4a523cf62d97b Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Sun, 17 Sep 2023 20:42:00 +0200
Subject: [PATCH] link with -latomic when needed
Some architecture such as sparc and some flavors of arm needs -latomic
to avoid the following build failure:
gthread-posix.c:(.text+0xda8): undefined reference to `__atomic_compare_exchange_4'
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Upstream: https://gitlab.gnome.org/GNOME/glib/-/merge_requests/3586
---
glib/meson.build | 1 +
meson.build | 2 ++
2 files changed, 3 insertions(+)
diff --git a/glib/meson.build b/glib/meson.build
index c26a35e42..7a761306b 100644
--- a/glib/meson.build
+++ b/glib/meson.build
@@ -426,6 +426,7 @@ libglib = library('glib-2.0',
pcre2,
platform_deps,
thread_dep,
+ atomic_dep
],
c_args : glib_c_args,
objc_args : glib_c_args,
diff --git a/meson.build b/meson.build
index 25ae10fc2..5ae84b3b3 100644
--- a/meson.build
+++ b/meson.build
@@ -2130,6 +2130,8 @@ libffi_dep = dependency('libffi', version : '>= 3.0.0')
libz_dep = dependency('zlib')
+atomic_dep = cc.find_library('atomic', required: false)
+
# First check in libc, fallback to libintl, and as last chance build
# proxy-libintl subproject.
# FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
--
2.40.1

View File

@ -0,0 +1,52 @@
From 4e6dc4dee0e1c6407113597180d9616b4f275f94 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Thu, 2 May 2024 14:02:17 +0200
Subject: [PATCH] link with -latomic when needed
Some architecture such as sparc and some flavors of arm needs -latomic
to avoid the following build failure:
gthread-posix.c:(.text+0xda8): undefined reference to `__atomic_compare_exchange_4'
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Upstream: https://gitlab.gnome.org/GNOME/glib/-/commit/4e6dc4dee0e1c6407113597180d9616b4f275f94
---
glib/meson.build | 1 +
meson.build | 9 +++++++++
2 files changed, 10 insertions(+)
diff --git a/glib/meson.build b/glib/meson.build
index 24cbb664d4..b2dd569e1e 100644
--- a/glib/meson.build
+++ b/glib/meson.build
@@ -419,6 +419,7 @@ libglib = library('glib-2.0',
include_directories : configinc,
link_with: [charset_lib, gnulib_lib],
dependencies : [
+ atomic_dep,
gnulib_libm_dependency,
libiconv,
libintl_deps,
diff --git a/meson.build b/meson.build
index 46c5aa200a..8b42940558 100644
--- a/meson.build
+++ b/meson.build
@@ -2233,6 +2233,15 @@ libffi_dep = dependency('libffi', version : '>= 3.0.0')
libz_dep = dependency('zlib')
+libatomic_test_code = '''
+ int main (int argc, char ** argv) {
+ return 0;
+ }'''
+atomic_dep = []
+if cc.links(libatomic_test_code, args : '-latomic', name : 'check for -latomic')
+ atomic_dep = cc.find_library('atomic')
+endif
+
# First check in libc, fallback to libintl, and as last chance build
# proxy-libintl subproject.
# FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
--
2.44.0