package/lame: Fix compile on 32bit Intel
In file included from xmm_quantize_sub.c:37:0: /home/br/br5/output/host/usr/lib/gcc/i586-buildroot-linux-uclibc/4.9.2/include/xmmintrin.h:929:1: error: inlining failed in call to always_inline '_mm_loadu_ps': target specific option mismatch _mm_loadu_ps (float const *__P) ^ xmm_quantize_sub.c:65:18: error: called from here const __m128 vec_fabs_mask = _mm_loadu_ps(&fabs_mask._float[0]); ^ Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
861600b15f
commit
f512b4efdb
24
package/lame/0003-msse.patch
Normal file
24
package/lame/0003-msse.patch
Normal file
@ -0,0 +1,24 @@
|
||||
Fix compile on 32bit Intel
|
||||
|
||||
Downloaded from
|
||||
http://anonscm.debian.org/cgit/pkg-multimedia/lame.git/tree/debian/patches/msse.patch
|
||||
|
||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
|
||||
Description: Build xmm_quantize_sub.c with -msse
|
||||
Author: Sebastian Ramacher <sramacher@debian.org>
|
||||
Bug: http://sourceforge.net/p/lame/bugs/443/
|
||||
Bug-Debian: https://bugs.debian.org/760047
|
||||
Forwarded: http://sourceforge.net/p/lame/bugs/443/
|
||||
Last-Update: 2014-08-31
|
||||
|
||||
--- lame-3.99.5+repack1.orig/libmp3lame/vector/Makefile.am
|
||||
+++ lame-3.99.5+repack1/libmp3lame/vector/Makefile.am
|
||||
@@ -20,6 +20,7 @@ xmm_sources = xmm_quantize_sub.c
|
||||
|
||||
if WITH_XMM
|
||||
liblamevectorroutines_la_SOURCES = $(xmm_sources)
|
||||
+liblamevectorroutines_la_CFLAGS = -msse
|
||||
endif
|
||||
|
||||
noinst_HEADERS = lame_intrin.h
|
Loading…
Reference in New Issue
Block a user