package/transmission: bump version to 2.9.4
Removed patch 0003, a different fix was committed upstream:
b21a6140e9
Renumbered remaining patches.
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
8e5837cae7
commit
f451bed9c4
@ -1,31 +0,0 @@
|
||||
Fix libminiupnpc version detection
|
||||
|
||||
Problem is known upstream: https://trac.transmissionbt.com/ticket/6140
|
||||
|
||||
For buildroot we know the libminiupnpc version so we hard-code 2.0.
|
||||
|
||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
|
||||
diff -uNr transmission-2.92.org/configure.ac transmission-2.92/configure.ac
|
||||
--- transmission-2.92.org/configure.ac 2016-03-06 21:23:45.336198393 +0100
|
||||
+++ transmission-2.92/configure.ac 2016-07-02 21:48:13.452385686 +0200
|
||||
@@ -386,18 +386,7 @@
|
||||
dnl MINIUPNPC_API_VERSION and we won't have to figure
|
||||
dnl it out on our own
|
||||
if test "x$upnp_version" = "xunknown" ; then
|
||||
- AC_RUN_IFELSE(
|
||||
- [AC_LANG_PROGRAM(
|
||||
- [#include <stdlib.h>
|
||||
- #include <miniupnpc/miniupnpc.h>],
|
||||
- [#ifdef MINIUPNPC_API_VERSION
|
||||
- return EXIT_SUCCESS;
|
||||
- #else
|
||||
- return EXIT_FAILURE;
|
||||
- #endif]
|
||||
- )],
|
||||
- [upnp_version=">= 1.7"]
|
||||
- )
|
||||
+ upnp_version="2.0"
|
||||
fi
|
||||
|
||||
dnl Or maybe it's miniupnp 1.6
|
@ -1,3 +1,3 @@
|
||||
# Locally calculated
|
||||
sha256 8815920e0a4499bcdadbbe89a4115092dab42ce5199f71ff9a926cfd12b9b90b transmission-2.93.tar.xz
|
||||
sha256 35442cc849f91f8df982c3d0d479d650c6ca19310a994eccdaa79a4af3916b7d transmission-2.94.tar.xz
|
||||
sha256 20801783bf59e27d03ed6aab625b32a34e221ae95bf801db87827c8023398495 COPYING
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
TRANSMISSION_VERSION = 2.93
|
||||
TRANSMISSION_VERSION = 2.94
|
||||
TRANSMISSION_SITE = https://github.com/transmission/transmission-releases/raw/master
|
||||
TRANSMISSION_SOURCE = transmission-$(TRANSMISSION_VERSION).tar.xz
|
||||
TRANSMISSION_DEPENDENCIES = \
|
||||
|
Loading…
Reference in New Issue
Block a user