package/mdadm: replace PIE workaround
Replace PIE workaround added by commit
826e0bc336
by an upstream patch
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
2e07cd5a1b
commit
f44b46c47b
40
package/mdadm/0004-Makefile-Move-pie-to-LDFLAGS.patch
Normal file
40
package/mdadm/0004-Makefile-Move-pie-to-LDFLAGS.patch
Normal file
@ -0,0 +1,40 @@
|
||||
From 893a55831e5abbcd15b171db66fa1f389fb61506 Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Tue, 7 May 2024 19:32:16 +0200
|
||||
Subject: Makefile: Move -pie to LDFLAGS
|
||||
|
||||
Move -pie from LDLIBS to LDFLAGS and make LDFLAGS configurable to allow
|
||||
the user to drop it by setting their own LDFLAGS (e.g. PIE could be
|
||||
enabled or disabled by the buildsystem such as buildroot).
|
||||
|
||||
Suggested-by: Mariusz Tkaczyk <mariusz.tkaczyk@linux.intel.com>
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Signed-off-by: Mariusz Tkaczyk <mariusz.tkaczyk@linux.intel.com>
|
||||
|
||||
Upstream: https://git.kernel.org/pub/scm/utils/mdadm/mdadm.git/commit/?id=893a55831e5abbcd15b171db66fa1f389fb61506
|
||||
---
|
||||
Makefile | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 7c221a89..adac7905 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -132,12 +132,12 @@ CFLAGS += -DUSE_PTHREADS
|
||||
MON_LDFLAGS += -pthread
|
||||
endif
|
||||
|
||||
-LDFLAGS = -Wl,-z,now,-z,noexecstack
|
||||
+LDFLAGS ?= -pie -Wl,-z,now,-z,noexecstack
|
||||
|
||||
# If you want a static binary, you might uncomment these
|
||||
# LDFLAGS += -static
|
||||
# STRIP = -s
|
||||
-LDLIBS = -ldl -pie
|
||||
+LDLIBS = -ldl
|
||||
|
||||
# To explicitly disable libudev, set -DNO_LIBUDEV in CXFLAGS
|
||||
ifeq (, $(findstring -DNO_LIBUDEV, $(CXFLAGS)))
|
||||
--
|
||||
cgit 1.2.3-korg
|
||||
|
@ -21,7 +21,7 @@ MDADM_BUILD_OPTS = \
|
||||
CXFLAGS="$(MDADM_CXFLAGS)" \
|
||||
CPPFLAGS="$(TARGET_CPPFLAGS) -DBINDIR=\\\"/sbin\\\"" \
|
||||
CHECK_RUN_DIR=0 \
|
||||
LDLIBS=-ldl
|
||||
LDFLAGS=$(TARGET_LDFLAGS)
|
||||
|
||||
MDADM_INSTALL_TARGET_OPTS = install-bin
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user