package/pulseaudio: remove musl fix

A recent change in puseaudio 8.0 [1] removed the nonstandard
__WORDSIZE define. So 0002-musl-fixes.patch is not needed
anymore.

Also remove PULSEAUDIO_AUTORECONF.

Fixes:
http://autobuild.buildroot.net/results/dc6/dc6642b18a97f6e0ac1524fe836226a7ee23df86

[1] https://cgit.freedesktop.org/pulseaudio/pulseaudio/commit/?id=7c1a5d61597b8a7b762f8295c7d791942dba3fb5

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Romain Naour 2016-02-13 14:07:48 +01:00 committed by Thomas Petazzoni
parent bb1324288a
commit f061f5a1da
2 changed files with 0 additions and 43 deletions

View File

@ -1,41 +0,0 @@
Portability fixes for musl taken from voidlinux:
- _WORDIZE is declared in <bits/user.h> via <sys/user.h>.
--xtraeme
[Bernd: Downloaded from
http://git.alpinelinux.org/cgit/aports/tree/testing/pulseaudio/musl-fixes.patch
and adjusted paths.]
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Thomas: remove xlocale.h part, it was fixed upstream.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
--- a/configure.ac.orig 2015-09-24 11:36:06.107661526 +0200
+++ b/configure.ac 2015-09-24 11:36:40.420036775 +0200
@@ -407,7 +407,7 @@ AC_HEADER_STDC
# POSIX
AC_CHECK_HEADERS_ONCE([arpa/inet.h glob.h grp.h netdb.h netinet/in.h \
netinet/in_systm.h netinet/tcp.h poll.h pwd.h sched.h \
- sys/mman.h sys/select.h sys/socket.h sys/wait.h \
+ sys/mman.h sys/select.h sys/socket.h sys/wait.h sys/user.h \
sys/uio.h syslog.h sys/dl.h dlfcn.h linux/sockios.h])
AC_CHECK_HEADERS([netinet/ip.h], [], [],
[#include <sys/types.h>
--- a/src/pulsecore/sample-util.h.orig 2015-09-24 11:37:57.773677238 +0200
+++ b/src/pulsecore/sample-util.h 2015-09-24 11:38:46.668208677 +0200
@@ -24,6 +24,14 @@
#include <inttypes.h>
#include <limits.h>
+#ifdef HAVE_CONFIG_H
+#include <config.h>
+#endif
+
+#ifdef HAVE_SYS_USER_H
+#include <sys/user.h> /* required by _WORDIZE with musl */
+#endif
+
#include <pulse/gccmacro.h>
#include <pulse/sample.h>
#include <pulse/volume.h>

View File

@ -7,8 +7,6 @@
PULSEAUDIO_VERSION = 8.0 PULSEAUDIO_VERSION = 8.0
PULSEAUDIO_SOURCE = pulseaudio-$(PULSEAUDIO_VERSION).tar.xz PULSEAUDIO_SOURCE = pulseaudio-$(PULSEAUDIO_VERSION).tar.xz
PULSEAUDIO_SITE = http://freedesktop.org/software/pulseaudio/releases PULSEAUDIO_SITE = http://freedesktop.org/software/pulseaudio/releases
# 0002-musl-fixes.patch patches configure.ac
PULSEAUDIO_AUTORECONF = YES
PULSEAUDIO_INSTALL_STAGING = YES PULSEAUDIO_INSTALL_STAGING = YES
PULSEAUDIO_LICENSE = LGPLv2.1+ (specific license for modules, see LICENSE file) PULSEAUDIO_LICENSE = LGPLv2.1+ (specific license for modules, see LICENSE file)
PULSEAUDIO_LICENSE_FILES = LICENSE GPL LGPL PULSEAUDIO_LICENSE_FILES = LICENSE GPL LGPL