package/webrtc-audio-processing: bump to version 1.3
- Drop patch (not needed anymore) - Switch to meson-package - libabseil-cpp is a mandatory dependency Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
8a170b8446
commit
ef0fa986eb
@ -1405,7 +1405,6 @@ package/wampcc/0001-Add-RISC-V-endian-detection.patch Upstream
|
||||
package/wampcc/0002-include-wampcc-platform.h-fix-build-with-musl-1.2.0.patch Upstream
|
||||
package/wampcc/0003-Broken-build-on-Windows.patch Upstream
|
||||
package/watchdogd/S01watchdogd Indent NotExecutable
|
||||
package/webrtc-audio-processing/0001-Proper-detection-of-cxxabi.h-and-execinfo.h.patch Upstream
|
||||
package/wget/0001-lib-getrandom.c-fix-build-with-uclibc-1.0.35.patch Upstream
|
||||
package/wilc-driver/0001-cfg80211.c-fix-missing-prandom_u32-with-Linux-6.1.0.patch Upstream
|
||||
package/wilc-driver/0002-spi.c-fix-build-failure-on-remove-callback.patch Upstream
|
||||
|
@ -675,17 +675,20 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTCDSP
|
||||
bool "webrtcdsp"
|
||||
# All depends from webrtc-audio-processing
|
||||
depends on BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING_ARCH_SUPPORTS
|
||||
depends on BR2_PACKAGE_LIBABSEIL_CPP_ARCH_SUPPORTS
|
||||
depends on BR2_INSTALL_LIBSTDCPP
|
||||
depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
|
||||
depends on BR2_TOOLCHAIN_GCC_AT_LEAST_8
|
||||
depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
|
||||
depends on !BR2_STATIC_LIBS
|
||||
select BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING
|
||||
help
|
||||
WebRTC echo-cancellation, gain control and noise suppression
|
||||
|
||||
comment "webrtcdsp needs a toolchain w/ C++, NPTL, gcc >= 4.8"
|
||||
comment "webrtcdsp needs a toolchain w/ C++, NPTL, dynamic library, gcc >= 8"
|
||||
depends on BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING_ARCH_SUPPORTS
|
||||
depends on BR2_PACKAGE_LIBABSEIL_CPP_ARCH_SUPPORTS
|
||||
depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS_NPTL \
|
||||
|| !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
|
||||
|| BR2_STATIC_LIBS || !BR2_TOOLCHAIN_GCC_AT_LEAST_8
|
||||
|
||||
config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WPE
|
||||
bool "wpe"
|
||||
|
@ -1,63 +0,0 @@
|
||||
From b7a166acaddc4c78afa2b653e25114d9114699f3 Mon Sep 17 00:00:00 2001
|
||||
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
Date: Sat, 6 Aug 2016 11:24:50 +0200
|
||||
Subject: [PATCH] Proper detection of cxxabi.h and execinfo.h
|
||||
|
||||
The current code in webrtc/base/checks.cc assumes that if __GLIBCXX__ is
|
||||
defined and __UCLIBC__ is not defined, then both cxxabi.h and execinfo.h
|
||||
will be available.
|
||||
|
||||
Unfortunately, this is not correct with the musl C library:
|
||||
|
||||
- It defines __GLIBCXX__
|
||||
- It does not define __UCLIBC__ (it's not uClibc after all!)
|
||||
- But it also doesn't provide execinfo.h
|
||||
|
||||
Therefore, in order to make things work properly, we switch to proper
|
||||
autoconf checks for cxxabi.h and execinfo.h, and only use the backtrace
|
||||
functionality if both are provided.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
---
|
||||
configure.ac | 2 ++
|
||||
webrtc/base/checks.cc | 4 ++--
|
||||
2 files changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index acbb3e2..ff4c752 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -45,6 +45,8 @@ AC_SUBST(GNUSTL_CFLAGS)
|
||||
# Borrowed from gst-plugins-bad
|
||||
AC_CHECK_HEADER(MobileCoreServices/MobileCoreServices.h, HAVE_IOS="yes", HAVE_IOS="no", [-])
|
||||
|
||||
+AC_CHECK_HEADERS([cxxabi.h execinfo.h])
|
||||
+
|
||||
# Based on gst-plugins-bad configure.ac and defines in
|
||||
# <chromium source>/build/config/BUILDCONFIG.gn and
|
||||
# webrtc/BUILD.gn
|
||||
diff --git a/webrtc/base/checks.cc b/webrtc/base/checks.cc
|
||||
index 49a31f2..05d23a6 100644
|
||||
--- a/webrtc/base/checks.cc
|
||||
+++ b/webrtc/base/checks.cc
|
||||
@@ -16,7 +16,7 @@
|
||||
#include <cstdio>
|
||||
#include <cstdlib>
|
||||
|
||||
-#if defined(__GLIBCXX__) && !defined(__UCLIBC__)
|
||||
+#if defined(HAVE_CXX_ABI_H) && defined(HAVE_EXECINFO_H)
|
||||
#include <cxxabi.h>
|
||||
#include <execinfo.h>
|
||||
#endif
|
||||
@@ -55,7 +55,7 @@ void PrintError(const char* format, ...) {
|
||||
// to get usable symbols on Linux. This is copied from V8. Chromium has a more
|
||||
// advanced stace trace system; also more difficult to copy.
|
||||
void DumpBacktrace() {
|
||||
-#if defined(__GLIBCXX__) && !defined(__UCLIBC__)
|
||||
+#if defined(HAVE_CXX_ABI_H) && defined(HAVE_EXECINFO_H)
|
||||
void* trace[100];
|
||||
int size = backtrace(trace, sizeof(trace) / sizeof(*trace));
|
||||
char** symbols = backtrace_symbols(trace, size);
|
||||
--
|
||||
2.7.4
|
||||
|
@ -5,17 +5,21 @@ config BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING_ARCH_SUPPORTS
|
||||
config BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING
|
||||
bool "webrtc-audio-processing"
|
||||
depends on BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING_ARCH_SUPPORTS
|
||||
depends on BR2_PACKAGE_LIBABSEIL_CPP_ARCH_SUPPORTS
|
||||
depends on BR2_INSTALL_LIBSTDCPP
|
||||
depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
|
||||
depends on BR2_TOOLCHAIN_GCC_AT_LEAST_8 # libabseil-cpp
|
||||
# pthread_condattr_setclock
|
||||
depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
|
||||
depends on !BR2_STATIC_LIBS # libabseil-cpp
|
||||
select BR2_PACKAGE_LIBABSEIL_CPP
|
||||
help
|
||||
AudioProcessing library based on Google's implementation of
|
||||
WebRTC.
|
||||
|
||||
http://freedesktop.org/software/pulseaudio/webrtc-audio-processing/
|
||||
|
||||
comment "webrtc-audio-processing needs a toolchain w/ C++, NPTL, gcc >= 4.8"
|
||||
comment "webrtc-audio-processing needs a toolchain w/ C++, NPTL, dynamic library, gcc >= 8"
|
||||
depends on BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING_ARCH_SUPPORTS
|
||||
depends on BR2_PACKAGE_LIBABSEIL_CPP_ARCH_SUPPORTS
|
||||
depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS_NPTL \
|
||||
|| !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
|
||||
|| BR2_STATIC_LIBS || !BR2_TOOLCHAIN_GCC_AT_LEAST_8
|
||||
|
@ -1,3 +1,3 @@
|
||||
# Locally calculated
|
||||
sha256 a0fdd938fd85272d67e81572c5a4d9e200a0c104753cb3c209ded175ce3c5dbf webrtc-audio-processing-0.3.1.tar.xz
|
||||
sha256 2365e93e778d7b61b5d6e02d21c47d97222e9c7deff9e1d0838ad6ec2e86f1b9 webrtc-audio-processing-1.3.tar.xz
|
||||
sha256 9b79539028e216e813e152d45f5c1ed5fdd0554426ad50270fb03134e7082dac COPYING
|
||||
|
@ -4,18 +4,12 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
WEBRTC_AUDIO_PROCESSING_VERSION = 0.3.1
|
||||
WEBRTC_AUDIO_PROCESSING_VERSION = 1.3
|
||||
WEBRTC_AUDIO_PROCESSING_SOURCE = webrtc-audio-processing-$(WEBRTC_AUDIO_PROCESSING_VERSION).tar.xz
|
||||
WEBRTC_AUDIO_PROCESSING_SITE = http://freedesktop.org/software/pulseaudio/webrtc-audio-processing
|
||||
WEBRTC_AUDIO_PROCESSING_INSTALL_STAGING = YES
|
||||
WEBRTC_AUDIO_PROCESSING_LICENSE = BSD-3-Clause
|
||||
WEBRTC_AUDIO_PROCESSING_LICENSE_FILES = COPYING
|
||||
WEBRTC_AUDIO_PROCESSING_DEPENDENCIES = host-pkgconf
|
||||
# 0001-Proper-detection-of-cxxabi.h-and-execinfo.h.patch
|
||||
WEBRTC_AUDIO_PROCESSING_AUTORECONF = YES
|
||||
WEBRTC_AUDIO_PROCESSING_DEPENDENCIES = host-pkgconf libabseil-cpp
|
||||
|
||||
ifeq ($(BR2_SOFT_FLOAT),y)
|
||||
WEBRTC_AUDIO_PROCESSING_CONF_OPTS += --with-ns-mode=fixed
|
||||
endif
|
||||
|
||||
$(eval $(autotools-package))
|
||||
$(eval $(meson-package))
|
||||
|
Loading…
Reference in New Issue
Block a user