rtl8723bs: new package
Signed-off-by: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
84919cacad
commit
eeecbe16e2
@ -448,6 +448,7 @@ endmenu
|
||||
source "package/rpi-userland/Config.in"
|
||||
source "package/rs485conf/Config.in"
|
||||
source "package/rtl8188eu/Config.in"
|
||||
source "package/rtl8723bs/Config.in"
|
||||
source "package/rtl8821au/Config.in"
|
||||
source "package/sane-backends/Config.in"
|
||||
source "package/sdparm/Config.in"
|
||||
|
@ -0,0 +1,41 @@
|
||||
From 9f70428f506ac9d5af325004c01c59c62669d7eb Mon Sep 17 00:00:00 2001
|
||||
From: Jason Abele <jason@jasonabeleconsulting.com>
|
||||
Date: Sat, 15 Aug 2015 18:20:54 -0700
|
||||
Subject: [PATCH] rtl8723bs: add debug level modparam
|
||||
|
||||
For ease of controlling debug printk verbosity, add a module parameter
|
||||
which sets debug level at module load.
|
||||
|
||||
Signed-off-by: Jason Abele <jason@jasonabeleconsulting.com>
|
||||
[Fixed to apply on current version]
|
||||
Signed-off-by: Ariel D'Alessandro <ariel@vanguardiasur.com.ar>
|
||||
---
|
||||
os_dep/os_intfs.c | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/os_dep/os_intfs.c b/os_dep/os_intfs.c
|
||||
index b30c2a0..eeb8946 100644
|
||||
--- a/os_dep/os_intfs.c
|
||||
+++ b/os_dep/os_intfs.c
|
||||
@@ -231,6 +231,10 @@ module_param(rtw_decrypt_phy_file, int, 0644);
|
||||
MODULE_PARM_DESC(rtw_decrypt_phy_file,"Enable Decrypt PHY File");
|
||||
#endif
|
||||
|
||||
+int rtw_debug_level = _drv_err_;
|
||||
+module_param(rtw_debug_level, int, 0644);
|
||||
+MODULE_PARM_DESC(rtw_debug_level,"Set Driver Debug Verbosity");
|
||||
+
|
||||
int _netdev_open(struct net_device *pnetdev);
|
||||
int netdev_open (struct net_device *pnetdev);
|
||||
static int netdev_close (struct net_device *pnetdev);
|
||||
@@ -347,6 +351,7 @@ static uint loadparam(struct adapter *padapter, _nic_hdl pnetdev)
|
||||
registry_par->qos_opt_enable = (u8)rtw_qos_opt_enable;
|
||||
|
||||
registry_par->hiq_filter = (u8)rtw_hiq_filter;
|
||||
+ GlobalDebugLevel = rtw_debug_level;
|
||||
return status;
|
||||
}
|
||||
|
||||
--
|
||||
2.8.3
|
||||
|
10
package/rtl8723bs/Config.in
Normal file
10
package/rtl8723bs/Config.in
Normal file
@ -0,0 +1,10 @@
|
||||
config BR2_PACKAGE_RTL8723BS
|
||||
bool "rtl8723bs"
|
||||
depends on BR2_LINUX_KERNEL
|
||||
help
|
||||
rtl8723bs wifi driver
|
||||
|
||||
https://github.com/hadess/rtl8723bs
|
||||
|
||||
comment "rtl8723bs needs a Linux kernel to be built"
|
||||
depends on !BR2_LINUX_KERNEL
|
27
package/rtl8723bs/rtl8723bs.mk
Normal file
27
package/rtl8723bs/rtl8723bs.mk
Normal file
@ -0,0 +1,27 @@
|
||||
################################################################################
|
||||
#
|
||||
# rtl8723bs
|
||||
#
|
||||
################################################################################
|
||||
|
||||
RTL8723BS_VERSION = 11ab92d8ccd71c80f0102828366b14ef6b676fb2
|
||||
RTL8723BS_SITE = $(call github,hadess,rtl8723bs,$(RTL8723BS_VERSION))
|
||||
RTL8723BS_LICENSE = GPLv2, proprietary (*.bin firmware blobs)
|
||||
|
||||
RTL8723BS_MODULE_MAKE_OPTS = \
|
||||
CONFIG_RTL8723BS=m \
|
||||
KVER=$(LINUX_VERSION_PROBED) \
|
||||
KSRC=$(LINUX_DIR)
|
||||
|
||||
RTL8723BS_BINS = rtl8723bs_ap_wowlan.bin rtl8723bs_wowlan.bin \
|
||||
rtl8723bs_bt.bin rtl8723bs_nic.bin
|
||||
|
||||
define RTL8723BS_INSTALL_FIRMWARE
|
||||
$(foreach bin, $(RTL8723BS_BINS), \
|
||||
$(INSTALL) -D -m 644 $(@D)/$(bin) $(TARGET_DIR)/lib/firmware/rtlwifi/$(bin)
|
||||
)
|
||||
endef
|
||||
RTL8723BS_POST_INSTALL_TARGET_HOOKS += RTL8723BS_INSTALL_FIRMWARE
|
||||
|
||||
$(eval $(kernel-module))
|
||||
$(eval $(generic-package))
|
Loading…
Reference in New Issue
Block a user