perl: remove libintl static linking handling

We no longer support building the full-blown libintl in static linking
scenarios, as it causes too many problems. Therefore, remove the patch
that was handling this.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Thomas Petazzoni 2017-07-04 00:03:01 +02:00
parent 72b8cb6175
commit ee557967ab

View File

@ -1,20 +0,0 @@
fix static build with gdbm + gettext
see doc http://perldoc.perl.org/ExtUtils/MakeMaker.html#LIBS
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
index: b/ext/GDBM_File/Makefile.PL
===================================================================
--- a/ext/GDBM_File/Makefile.PL
+++ b/ext/GDBM_File/Makefile.PL
@@ -2,7 +2,7 @@ use ExtUtils::MakeMaker;
use ExtUtils::Constant 0.11 'WriteConstants';
WriteMakefile(
NAME => 'GDBM_File',
- LIBS => ["-lgdbm", "-ldbm"],
+ LIBS => ["-lgdbm -lintl", "-lgdbm", "-ldbm"],
XSPROTOARG => '-noprototypes', # XXX remove later?
VERSION_FROM => 'GDBM_File.pm',
realclean => {FILES=> 'const-c.inc const-xs.inc'},