package/zziplib: bump to version 0.13.74
- Drop patches (already in version)
- docs/copying.htm renamed to docs/copying.htm.md, and reformatted from
HTML to Markdown, with upstream commit:
b8138ba56e
https://github.com/gdraheim/zziplib/blob/v0.13.74/ChangeLog
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr:
- explain why hash of docs/copying.htm.md changed
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
parent
b3819b761f
commit
eddc53a9c1
@ -1703,7 +1703,6 @@ package/zip/0006-unix-configure-borrow-the-LFS-test-from-autotools.patch lib_pat
|
||||
package/zip/0007-timezone.c-needs-time.h-fixes-musl-compile.patch lib_patch.Upstream
|
||||
package/zip/0008-fix-musl-static-build.patch lib_patch.Upstream
|
||||
package/zmqpp/0001-Allow-building-shared-or-static-library-only.patch lib_patch.Upstream
|
||||
package/zziplib/0001-implant-ZZIP_LIBLATEST-for-zzip_lib.patch lib_patch.Upstream
|
||||
support/dependencies/check-host-asciidoc.sh Shellcheck
|
||||
support/dependencies/check-host-cmake.sh Shellcheck
|
||||
support/dependencies/check-host-gzip.sh Shellcheck
|
||||
|
@ -1,75 +0,0 @@
|
||||
From 0e8d35f92efb680c81f6ec1fca9f11d173dce389 Mon Sep 17 00:00:00 2001
|
||||
From: Guido Draheim <guidod@gmx.de>
|
||||
Date: Sat, 22 May 2021 15:13:28 +0200
|
||||
Subject: [PATCH] #117 implant ZZIP_LIBLATEST for zzip.lib
|
||||
|
||||
[Andreas: Extract link creation for versioned libraries from commit
|
||||
0e8d35f92efb680c81f6ec1fca9f11d173dce389.]
|
||||
Signed-off-by: Andreas Ziegler <br015@umbiko.net>
|
||||
---
|
||||
zzip/CMakeLists.txt | 57 +++++++++++++++++++++++++++++++++++----------
|
||||
1 file changed, 45 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/zzip/CMakeLists.txt b/zzip/CMakeLists.txt
|
||||
index a966d5f..ccd08b6 100644
|
||||
--- a/zzip/CMakeLists.txt
|
||||
+++ b/zzip/CMakeLists.txt
|
||||
@@ -28,6 +28,12 @@ option(ZZIP_LIBTOOL "Ensure binary compatibility with libtool" OFF)
|
||||
option(ZZIP_PKGCONFIG "Generate pkg-config files for linking" OFF)
|
||||
endif()
|
||||
|
||||
+if(ZZIP_LIBTOOL OR ZZIP_PKGCONFIG)
|
||||
+option(ZZIP_LIBLATEST "Ensure libname.lib links to libname-REL.lib" ON)
|
||||
+else()
|
||||
+option(ZZIP_LIBLATEST "Ensure libname.lib links to libname-REL.lib" OFF)
|
||||
+endif()
|
||||
+
|
||||
# used in zzip/_config.h
|
||||
set(ZZIP_PACKAGE "${PROJECT_NAME}lib")
|
||||
set(ZZIP_VERSION "${PROJECT_VERSION}")
|
||||
@@ -346,6 +340,45 @@ if(ZZIP_LIBTOOL)
|
||||
endif(CMAKE_SHARED_LIBRARY_SONAME_C_FLAG)
|
||||
endif(ZZIP_LIBTOOL)
|
||||
|
||||
+if(ZZIP_LIBLATEST)
|
||||
+ if(BUILD_SHARED_LIBS)
|
||||
+ set(lib ${CMAKE_SHARED_LIBRARY_PREFIX})
|
||||
+ set(dll ${CMAKE_SHARED_LIBRARY_SUFFIX})
|
||||
+ else()
|
||||
+ set(lib ${CMAKE_STATIC_LIBRARY_PREFIX})
|
||||
+ set(dll ${CMAKE_STATIC_LIBRARY_SUFFIX})
|
||||
+ endif()
|
||||
+ get_target_property(libname libzzip OUTPUT_NAME)
|
||||
+ get_target_property(librelease libzzip RELEASE_POSTFIX)
|
||||
+ add_custom_target(libzzip_latest ALL
|
||||
+ COMMAND ${CMAKE_COMMAND} -E create_symlink $<TARGET_FILE_NAME:libzzip> ${lib}${libname}${dll}
|
||||
+ )
|
||||
+ install(FILES
|
||||
+ ${outdir}/${lib}${libname}${dll}
|
||||
+ DESTINATION ${CMAKE_INSTALL_LIBDIR})
|
||||
+ if(ZZIPFSEEKO)
|
||||
+ get_target_property(libname libzzipfseeko OUTPUT_NAME)
|
||||
+ get_target_property(librelease libzzipfseeko RELEASE_POSTFIX)
|
||||
+ add_custom_target(libzzipfseeko_latest ALL
|
||||
+ COMMAND ${CMAKE_COMMAND} -E create_symlink $<TARGET_FILE_NAME:libzzipfseeko> ${lib}${libname}${dll}
|
||||
+ )
|
||||
+ install(FILES
|
||||
+ ${outdir}/${lib}${libname}${dll}
|
||||
+ DESTINATION ${CMAKE_INSTALL_LIBDIR})
|
||||
+ endif(ZZIPFSEEKO)
|
||||
+ if(ZZIPMMAPPED)
|
||||
+ get_target_property(libname libzzipmmapped OUTPUT_NAME)
|
||||
+ get_target_property(librelease libzzipmmapped RELEASE_POSTFIX)
|
||||
+ add_custom_target(libzzipmmaped_latest ALL
|
||||
+ COMMAND ${CMAKE_COMMAND} -E create_symlink $<TARGET_FILE_NAME:libzzipmmapped> ${lib}${libname}${dll}
|
||||
+ )
|
||||
+ install(FILES
|
||||
+ ${outdir}/${lib}${libname}${dll}
|
||||
+ DESTINATION ${CMAKE_INSTALL_LIBDIR})
|
||||
+ endif(ZZIPMMAPPED)
|
||||
+endif(ZZIP_LIBLATEST)
|
||||
+
|
||||
+
|
||||
## messages ##############################################
|
||||
|
||||
message(STATUS "lib zzipfseeko to be compiled: ${ZZIPFSEEKO}")
|
@ -1,72 +0,0 @@
|
||||
From 5977725ecea038f32a86938703ca1ed2b080b31c Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Ziegler <br015@umbiko.net>
|
||||
Date: Fri, 29 Jul 2022 12:32:27 +0200
|
||||
Subject: [PATCH] ZZIP_LIBLATEST: create symlinks only if target is missing
|
||||
|
||||
zzip/CMakeList.txt uses custom build targets to create symlinks to the
|
||||
(normally versioned) build results from unversioned file names. These
|
||||
targets are executed unconditionally, every time a build is started,
|
||||
regardless of the existence of the symlink.
|
||||
|
||||
Debug builds, however, generate unversioned libraries. The build targets
|
||||
therefore overwrite existing files with recursive links.
|
||||
|
||||
Create custom targets depending on the target file plus custom build
|
||||
commands containing the symlink creation, thereby ensuring that symlinks
|
||||
are only created if the link target is missing.
|
||||
|
||||
Signed-off-by: Andreas Ziegler <br015@umbiko.net>
|
||||
Upstream: https://github.com/gdraheim/zziplib/pull/138
|
||||
---
|
||||
zzip/CMakeLists.txt | 18 +++++++++++++++---
|
||||
1 file changed, 15 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/zzip/CMakeLists.txt b/zzip/CMakeLists.txt
|
||||
index 4fa6b9c..dd1e56a 100644
|
||||
--- a/zzip/CMakeLists.txt
|
||||
+++ b/zzip/CMakeLists.txt
|
||||
@@ -350,8 +350,12 @@ if(ZZIP_LIBLATEST)
|
||||
endif()
|
||||
get_target_property(libname libzzip OUTPUT_NAME)
|
||||
get_target_property(librelease libzzip RELEASE_POSTFIX)
|
||||
+ set(libzzip_target "${lib}${libname}${dll}")
|
||||
+ add_custom_command(OUTPUT ${libzzip_target}
|
||||
+ COMMAND ${CMAKE_COMMAND} -E create_symlink $<TARGET_FILE_NAME:libzzip> ${libzzip_target}
|
||||
+ )
|
||||
add_custom_target(libzzip_latest ALL
|
||||
- COMMAND ${CMAKE_COMMAND} -E create_symlink $<TARGET_FILE_NAME:libzzip> ${lib}${libname}${dll}
|
||||
+ DEPENDS ${libzzip_target}
|
||||
)
|
||||
install(FILES
|
||||
${outdir}/${lib}${libname}${dll}
|
||||
@@ -359,8 +363,12 @@ if(ZZIP_LIBLATEST)
|
||||
if(ZZIPFSEEKO)
|
||||
get_target_property(libname libzzipfseeko OUTPUT_NAME)
|
||||
get_target_property(librelease libzzipfseeko RELEASE_POSTFIX)
|
||||
+ set(libzzipfseeko_target "${lib}${libname}${dll}")
|
||||
+ add_custom_command(OUTPUT ${libzzipfseeko_target}
|
||||
+ COMMAND ${CMAKE_COMMAND} -E create_symlink $<TARGET_FILE_NAME:libzzipfseeko> ${libzzipfseeko_target}
|
||||
+ )
|
||||
add_custom_target(libzzipfseeko_latest ALL
|
||||
- COMMAND ${CMAKE_COMMAND} -E create_symlink $<TARGET_FILE_NAME:libzzipfseeko> ${lib}${libname}${dll}
|
||||
+ DEPENDS ${libzzipfseeko_target}
|
||||
)
|
||||
install(FILES
|
||||
${outdir}/${lib}${libname}${dll}
|
||||
@@ -369,8 +377,12 @@ if(ZZIP_LIBLATEST)
|
||||
if(ZZIPMMAPPED)
|
||||
get_target_property(libname libzzipmmapped OUTPUT_NAME)
|
||||
get_target_property(librelease libzzipmmapped RELEASE_POSTFIX)
|
||||
+ set(libzzipmmapped_target "${lib}${libname}${dll}")
|
||||
+ add_custom_command(OUTPUT ${libzzipmmapped_target}
|
||||
+ COMMAND ${CMAKE_COMMAND} -E create_symlink $<TARGET_FILE_NAME:libzzipmmapped> ${libzzipmmapped_target}
|
||||
+ )
|
||||
add_custom_target(libzzipmmaped_latest ALL
|
||||
- COMMAND ${CMAKE_COMMAND} -E create_symlink $<TARGET_FILE_NAME:libzzipmmapped> ${lib}${libname}${dll}
|
||||
+ DEPENDS ${libzzipmmapped_target}
|
||||
)
|
||||
install(FILES
|
||||
${outdir}/${lib}${libname}${dll}
|
||||
--
|
||||
2.34.1
|
||||
|
@ -1,5 +1,5 @@
|
||||
# sha256 locally computed
|
||||
sha256 93ef44bf1f1ea24fc66080426a469df82fa631d13ca3b2e4abaeab89538518dc zziplib-0.13.72.tar.gz
|
||||
sha256 319093aa98d39453f3ea2486a86d8a2fab2d5632f6633a2665318723a908eecf zziplib-0.13.74.tar.gz
|
||||
sha256 94b03f1a60a7fd5007149530626a895a6ef5a8b9342abfd56860c5f3956f5d23 docs/COPYING.LIB
|
||||
sha256 c2aa7d58cebd24cb877bbf11d6b13a4bb7cd08b9d7db5d3037ca06c46bf4cfd8 docs/COPYING.MPL
|
||||
sha256 1c6da11efe8c43ee853fe5b21501dd72b81831ae84d58ea376bddc0620a5c361 docs/copying.htm
|
||||
sha256 9418aca218090f0bebfa91298c8145c7342de095eced3d72ea241c178df59368 docs/copying.htm.md
|
||||
|
@ -4,10 +4,10 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
ZZIPLIB_VERSION = 0.13.72
|
||||
ZZIPLIB_VERSION = 0.13.74
|
||||
ZZIPLIB_SITE = $(call github,gdraheim,zziplib,v$(ZZIPLIB_VERSION))
|
||||
ZZIPLIB_LICENSE = LGPL-2.0+ or MPL-1.1
|
||||
ZZIPLIB_LICENSE_FILES = docs/COPYING.LIB docs/COPYING.MPL docs/copying.htm
|
||||
ZZIPLIB_LICENSE_FILES = docs/COPYING.LIB docs/COPYING.MPL docs/copying.htm.md
|
||||
ZZIPLIB_CPE_ID_VALID = YES
|
||||
ZZIPLIB_INSTALL_STAGING = YES
|
||||
ZZIPLIB_CONF_OPTS += \
|
||||
|
Loading…
Reference in New Issue
Block a user