package/cog: bump to version 0.16.1
This is a small bugfix release which solves build issues. The patch to fix the libdrm dependency is included in this release and can be removed. Release notes: https://wpewebkit.org/release/cog-0.16.1.html Signed-off-by: Adrian Perez de Castro <aperez@igalia.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
c77c66b7df
commit
ed9b0d3954
@ -1,36 +0,0 @@
|
|||||||
From 9a1982c563e218b7695e6a174c8230d3b063eb27 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Gary Bisson <gary.bisson@boundarydevices.com>
|
|
||||||
Date: Thu, 6 Oct 2022 09:04:22 +0200
|
|
||||||
Subject: [PATCH] wl: Fix libdrm dependency when protocols are used
|
|
||||||
|
|
||||||
As the comment says, cog-platform-wl.c needs drm_fourcc.h to build
|
|
||||||
properly when wayland_weston_direct_display is enabled.
|
|
||||||
|
|
||||||
However, libdrm.pc doesn't specify "include/libdrm" as part of its
|
|
||||||
includedir but whether in its cflags. So use the compile_args dep
|
|
||||||
instead of includes to fix the build failure.
|
|
||||||
|
|
||||||
Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
|
|
||||||
(cherry picked from commit 32c1d9533bcdc22cbc01d02bf2e6ac0d4bda2dc2)
|
|
||||||
Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
|
|
||||||
[Upstream status: https://github.com/Igalia/cog/pull/501]
|
|
||||||
---
|
|
||||||
platform/wayland/meson.build | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/platform/wayland/meson.build b/platform/wayland/meson.build
|
|
||||||
index f1e18ec..31e4460 100644
|
|
||||||
--- a/platform/wayland/meson.build
|
|
||||||
+++ b/platform/wayland/meson.build
|
|
||||||
@@ -67,7 +67,7 @@ if wayland_platform_weston_protocols.length() > 0
|
|
||||||
|
|
||||||
# The code uses definitions from the drm_fourcc.h header, but does not
|
|
||||||
# need to link the library; libdrm here is only a build-time dependency.
|
|
||||||
- wayland_platform_dependencies += [dependency('libdrm').partial_dependency(includes: true)]
|
|
||||||
+ wayland_platform_dependencies += [dependency('libdrm').partial_dependency(compile_args: true)]
|
|
||||||
endif
|
|
||||||
|
|
||||||
|
|
||||||
--
|
|
||||||
2.38.0
|
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
# From https://wpewebkit.org/releases/cog-0.16.0.tar.xz.sums
|
# From https://wpewebkit.org/releases/cog-0.16.1.tar.xz.sums
|
||||||
md5 2705472ea4f333290973722c0862b21d cog-0.16.0.tar.xz
|
md5 1489740db6b4ea568578035c30b8b2f4 cog-0.16.1.tar.xz
|
||||||
sha1 ef16e5e3d91d0da056fe5e4f596c211af7453b4e cog-0.16.0.tar.xz
|
sha1 1235203085e7ccd8fc76eab6bdfcdb2e3ae38ea9 cog-0.16.1.tar.xz
|
||||||
sha256 2956f719d36c9a6368f63901a0d1ceaf4d27f529f7df441b3748c36d72906fc6 cog-0.16.0.tar.xz
|
sha256 37c5f14123b8dcf077839f6c60f0d721d2a91bb37829e796f420126e6b0d38b5 cog-0.16.1.tar.xz
|
||||||
|
|
||||||
# Hashes for license files:
|
# Hashes for license files:
|
||||||
sha256 e6c42d93c68b292bcccf6d2ec3e13da85df90b718ba27c2c2a01053a9d009252 COPYING
|
sha256 e6c42d93c68b292bcccf6d2ec3e13da85df90b718ba27c2c2a01053a9d009252 COPYING
|
||||||
|
@ -4,7 +4,7 @@
|
|||||||
#
|
#
|
||||||
################################################################################
|
################################################################################
|
||||||
|
|
||||||
COG_VERSION = 0.16.0
|
COG_VERSION = 0.16.1
|
||||||
COG_SITE = https://wpewebkit.org/releases
|
COG_SITE = https://wpewebkit.org/releases
|
||||||
COG_SOURCE = cog-$(COG_VERSION).tar.xz
|
COG_SOURCE = cog-$(COG_VERSION).tar.xz
|
||||||
COG_INSTALL_STAGING = YES
|
COG_INSTALL_STAGING = YES
|
||||||
|
Loading…
Reference in New Issue
Block a user