package/libblockdev: bump to version 3.0.4
Update local patch to add missing strerror_l() to other files. Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
359abca84c
commit
ed573043b5
@ -1,4 +1,4 @@
|
||||
From 425d9ad320746298bd52b74ea3f38ad3c0468ff0 Mon Sep 17 00:00:00 2001
|
||||
From 2acf5a8d4858035396ee45d96c824e0481644d36 Mon Sep 17 00:00:00 2001
|
||||
From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||||
Date: Sat, 29 Aug 2020 16:04:15 +0200
|
||||
Subject: [PATCH] Provide replacement function for strerror_l()
|
||||
@ -11,16 +11,19 @@ Upstream status: Not Applicable since it's due uclibc only
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||||
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
|
||||
[Giulio: ported to version 3.0]
|
||||
[Giulio: ported to version 3.0+]
|
||||
---
|
||||
configure.ac | 2 ++
|
||||
src/plugins/crypto.c | 7 +++++++
|
||||
src/plugins/part.c | 9 +++++++++
|
||||
src/utils/module.c | 8 +++++++-
|
||||
4 files changed, 25 insertions(+), 1 deletion(-)
|
||||
configure.ac | 2 ++
|
||||
src/plugins/crypto.c | 7 +++++++
|
||||
src/plugins/nvme/nvme-error.c | 8 ++++++++
|
||||
src/plugins/nvme/nvme-fabrics.c | 8 ++++++++
|
||||
src/plugins/nvme/nvme-op.c | 8 ++++++++
|
||||
src/plugins/part.c | 9 +++++++++
|
||||
src/utils/module.c | 8 +++++++-
|
||||
7 files changed, 49 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 88fa835a..4fba7b7d 100644
|
||||
index 0a8ce4a7..dfbddb39 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -120,6 +120,8 @@ AC_CHECK_HEADERS([dlfcn.h string.h unistd.h sys/fcntl.h sys/ioctl.h linux/random
|
||||
@ -33,7 +36,7 @@ index 88fa835a..4fba7b7d 100644
|
||||
AS_HELP_STRING([--with-escrow], [support escrow @<:@default=yes@:>@]),
|
||||
[],
|
||||
diff --git a/src/plugins/crypto.c b/src/plugins/crypto.c
|
||||
index 503e1207..5896d211 100644
|
||||
index c5f719ca..b2ae3f56 100644
|
||||
--- a/src/plugins/crypto.c
|
||||
+++ b/src/plugins/crypto.c
|
||||
@@ -62,6 +62,13 @@
|
||||
@ -50,8 +53,65 @@ index 503e1207..5896d211 100644
|
||||
/**
|
||||
* SECTION: crypto
|
||||
* @short_description: plugin for operations with encrypted devices
|
||||
diff --git a/src/plugins/nvme/nvme-error.c b/src/plugins/nvme/nvme-error.c
|
||||
index 4bd4d771..618b6aef 100644
|
||||
--- a/src/plugins/nvme/nvme-error.c
|
||||
+++ b/src/plugins/nvme/nvme-error.c
|
||||
@@ -34,6 +34,14 @@
|
||||
#include "nvme.h"
|
||||
#include "nvme-private.h"
|
||||
|
||||
+#define UNUSED __attribute__((unused))
|
||||
+
|
||||
+#if !defined(HAVE_STRERROR_L)
|
||||
+static char *strerror_l(int errnum, locale_t locale UNUSED)
|
||||
+{
|
||||
+ return strerror(errnum);
|
||||
+}
|
||||
+#endif
|
||||
|
||||
/**
|
||||
* bd_nvme_error_quark: (skip)
|
||||
diff --git a/src/plugins/nvme/nvme-fabrics.c b/src/plugins/nvme/nvme-fabrics.c
|
||||
index 1877845f..5fcbeddc 100644
|
||||
--- a/src/plugins/nvme/nvme-fabrics.c
|
||||
+++ b/src/plugins/nvme/nvme-fabrics.c
|
||||
@@ -36,6 +36,14 @@
|
||||
#include "nvme.h"
|
||||
#include "nvme-private.h"
|
||||
|
||||
+#define UNUSED __attribute__((unused))
|
||||
+
|
||||
+#if !defined(HAVE_STRERROR_L)
|
||||
+static char *strerror_l(int errnum, locale_t locale UNUSED)
|
||||
+{
|
||||
+ return strerror(errnum);
|
||||
+}
|
||||
+#endif
|
||||
|
||||
/* nvme-cli defaults */
|
||||
#define PATH_NVMF_CONFIG "/etc/nvme/config.json"
|
||||
diff --git a/src/plugins/nvme/nvme-op.c b/src/plugins/nvme/nvme-op.c
|
||||
index dbef4f3a..7bafd7a3 100644
|
||||
--- a/src/plugins/nvme/nvme-op.c
|
||||
+++ b/src/plugins/nvme/nvme-op.c
|
||||
@@ -35,6 +35,14 @@
|
||||
#include "nvme.h"
|
||||
#include "nvme-private.h"
|
||||
|
||||
+#define UNUSED __attribute__((unused))
|
||||
+
|
||||
+#if !defined(HAVE_STRERROR_L)
|
||||
+static char *strerror_l(int errnum, locale_t locale UNUSED)
|
||||
+{
|
||||
+ return strerror(errnum);
|
||||
+}
|
||||
+#endif
|
||||
|
||||
/**
|
||||
* bd_nvme_device_self_test:
|
||||
diff --git a/src/plugins/part.c b/src/plugins/part.c
|
||||
index d75bb791..ba34bb93 100644
|
||||
index 46d31137..6234e013 100644
|
||||
--- a/src/plugins/part.c
|
||||
+++ b/src/plugins/part.c
|
||||
@@ -26,6 +26,15 @@
|
||||
|
@ -1,3 +1,3 @@
|
||||
# Locally calculated
|
||||
sha256 0f2872830293f3e222832903d80de4c38e06a9c3ea18915b3263272a72095ea8 libblockdev-3.0.3.tar.gz
|
||||
sha256 49841ff92db0ab032931e6f2b5eab63e5969b0ddc14b067b60e46a6eb6c60e47 libblockdev-3.0.4.tar.gz
|
||||
sha256 97bdc721d875501b6243a456333fdfdb1ab64d31c4da2554de845caf4674b946 LICENSE
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
LIBBLOCKDEV_VERSION = 3.0.3
|
||||
LIBBLOCKDEV_VERSION = 3.0.4
|
||||
LIBBLOCKDEV_SITE = https://github.com/storaged-project/libblockdev/releases/download/$(LIBBLOCKDEV_VERSION)-1
|
||||
LIBBLOCKDEV_LICENSE = LGPL-2.1
|
||||
LIBBLOCKDEV_LICENSE_FILES = LICENSE
|
||||
|
Loading…
Reference in New Issue
Block a user