package/tcl: fix package patch
The commit4e365d1768
"package/tcl: bump to version 8.6.13" did NOT refreshed the package patch, because the patch was still applying correctly and the package was working as expected. It was refreshed in the previous bump, in commit9cf314745a
"package/tcl: bump to version 8.6.12". This was part of 2022.02. Looking closer at the patch content, the -/+ lines are exactly the same. So this patch does not change anything. Since the file was kept and the commit log mention a patch refresh, the intent was more likely to carry over the old patch (which was declaring all libc functions as "unbroken". This commit actually refreshes this patch. It was regenerated with git format-patch. Since the patch is renamed due to git format-patch, the .checkpackageignore is updated accordingly. Note: This ancient patch will be removed soon, as an upstream commit [1], not yet in a release, cleaned up and removed those old parts. [1]04d66a2571
Cc: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Julien Olivain <ju.o@free.fr> Signed-off-by: Arnout Vandecappelle <arnout@mind.be>
This commit is contained in:
parent
6425e0b848
commit
ec8a9cc518
@ -1388,7 +1388,7 @@ package/taskd/0001-Fix-missing-cmakedefine-HAVE_GET_CURRENT_DIR_NAME.patch Upstr
|
||||
package/taskd/0002-Use-correct-variables-for-GnuTLS-detection.patch Upstream
|
||||
package/taskd/0003-CMakeLists-use-pkg-config-uuid-detection.patch Upstream
|
||||
package/tcf-agent/S55tcf-agent Shellcheck Variables
|
||||
package/tcl/0001-dont-build-compat.patch Upstream
|
||||
package/tcl/0001-Disable-tcl-compatibility-layers.patch Upstream
|
||||
package/tesseract-ocr/0001-Check-if-platform-supports-feenableexcept.patch Upstream
|
||||
package/tesseract-ocr/0002-configure.ac-fix-build-on-aarch64_be.patch Upstream
|
||||
package/tftpd/0001-Use-extern-qualifier-to-fix-gcc-10.x-build.patch Upstream
|
||||
|
@ -1,4 +1,6 @@
|
||||
From c829552921f0c7c8e522f911135ee100742b441b Mon Sep 17 00:00:00 2001
|
||||
From: Andrew Ruder <andrew.ruder@elecsyscorp.com>
|
||||
Date: Tue, 8 Apr 2014 15:54:04 -0500
|
||||
Subject: [PATCH] Disable tcl compatibility layers
|
||||
|
||||
Turn off building compatibility layers for old/broken versions of
|
||||
@ -9,17 +11,25 @@ to not have broken behavior.
|
||||
Signed-off-by: Andrew Ruder <andrew.ruder@elecsyscorp.com>
|
||||
[Fabrice: Update for 8.6.12]
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Julien: Update for 8.6.13]
|
||||
Signed-off-by: Julien Olivain <ju.o@free.fr>
|
||||
---
|
||||
unix/tcl.m4 | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/unix/tcl.m4 b/unix/tcl.m4
|
||||
index ca94abd4ad..42eb58d384 100644
|
||||
--- a/unix/tcl.m4
|
||||
+++ b/unix/tcl.m4
|
||||
@@ -2725,7 +2725,7 @@ AC_DEFUN([SC_TCL_CHECK_BROKEN_FUNC],[
|
||||
@@ -2646,7 +2646,7 @@ AC_DEFUN([SC_TCL_CHECK_BROKEN_FUNC],[
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
int main() {]$2[}]]])],[tcl_cv_$1_unbroken=ok],
|
||||
- [tcl_cv_$1_unbroken=broken],[tcl_cv_$1_unbroken=unknown]))
|
||||
+ [tcl_cv_$1_unbroken=broken],[tcl_cv_$1_unbroken=unknown]))
|
||||
if test ["$tcl_cv_]$1[_unbroken"] = "ok"; then
|
||||
+ [tcl_cv_$1_unbroken=broken],[tcl_cv_$1_unbroken=ok]))
|
||||
if test ["$tcl_cv_]$1[_unbroken"] = "ok"; then
|
||||
tcl_ok=1
|
||||
else
|
||||
--
|
||||
2.41.0
|
||||
|
Loading…
Reference in New Issue
Block a user