diff --git a/package/c-icap/c-icap.mk b/package/c-icap/c-icap.mk
index 2d8b30920b..750b231c7c 100644
--- a/package/c-icap/c-icap.mk
+++ b/package/c-icap/c-icap.mk
@@ -48,6 +48,13 @@ else
 C_ICAP_CONF_OPTS += --without-ldap
 endif
 
+ifeq ($(BR2_PACKAGE_PCRE),y)
+C_ICAP_CONF_OPTS += --with-pcre
+C_ICAP_DEPENDENCIES += pcre
+else
+C_ICAP_CONF_OPTS += --without-pcre
+endif
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 C_ICAP_CONF_OPTS += --with-zlib
 C_ICAP_DEPENDENCIES += zlib