docker: change into generic-package

docker is using autotools-package while it is in fact just a plain make
package.

Remove docker-1.5-skip-configure.patch which was just a hack to avoid
calling the non-existent configure script.

Remove docker-1.5-pkgconfig.patch which is not needed when PATH is set
appropriately.

Add a XLIBPATH option to the command line to avoid linking with
/usr/X11R6/lib.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Arnout Vandecappelle 2013-10-24 00:24:18 +02:00 committed by Peter Korsgaard
parent 70da2ae5ff
commit eb742c1956
3 changed files with 11 additions and 38 deletions

View File

@ -1,23 +0,0 @@
--- a/Makefile 2002-11-20 05:20:49.000000000 -0500
+++ b/Makefile 2008-04-28 12:36:23.000000000 -0400
@@ -20,7 +20,6 @@ CFLAGS=-pedantic -Wall -W -O
PACKAGE=docker
VERSION=1.5
-
target=docker
sources=docker.c kde.c icons.c xproperty.c net.c
headers=docker.h kde.h icons.h xproperty.h net.h version.h
@@ -31,10 +30,10 @@ all: $(target) $(sources) $(headers)
$(target): $(sources:.c=.o)
$(CC) $(CFLAGS) -L$(XLIBPATH) -lX11 \
- `pkg-config --libs glib-2.0` $^ -o $@
+ `$(PKG_CONFIG) --libs glib-2.0` $^ -o $@
%.o: %.c
- $(CC) -c $(CFLAGS) `pkg-config --cflags glib-2.0` $<
+ $(CC) -c $(CFLAGS) `$(PKG_CONFIG) --cflags glib-2.0` $<
version.h: version.h.in Makefile
sed -e "s/@VERSION@/$(VERSION)/" version.h.in > $@

View File

@ -1,4 +0,0 @@
--- a/.stamp_configured 2008-03-19 03:34:24.425005162 -0400
+++ b/.stamp_configured 2008-03-19 14:25:33.000000000 -0400
@@ -0,0 +1 @@
+

View File

@ -6,16 +6,16 @@
DOCKER_VERSION = 1.5
DOCKER_SITE = http://icculus.org/openbox/2/docker
DOCKER_MAKE_OPT = CC="$(TARGET_CC)" CXX="$(TARGET_CXX)" LD="$(TARGET_LD)" \
CFLAGS="-I$(STAGING_DIR)/usr/include \
-I$(STAGING_DIR)/usr/include/glib-2.0 \
-I$(STAGING_DIR)/usr/lib/glib-2.0/include" \
PKG_CONFIG="$(PKG_CONFIG_HOST_BINARY)" \
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib"
DOCKER_INSTALL_TARGET_OPT = PREFIX=$(TARGET_DIR)/usr install
DOCKER_DEPENDENCIES = host-pkgconf libglib2 xlib_libX11
$(eval $(autotools-package))
define DOCKER_BUILD_CMDS
$(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
XLIBPATH=$(STAGING_DIR)/usr/lib
endef
define DOCKER_INSTALL_TARGET_CMDS
$(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
XLIBPATH=$(STAGING_DIR)/usr/lib PREFIX=$(TARGET_DIR)/usr install
endef
$(eval $(generic-package))