diff --git a/package/optee-test/0001-xtest-add-DOPENSSL_API_COMPAT-10100.patch b/package/optee-test/0001-xtest-add-DOPENSSL_API_COMPAT-10100.patch
deleted file mode 100644
index b876c3385f..0000000000
--- a/package/optee-test/0001-xtest-add-DOPENSSL_API_COMPAT-10100.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From a0db2b60b9f5c14e9f69c0e06e1a8d35f9fb1b5a Mon Sep 17 00:00:00 2001
-From: Jerome Forissier <jerome.forissier@linaro.org>
-Date: Tue, 25 Jul 2023 14:39:25 +0200
-Subject: [PATCH] xtest: add -DOPENSSL_API_COMPAT=10100
-
-regression_1000.c uses OpenSSL functions that have been deprecated
-after version 1.1. In particular, building with version 3.0 causes the
-following error (and other similar ones not pasted here):
-
- optee_test/host/xtest/regression_1000.c: In function 'check_signature':
- optee_test/host/xtest/regression_1000.c:2735:9: error: 'SHA256_Init' is deprecated: Since OpenSSL 3.0 [-Werror=deprecated-declarations]
-  2735 |         SHA256_Init(&ctx);
-       |         ^~~~~~~~~~~
-
-Add -DOPENSSL_API_COMPAT=10100 to the build flags to avoid this and be
-flexible with regards to which version of OpenSSL build environment has
-to provide.
-
-Signed-off-by: Jerome Forissier <jerome.forissier@linaro.org>
-Acked-by: Jens Wiklander <jens.wiklander@linaro.org>
-(cherry picked from commit cf111604c4c32a76be90f29aab25fa9b882c8715)
-Upstream: https://github.com/OP-TEE/optee_test/commit/cf111604c4c32a76be90f29aab25fa9b882c8715
-Signed-off-by: Romain Naour <romain.naour@gmail.com>
----
- host/xtest/CMakeLists.txt | 2 +-
- host/xtest/Makefile       | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/host/xtest/CMakeLists.txt b/host/xtest/CMakeLists.txt
-index 776787b..ae0f4e0 100644
---- a/host/xtest/CMakeLists.txt
-+++ b/host/xtest/CMakeLists.txt
-@@ -12,7 +12,7 @@ endif()
- 
- find_package(OpenSSL)
- if(OPENSSL_FOUND)
--	add_compile_options(-DOPENSSL_FOUND=1)
-+	add_compile_options(-DOPENSSL_FOUND=1 -DOPENSSL_API_COMPAT=10100)
- 	set (OPENSSL_PRIVATE_LINK OpenSSL::Crypto)
- endif()
- 
-diff --git a/host/xtest/Makefile b/host/xtest/Makefile
-index 8505629..2497850 100644
---- a/host/xtest/Makefile
-+++ b/host/xtest/Makefile
-@@ -39,7 +39,7 @@ endef
- # - User/group login tests 1027 and 1028
- WITH_OPENSSL ?= y
- ifeq ($(WITH_OPENSSL),y)
--CFLAGS += -DOPENSSL_FOUND=1
-+CFLAGS += -DOPENSSL_FOUND=1 -DOPENSSL_API_COMPAT=10100
- ifneq ($(OPTEE_OPENSSL_EXPORT),)
- LDFLAGS += -lcrypto
- CFLAGS += -I$(OPTEE_OPENSSL_EXPORT)
--- 
-2.41.0
-
diff --git a/package/optee-test/optee-test.hash b/package/optee-test/optee-test.hash
index 08b3331374..9744ab6d92 100644
--- a/package/optee-test/optee-test.hash
+++ b/package/optee-test/optee-test.hash
@@ -1,4 +1,4 @@
-# From https://github.com/OP-TEE/optee_test/archive/3.21.0/optee-test-3.21.0.tar.gz
-sha256  44c7dc3df48e9d73f12bbbef1cc2a4e22d859ab8a5e67a07923267f924175d65  optee-test-3.21.0.tar.gz
+# From https://github.com/OP-TEE/optee_test/archive/4.0.0/optee-test-4.0.0.tar.gz
+sha256  dc37b90c98db54068e61b31e20378878e2cfdf3c71f90c8a635786164651c62f  optee-test-4.0.0.tar.gz
 # Locally computed
 sha256  6e6810981f0ddab9e0d44399d0700a15d9f760a3c2843cc866659c2074139ae7  LICENSE.md
diff --git a/package/optee-test/optee-test.mk b/package/optee-test/optee-test.mk
index d306ef8269..44d3015ae1 100644
--- a/package/optee-test/optee-test.mk
+++ b/package/optee-test/optee-test.mk
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-OPTEE_TEST_VERSION = 3.21.0
+OPTEE_TEST_VERSION = 4.0.0
 OPTEE_TEST_SITE = $(call github,OP-TEE,optee_test,$(OPTEE_TEST_VERSION))
 OPTEE_TEST_LICENSE = GPL-2.0, BSD-2-Clause,
 OPTEE_TEST_LICENSE_FILES = LICENSE.md