libnss: don't use target CFLAGS with host toolchain
The OPTIMIZER variable is used to construct CFLAGS for host toolchain. This breaks the build since we set it to TARGET_CFLAGS, and these may not be supported by host toolchain. Augment the cross-compile patch to handle OPTIMIZER so that we can initialize it to TARGET_OPTIMIZER, and override it when used with host toolchain. Fixes: http://autobuild.buildroot.net/results/3f1/3f1afc1b58cb6fe53c438b55f169e2a78238806d/ Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
6c526bbd4f
commit
ea7bb05c7b
@ -4,11 +4,12 @@ compiled code so we cannot define it on the command line without breaking
|
||||
the host tools build.
|
||||
|
||||
[Gustavo: update for nss 3.16.1]
|
||||
[baruch: add OPTIMIZER handling]
|
||||
Signed-off-by: Will Newton <will.newton@imgtec.com>
|
||||
|
||||
diff -Nura nss-3.16.1.orig/nss/coreconf/Linux.mk nss-3.16.1/nss/coreconf/Linux.mk
|
||||
--- nss-3.16.1.orig/nss/coreconf/Linux.mk 2014-06-18 10:34:30.503996123 -0300
|
||||
+++ nss-3.16.1/nss/coreconf/Linux.mk 2014-06-18 10:35:02.233068390 -0300
|
||||
diff -Nuar nss-3.16.1-orig/nss/coreconf/Linux.mk nss-3.16.1/nss/coreconf/Linux.mk
|
||||
--- nss-3.16.1-orig/nss/coreconf/Linux.mk 2014-05-02 06:27:18.000000000 +0300
|
||||
+++ nss-3.16.1/nss/coreconf/Linux.mk 2014-07-01 02:38:18.701480512 +0300
|
||||
@@ -16,9 +16,13 @@
|
||||
IMPL_STRATEGY = _PTH
|
||||
endif
|
||||
@ -26,3 +27,22 @@ diff -Nura nss-3.16.1.orig/nss/coreconf/Linux.mk nss-3.16.1/nss/coreconf/Linux.m
|
||||
|
||||
DEFAULT_COMPILER = gcc
|
||||
|
||||
@@ -125,6 +129,7 @@
|
||||
endif
|
||||
endif
|
||||
|
||||
+OPTIMIZER = $(TARGET_OPTIMIZER)
|
||||
|
||||
ifeq ($(USE_PTHREADS),1)
|
||||
OS_PTHREAD = -lpthread
|
||||
diff -Nuar nss-3.16.1-orig/nss/coreconf/nsinstall/Makefile nss-3.16.1/nss/coreconf/nsinstall/Makefile
|
||||
--- nss-3.16.1-orig/nss/coreconf/nsinstall/Makefile 2014-05-02 06:27:18.000000000 +0300
|
||||
+++ nss-3.16.1/nss/coreconf/nsinstall/Makefile 2014-07-01 02:38:48.102185011 +0300
|
||||
@@ -31,6 +31,7 @@
|
||||
|
||||
ifdef NATIVE_FLAGS
|
||||
OS_CFLAGS=$(NATIVE_FLAGS)
|
||||
+OPTIMIZER=
|
||||
endif
|
||||
|
||||
include $(DEPTH)/coreconf/rules.mk
|
||||
|
@ -47,7 +47,8 @@ define LIBNSS_BUILD_CMDS
|
||||
SOURCE_MD_DIR=$(@D)/$(LIBNSS_DISTDIR) \
|
||||
DIST=$(@D)/$(LIBNSS_DISTDIR) \
|
||||
CHECKLOC= \
|
||||
$(LIBNSS_BUILD_VARS) OPTIMIZER="$(TARGET_CFLAGS)"
|
||||
$(LIBNSS_BUILD_VARS) TARGET_OPTIMIZER="$(TARGET_CFLAGS)" \
|
||||
NATIVE_FLAGS="$(HOST_CFLAGS)"
|
||||
endef
|
||||
|
||||
define LIBNSS_INSTALL_STAGING_CMDS
|
||||
|
Loading…
Reference in New Issue
Block a user