package/numactl: bump to version 2.0.16
- Drop patches (already in version) - Use official tarball and so drop autoreconf https://github.com/numactl/numactl/releases/tag/v2.0.15 https://github.com/numactl/numactl/releases/tag/v2.0.16 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
parent
702a60a296
commit
e9bc980d93
@ -1,25 +0,0 @@
|
||||
From f96c96af7fbf2779b15f66f03b10315a24fb4f5a Mon Sep 17 00:00:00 2001
|
||||
From: Scott McMillan <smcmillan@nvidia.com>
|
||||
Date: Fri, 9 Oct 2020 08:56:52 -0500
|
||||
Subject: [PATCH] Do not stringify SYMVER symbols
|
||||
|
||||
Upstream: f96c96af7fbf2779b15f66f03b10315a24fb4f5a
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||||
---
|
||||
util.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/util.h b/util.h
|
||||
index 99ada33..f2a20ac 100644
|
||||
--- a/util.h
|
||||
+++ b/util.h
|
||||
@@ -22,5 +22,5 @@ extern char *policy_name(int policy);
|
||||
#if HAVE_ATTRIBUTE_SYMVER
|
||||
#define SYMVER(a,b) __attribute__ ((symver (b)))
|
||||
#else
|
||||
-#define SYMVER(a,b) __asm__ (".symver " #a "," #b);
|
||||
+#define SYMVER(a,b) __asm__ (".symver " a "," b);
|
||||
#endif
|
||||
--
|
||||
2.30.2
|
||||
|
@ -1,52 +0,0 @@
|
||||
From e0de0d9e981ddb53bdeb4a4b9dc43046c9ff4ff9 Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Thu, 6 May 2021 23:08:36 +0200
|
||||
Subject: [PATCH] link with -latomic if needed
|
||||
|
||||
numactl unconditionally uses __atomic_fetch_and but some architectures
|
||||
(e.g. sparc) needs to link with -latomic to be able to use it. So check
|
||||
if -latomic is needed and update numa.pc accordingly
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Retrieved from:
|
||||
https://github.com/numactl/numactl/commit/e0de0d9e981ddb53bdeb4a4b9dc43046c9ff4ff9]
|
||||
---
|
||||
Makefile.am | 1 +
|
||||
configure.ac | 2 ++
|
||||
numa.pc.in | 1 +
|
||||
3 files changed, 4 insertions(+)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 44d0d76..34f6815 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -151,6 +151,7 @@ SED_PROCESS = \
|
||||
-e 's,@exec_prefix\@,$(exec_prefix),g' \
|
||||
-e 's,@libdir\@,$(libdir),g' \
|
||||
-e 's,@includedir\@,$(includedir),g' \
|
||||
+ -e 's,@LIBS\@,$(LIBS),g' \
|
||||
< $< > $@ || rm $@
|
||||
|
||||
%.pc: %.pc.in Makefile
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 659a765..e3b0eb3 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -24,6 +24,8 @@ AM_CONDITIONAL([HAVE_TREE_VECTORIZE], [test x"${tree_vectorize}" = x"true"])
|
||||
|
||||
AC_CONFIG_FILES([Makefile])
|
||||
|
||||
+AC_SEARCH_LIBS([__atomic_fetch_and_1], [atomic])
|
||||
+
|
||||
# GCC tries to be "helpful" and only issue a warning for unrecognized
|
||||
# attributes. So we compile the test with Werror, so that if the
|
||||
# attribute is not recognized the compilation fails
|
||||
diff --git a/numa.pc.in b/numa.pc.in
|
||||
index 8a0f202..cc04d50 100644
|
||||
--- a/numa.pc.in
|
||||
+++ b/numa.pc.in
|
||||
@@ -8,3 +8,4 @@ Description: NUMA policy library
|
||||
Version: @VERSION@
|
||||
Cflags: -I${includedir}
|
||||
Libs: -L${libdir} -lnuma
|
||||
+Libs.Private: @LIBS@
|
@ -1,4 +1,4 @@
|
||||
# Locally calculated
|
||||
sha256 1ee27abd07ff6ba140aaf9bc6379b37825e54496e01d6f7343330cf1a4487035 numactl-2.0.14.tar.gz
|
||||
sha256 1b242f893af977a1d31af6ce9d6b8dafdd2d8ec3dc9207f7c2dc0d3446e7c7c8 numactl-2.0.16.tar.gz
|
||||
sha256 ab15fd526bd8dd18a9e77ebc139656bf4d33e97fc7238cd11bf60e2b9b8666c6 LICENSE.GPL2
|
||||
sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 LICENSE.LGPL2.1
|
||||
|
@ -4,12 +4,12 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
NUMACTL_VERSION = 2.0.14
|
||||
NUMACTL_SITE = $(call github,numactl,numactl,v$(NUMACTL_VERSION))
|
||||
NUMACTL_VERSION = 2.0.16
|
||||
NUMACTL_SITE = \
|
||||
https://github.com/numactl/numactl/releases/download/v$(NUMACTL_VERSION)
|
||||
NUMACTL_LICENSE = LGPL-2.1 (libnuma), GPL-2.0 (programs)
|
||||
NUMACTL_LICENSE_FILES = LICENSE.GPL2 LICENSE.LGPL2.1
|
||||
NUMACTL_INSTALL_STAGING = YES
|
||||
NUMACTL_AUTORECONF = YES
|
||||
NUMACTL_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -fPIC"
|
||||
|
||||
$(eval $(autotools-package))
|
||||
|
Loading…
Reference in New Issue
Block a user