rp-pppoe: bump to version 3.10, convert to gentargets, undeprecate.

Most of the work from Darcy Watkins <dwatkins@tranzeo.com>

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Gustavo Zacarias 2010-11-02 16:32:36 -03:00 committed by Peter Korsgaard
parent 7c949cb2a2
commit e9ae739ce7
7 changed files with 93 additions and 8797 deletions

View File

@ -41,9 +41,9 @@
mysql_client, nano, nbd, ncftp, neon, netperf, netsnmp,
ng-spice-rework, ntfsprogs, ntp, openntpd, openssh, openssl,
openvpn, oprofile, pango, patch, pcre, php, pkg-config,
portmap, pppd, prboom, radvd, rdesktop, readline, ruby, qt,
quagga, samba, sawman, sdl_mixer, sdl_sound, setserial,
shared-mime-info, speex, sqlite, squashfs,
portmap, pppd, pptp-linux, prboom, radvd, rdesktop, readline,
rp-pppoe, ruby, qt, quagga, samba, sawman, sdl_mixer, sdl_sound,
setserial, shared-mime-info, speex, sqlite, squashfs,
startup-notification, strace, sylpheed, taglib, tcpdump,
thttpd, tiff, tn5250, torsmo, udev, udpcast, usbmount,
usbutils, vsftpd, vtun, which, wpa_supplicant, xapp_twm,

View File

@ -1,7 +1,11 @@
config BR2_PACKAGE_RP_PPPOE
bool "pppoe"
depends on BR2_DEPRECATED
bool "rp-pppoe"
depends on BR2_PACKAGE_PPPD
help
An implementation of the Point-to-point protocol over Ethernet.
Has userspace client and server deamons. You likely only need
this package if you are implementing the pppoe server that will
service other pppoe client devices. Otherwise the normal client
functionality already exists in the pppd package (and kernel).
http://www.roaringpenguin.com/pppoe.html

View File

@ -0,0 +1,34 @@
--- rp-pppoe-3.10.orig/src/configure.in 2006-04-02 16:29:42.000000000 +0200
+++ rp-pppoe-3.10/src/configure.in 2007-08-24 11:51:04.000000000 +0200
@@ -231,6 +231,7 @@ esac
dnl Figure out packing order of structures
AC_MSG_CHECKING([packing order of bit fields])
+if test "x$rpppoe_cv_pack_bitfields" = "x" ; then
AC_TRY_RUN([
union foo {
struct bar {
@@ -254,8 +255,8 @@ main(void)
return 2;
}
}], rpppoe_cv_pack_bitfields=normal, rpppoe_cv_pack_bitfields=rev,
-$ECHO "no defaults for cross-compiling"; exit 0)
-
+$ECHO "no defaults for cross-compiling")
+fi
if test "$rpppoe_cv_pack_bitfields" = "rev" ; then
AC_MSG_RESULT(reversed)
AC_DEFINE(PACK_BITFIELDS_REVERSED)
--- rp-pppoe-3.10.orig/src/configure 2010-08-20 10:46:39.000000000 -0700
+++ rp-pppoe-3.10/src/configure 2010-08-20 11:02:16.000000000 -0700
@@ -6272,7 +6272,9 @@ esac
{ echo "$as_me:$LINENO: checking packing order of bit fields" >&5
echo $ECHO_N "checking packing order of bit fields... $ECHO_C" >&6; }
if test "$cross_compiling" = yes; then
- $ECHO "no defaults for cross-compiling"; exit 0
+if test "x$rpppoe_cv_pack_bitfields" = "x" ; then
+ $ECHO "no defaults for cross-compiling"
+fi
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */

View File

@ -0,0 +1,23 @@
--- rp-pppoe-3.10/src/configure.theorig 2008-02-05 13:57:15.000000000 -0800
+++ rp-pppoe-3.10/src/configure 2008-02-05 13:24:36.000000000 -0800
@@ -6151,7 +6151,7 @@ modprobe ppp_synctty > /dev/null 2>&1
modprobe pppoe > /dev/null 2>&1
fi
if test "$cross_compiling" = yes; then
- ac_cv_linux_kernel_pppoe=no; $ECHO "cross-compiling, default: "
+ ac_cv_linux_kernel_pppoe=yes; $ECHO "cross-compiling, default: "
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
--- rp-pppoe-3.10/src/pppoe-server.c.theorig 2006-04-02 07:29:42.000000000 -0700
+++ rp-pppoe-3.10/src/pppoe-server.c 2008-02-05 13:52:15.000000000 -0800
@@ -20,6 +20,9 @@ static char const RCSID[] =
#include "config.h"
+/* Patched hack to make this cross compile */
+#define HAVE_LINUX_KERNEL_PPPOE 1
+
#if defined(HAVE_NETPACKET_PACKET_H) || defined(HAVE_LINUX_IF_PACKET_H)
#define _POSIX_SOURCE 1 /* For sigaction defines */
#endif

View File

@ -1,22 +0,0 @@
diff -rdup rp-pppoe-3.8.oorig/src/configure.in rp-pppoe-3.8/src/configure.in
--- rp-pppoe-3.8.oorig/src/configure.in 2006-04-02 16:29:42.000000000 +0200
+++ rp-pppoe-3.8/src/configure.in 2007-08-24 11:51:04.000000000 +0200
@@ -221,6 +221,7 @@ esac
dnl Figure out packing order of structures
AC_MSG_CHECKING([packing order of bit fields])
+if test "x$rpppoe_cv_pack_bitfields" = "x" ; then
AC_TRY_RUN([
union foo {
struct bar {
@@ -244,8 +245,8 @@ main(void)
return 2;
}
}], rpppoe_cv_pack_bitfields=normal, rpppoe_cv_pack_bitfields=rev,
-$ECHO "no defaults for cross-compiling"; exit 0)
-
+$ECHO "no defaults for cross-compiling")
+fi
if test "$rpppoe_cv_pack_bitfields" = "rev" ; then
AC_MSG_RESULT(reversed)
AC_DEFINE(PACK_BITFIELDS_REVERSED)

File diff suppressed because it is too large Load Diff

View File

@ -3,78 +3,34 @@
# rp-pppoe
#
#############################################################
RP_PPPOE_VERSION:=3.8
RP_PPPOE_SOURCE:=rp-pppoe_$(RP_PPPOE_VERSION).orig.tar.gz
RP_PPPOE_PATCH:=rp-pppoe_$(RP_PPPOE_VERSION)-3.diff.gz
RP_PPPOE_SITE:=$(BR2_DEBIAN_MIRROR)/debian/pool/main/r/rp-pppoe
RP_PPPOE_TOPDIR:=$(BUILD_DIR)/rp-pppoe-$(RP_PPPOE_VERSION)
RP_PPPOE_DIR:=$(BUILD_DIR)/rp-pppoe-$(RP_PPPOE_VERSION)/src
RP_PPPOE_CAT:=$(ZCAT)
RP_PPPOE_BINARY:=pppoe
RP_PPPOE_TARGET_BINARY:=usr/sbin/pppoe
$(DL_DIR)/$(RP_PPPOE_SOURCE):
$(call DOWNLOAD,$(RP_PPPOE_SITE),$(RP_PPPOE_SOURCE))
ifneq ($(RP_PPPOE_PATCH),)
RP_PPPOE_PATCH_FILE:=$(DL_DIR)/$(RP_PPPOE_PATCH)
$(RP_PPPOE_PATCH_FILE):
$(call DOWNLOAD,$(RP_PPPOE_SITE),$(RP_PPPOE_PATCH))
endif
$(RP_PPPOE_TOPDIR)/.unpacked: $(DL_DIR)/$(RP_PPPOE_SOURCE) $(RP_PPPOE_PATCH_FILE)
$(RP_PPPOE_CAT) $(DL_DIR)/$(RP_PPPOE_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
ifneq ($(RP_PPPOE_PATCH),)
(cd $(RP_PPPOE_TOPDIR) && $(RP_PPPOE_CAT) $(DL_DIR)/$(RP_PPPOE_PATCH) | patch -p1)
if [ -d $(RP_PPPOE_TOPDIR)/debian/patches ]; then \
toolchain/patch-kernel.sh $(RP_PPPOE_TOPDIR) $(RP_PPPOE_TOPDIR)/debian/patches \*.patch; \
fi
endif
toolchain/patch-kernel.sh $(RP_PPPOE_TOPDIR) package/rp-pppoe/ rp-pppoe\*.patch
touch $@
$(RP_PPPOE_TOPDIR)/.configured: $(RP_PPPOE_TOPDIR)/.unpacked
(cd $(RP_PPPOE_DIR); rm -rf config.cache; \
$(TARGET_CONFIGURE_OPTS) \
$(TARGET_CONFIGURE_ARGS) \
RP_PPPOE_VERSION = 3.10
RP_PPPOE_SITE = http://www.roaringpenguin.com/files/download
RP_PPPOE_DEPENDENCIES = pppd
RP_PPPOE_SUBDIR = src
RP_PPPOE_TARGET_FILES = pppoe pppoe-server pppoe-relay pppoe-sniff
RP_PPPOE_MAKE_OPT = PLUGIN_DIR=/usr/lib/pppd/$(PPPD_VERSION)
RP_PPPOE_CONF_OPT = --disable-debugging
RP_PPPOE_CONF_ENV = \
rpppoe_cv_pack_bitfields=normal \
./configure $(QUIET) \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--prefix=/usr \
$(DISABLE_LARGEFILE) \
--disable-debugging \
)
touch $@
PPPD_H=$(PPPD_DIR)/pppd/pppd.h
$(RP_PPPOE_DIR)/$(RP_PPPOE_BINARY): $(RP_PPPOE_TOPDIR)/.configured
$(MAKE) -C $(RP_PPPOE_DIR)
define RP_PPPOE_INSTALL_TARGET_CMDS
for ff in $(RP_PPPOE_TARGET_FILES); do \
$(INSTALL) -m 0755 $(@D)/src/$$ff $(TARGET_DIR)/usr/sbin/$$ff; \
done
for ff in $(RP_PPPOE_TARGET_FILES); do \
$(INSTALL) -m 644 -D $(RP_PPPOE_DIR)/man/$$ff.8 $(TARGET_DIR)/usr/share/man/man8/$$ff.8; \
done
endef
$(TARGET_DIR)/$(RP_PPPOE_TARGET_BINARY): $(RP_PPPOE_DIR)/$(RP_PPPOE_BINARY)
cp -dpf $(RP_PPPOE_DIR)/$(RP_PPPOE_BINARY) $@
ifeq ($(BR2_HAVE_DOCUMENTATION),y)
mkdir -p $(TARGET_DIR)/usr/share/man/man8
$(INSTALL) -m 644 $(RP_PPPOE_TOPDIR)/man/pppoe.8 $(TARGET_DIR)/usr/share/man/man8/pppoe.8
endif
$(STRIPCMD) $(STRIP_STRIP_ALL) $@
define RP_PPPOE_UNINSTALL_TARGET_CMDS
for ff in $(RP_PPPOE_TARGET_FILES); do \
rm -f $(TARGET_DIR)/usr/sbin/$$ff; \
done
for ff in $(RP_PPPOE_TARGET_FILES); do \
rm -f $(TARGET_DIR)/usr/share/man/man8/$$ff.8; \
done
endef
rp-pppoe: $(TARGET_DIR)/$(RP_PPPOE_TARGET_BINARY)
rp-pppoe-source: $(DL_DIR)/$(RP_PPPOE_SOURCE) $(RP_PPPOE_PATCH_FILE)
rp-pppoe-clean:
-$(MAKE) -C $(RP_PPPOE_DIR) clean
rm -f $(TARGET_DIR)/$(RP_PPPOE_TARGET_BINARY) \
$(TARGET_DIR)/usr/share/man/man8/pppoe.8*
rp-pppoe-dirclean:
rm -rf $(RP_PPPOE_TOPDIR)
#############################################################
#
# Toplevel Makefile options
#
#############################################################
ifeq ($(BR2_PACKAGE_RP_PPPOE),y)
TARGETS+=rp-pppoe
endif
$(eval $(call AUTOTARGETS,package,rp-pppoe))