zstd: bump to version 1.3.5
Drop upstream patches. Cc: Andrey Smirnov <andrew.smirnov@gmail.com> Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
7cc269216d
commit
e8ea239d6d
@ -1,51 +0,0 @@
|
||||
From 2623a12bff19049b6ad5bc066e3ef9c6259d415c Mon Sep 17 00:00:00 2001
|
||||
From: Peter Seiderer <ps.report@gmx.net>
|
||||
Date: Mon, 16 Apr 2018 20:44:49 +0200
|
||||
Subject: [PATCH] Split library install target into pc, static, shared and
|
||||
include only target
|
||||
|
||||
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
||||
---
|
||||
lib/Makefile | 15 ++++++++++++---
|
||||
1 file changed, 12 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/lib/Makefile b/lib/Makefile
|
||||
index cdfdc5c..b592aa6 100644
|
||||
--- a/lib/Makefile
|
||||
+++ b/lib/Makefile
|
||||
@@ -159,20 +159,29 @@ libzstd.pc: libzstd.pc.in
|
||||
-e 's|@VERSION@|$(VERSION)|' \
|
||||
$< >$@
|
||||
|
||||
-install: libzstd.a libzstd libzstd.pc
|
||||
+install: install-pc install-static install-shared install-includes
|
||||
+ @echo zstd static and shared library installed
|
||||
+
|
||||
+install-pc: libzstd.pc
|
||||
@$(INSTALL) -d -m 755 $(DESTDIR)$(PKGCONFIGDIR)/ $(DESTDIR)$(INCLUDEDIR)/
|
||||
@$(INSTALL_DATA) libzstd.pc $(DESTDIR)$(PKGCONFIGDIR)/
|
||||
- @echo Installing libraries
|
||||
+
|
||||
+install-static: libzstd.a
|
||||
+ @echo Installing static library
|
||||
@$(INSTALL_DATA) libzstd.a $(DESTDIR)$(LIBDIR)
|
||||
+
|
||||
+install-shared: libzstd
|
||||
+ @echo Installing shared library
|
||||
@$(INSTALL_PROGRAM) $(LIBZSTD) $(DESTDIR)$(LIBDIR)
|
||||
@ln -sf $(LIBZSTD) $(DESTDIR)$(LIBDIR)/libzstd.$(SHARED_EXT_MAJOR)
|
||||
@ln -sf $(LIBZSTD) $(DESTDIR)$(LIBDIR)/libzstd.$(SHARED_EXT)
|
||||
+
|
||||
+install-includes:
|
||||
@echo Installing includes
|
||||
@$(INSTALL_DATA) zstd.h $(DESTDIR)$(INCLUDEDIR)
|
||||
@$(INSTALL_DATA) common/zstd_errors.h $(DESTDIR)$(INCLUDEDIR)
|
||||
@$(INSTALL_DATA) deprecated/zbuff.h $(DESTDIR)$(INCLUDEDIR) # prototypes generate deprecation warnings
|
||||
@$(INSTALL_DATA) dictBuilder/zdict.h $(DESTDIR)$(INCLUDEDIR)
|
||||
- @echo zstd static and shared library installed
|
||||
|
||||
uninstall:
|
||||
@$(RM) $(DESTDIR)$(LIBDIR)/libzstd.a
|
||||
--
|
||||
2.16.3
|
||||
|
@ -1,45 +0,0 @@
|
||||
From 9a0643b633c00e86db059e3790bdea7155fb6dc9 Mon Sep 17 00:00:00 2001
|
||||
From: Baruch Siach <baruch@tkos.co.il>
|
||||
Date: Tue, 8 May 2018 20:43:28 +0300
|
||||
Subject: [PATCH] lib/Makefile: create include directory before headers
|
||||
installation
|
||||
|
||||
Make sure that $(INCLUDEDIR) exists before copying the headers there.
|
||||
Otherwise, the contest of header files is copied over
|
||||
$(DESTDIR)$(INCLUDEDIR), making it a regular file.
|
||||
|
||||
While at it, remove $(DESTDIR)$(INCLUDEDIR) from the list of directories
|
||||
to create in the install-pc target. The install-pc target does not need
|
||||
this directory.
|
||||
|
||||
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
|
||||
---
|
||||
Upstream status: https://github.com/facebook/zstd/pull/1123
|
||||
|
||||
lib/Makefile | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/Makefile b/lib/Makefile
|
||||
index f64f192d4724..d8178c7a58a0 100644
|
||||
--- a/lib/Makefile
|
||||
+++ b/lib/Makefile
|
||||
@@ -163,7 +163,7 @@ install: install-pc install-static install-shared install-includes
|
||||
@echo zstd static and shared library installed
|
||||
|
||||
install-pc: libzstd.pc
|
||||
- @$(INSTALL) -d -m 755 $(DESTDIR)$(PKGCONFIGDIR)/ $(DESTDIR)$(INCLUDEDIR)/
|
||||
+ @$(INSTALL) -d -m 755 $(DESTDIR)$(PKGCONFIGDIR)/
|
||||
@$(INSTALL_DATA) libzstd.pc $(DESTDIR)$(PKGCONFIGDIR)/
|
||||
|
||||
install-static: libzstd.a
|
||||
@@ -178,6 +178,7 @@ install-shared: libzstd
|
||||
|
||||
install-includes:
|
||||
@echo Installing includes
|
||||
+ @$(INSTALL) -d -m 755 $(DESTDIR)$(INCLUDEDIR)/
|
||||
@$(INSTALL_DATA) zstd.h $(DESTDIR)$(INCLUDEDIR)
|
||||
@$(INSTALL_DATA) common/zstd_errors.h $(DESTDIR)$(INCLUDEDIR)
|
||||
@$(INSTALL_DATA) deprecated/zbuff.h $(DESTDIR)$(INCLUDEDIR) # prototypes generate deprecation warnings
|
||||
--
|
||||
2.17.0
|
||||
|
@ -1,5 +1,5 @@
|
||||
# Locally computed
|
||||
sha256 92e41b6e8dd26bbd46248e8aa1d86f1551bc221a796277ae9362954f26d605a9 zstd-v1.3.4.tar.gz
|
||||
sha256 d6e1559e4cdb7c4226767d4ddc990bff5f9aab77085ff0d0490c828b025e2eea zstd-v1.3.5.tar.gz
|
||||
|
||||
# License files (locally computed as well)
|
||||
sha256 2c1a7fa704df8f3a606f6fc010b8b5aaebf403f3aeec339a12048f1ba7331a0b LICENSE
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
ZSTD_VERSION = v1.3.4
|
||||
ZSTD_VERSION = v1.3.5
|
||||
ZSTD_SITE = $(call github,facebook,zstd,$(ZSTD_VERSION))
|
||||
ZSTD_INSTALL_STAGING = YES
|
||||
ZSTD_LICENSE = BSD-3-Clause or GPL-2.0
|
||||
|
Loading…
Reference in New Issue
Block a user