package/libuwsc: fix wolfssl build
Commit 1567fbd72d
didn't fully fix the
wolfssl build failure because the include on wolfssl/options.h was still
missing:
/home/autobuild/autobuild/instance-6/output-1/build/libuwsc-3.3.5/src/ssl.c:62:5: error: unknown type name 'SSL_CTX'
62 | SSL_CTX *ctx;
| ^~~~~~~
While at it, add upstream tag to patches
Fixes:
- http://autobuild.buildroot.org/results/edc49cce5b1f456d980841f4c315e7cd784b1561
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
b31b91296e
commit
e874fd08e0
@ -727,8 +727,6 @@ package/libuhttpd/0001-add-compatibility-for-wolfssl-5-0.patch Upstream
|
||||
package/libuio/0001-configure.ac-set-automake-strictness-to-foreign.patch Upstream
|
||||
package/liburcu/0001-Only-blacklist-ARM-gcc-4.8.0-and-4.8.1.patch Upstream
|
||||
package/libusbgx/0001-Add-include-of-sys-sysmacro.h.patch Upstream
|
||||
package/libuwsc/0001-CMakeLists.txt-add-BUILD_EXAMPLE.patch Upstream
|
||||
package/libuwsc/0002-fix-bad-indentation.patch Upstream
|
||||
package/libvpx/0001-vpx_mem-vpx_mem.h-Fix-compilation-with-uClibc.patch Upstream
|
||||
package/libwebsock/0001-Switch-to-use-pkg-config-to-detect-libevent-and-open.patch Upstream
|
||||
package/libwebsock/0002-fix-ssl.patch Upstream
|
||||
|
@ -6,7 +6,7 @@ Subject: [PATCH] CMakeLists.txt: add BUILD_EXAMPLE
|
||||
Allow the user to disable example
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[yann.morin.1998@free.fr: backport from upstream]
|
||||
Upstream: https://github.com/zhaojh329/libuwsc/commit/bb71b21eb9407479ad729b3c858b0fc350fae335
|
||||
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
|
||||
---
|
||||
CMakeLists.txt | 6 +++++-
|
||||
|
@ -5,8 +5,7 @@ Subject: [PATCH] fix bad indentation
|
||||
|
||||
Fixes error with GCC11.
|
||||
|
||||
[Retrieved from:
|
||||
https://github.com/zhaojh329/libuwsc/commit/8cb416140741a596235b8acc46b2b119b13ebfab]
|
||||
Upstream: https://github.com/zhaojh329/libuwsc/commit/8cb416140741a596235b8acc46b2b119b13ebfab
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
src/lua/uwsc_lua.c | 2 +-
|
||||
|
37
package/libuwsc/0003-src-ssl.c-fix-wolfssl-build.patch
Normal file
37
package/libuwsc/0003-src-ssl.c-fix-wolfssl-build.patch
Normal file
@ -0,0 +1,37 @@
|
||||
From 1c3579e99163a13d622c3ef44088c23d5eea306d Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Sun, 14 Jan 2024 16:44:13 +0100
|
||||
Subject: [PATCH] src/ssl.c: fix wolfssl build
|
||||
|
||||
wolfssl/options.h must also be included by clients to avoid the
|
||||
following build failure because OPENSSL_ALL won't be defined:
|
||||
|
||||
/home/autobuild/autobuild/instance-6/output-1/build/libuwsc-3.3.5/src/ssl.c:62:5: error: unknown type name 'SSL_CTX'
|
||||
62 | SSL_CTX *ctx;
|
||||
| ^~~~~~~
|
||||
|
||||
Fixes:
|
||||
- http://autobuild.buildroot.org/results/edc49cce5b1f456d980841f4c315e7cd784b1561
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Upstream: N/A (already fixed by
|
||||
https://github.com/zhaojh329/ssl/commit/c40ebcd7b4277321acbbd4b00b4b10fd363c7a97)
|
||||
---
|
||||
src/ssl.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/ssl.c b/src/ssl.c
|
||||
index 3640022..6a3d250 100644
|
||||
--- a/src/ssl.c
|
||||
+++ b/src/ssl.c
|
||||
@@ -54,6 +54,7 @@ struct uwsc_ssl_ctx {
|
||||
#include <openssl/err.h>
|
||||
#elif UWSC_HAVE_WOLFSSL
|
||||
#define WC_NO_HARDEN
|
||||
+#include <wolfssl/options.h>
|
||||
#include <wolfssl/openssl/ssl.h>
|
||||
#include <wolfssl/openssl/err.h>
|
||||
#endif
|
||||
--
|
||||
2.43.0
|
||||
|
Loading…
Reference in New Issue
Block a user