Merge branch 'e17' of git://git.free-electrons.com/users/thomas-petazzoni/buildroot

This commit is contained in:
Peter Korsgaard 2012-12-30 11:52:15 +01:00
commit e67a6cebcd
27 changed files with 251 additions and 121 deletions

View File

@ -151,6 +151,7 @@ source "package/liberation/Config.in"
source "package/libsexy/Config.in"
comment "X Window managers"
source "package/enlightenment/Config.in"
source "package/matchbox/Config.in"
source "package/metacity/Config.in"
source "package/blackbox/Config.in"

View File

@ -13,7 +13,9 @@ source "package/efl/libeina/Config.in"
source "package/efl/libecore/Config.in"
source "package/efl/libeet/Config.in"
source "package/efl/libefreet/Config.in"
source "package/efl/libeio/Config.in"
source "package/efl/libevas/Config.in"
source "package/efl/libevas-generic-loaders/Config.in"
source "package/efl/libembryo/Config.in"
source "package/efl/libedje/Config.in"
source "package/efl/libethumb/Config.in"

View File

@ -4,7 +4,7 @@
#
#############################################################
EXPEDITE_VERSION = 1.1.0
EXPEDITE_VERSION = 1.7.4
EXPEDITE_SITE = http://download.enlightenment.org/releases/
EXPEDITE_LICENSE = BSD-2c
EXPEDITE_LICENSE_FILES = COPYING

View File

@ -1,94 +0,0 @@
Backported for commit a0df6712b6afcd07facd32e5a66809170277bdf3
Fixed the ChangeLog part.
This patch fix build with glibc >=2.16, avoiding the following error occurs:
Making all in ecore
make[6]: Entering directory `/opt/buildroot/output/build/host-libecore-1.1.0/src/lib/ecore'
CC ecore.lo
CC ecore_anim.lo
CC ecore_app.lo
CC ecore_events.lo
CC ecore_getopt.lo
CC ecore_idle_enterer.lo
CC ecore_idle_exiter.lo
CC ecore_idler.lo
CC ecore_job.lo
CC ecore_main.lo
CC ecore_pipe.lo
CC ecore_poll.lo
CC ecore_time.lo
CC ecore_timer.lo
CC ecore_thread.lo
CC ecore_glib.lo
CC ecore_throttle.lo
CC ecore_signal.lo
CC ecore_exe.lo
ecore_exe.c: In function ecore_exe_pipe_run:
ecore_exe.c:486:15: warning: implicit declaration of function setpriority [-Wimplicit-function-declaration]
ecore_exe.c:486:27: error PRIO_PROCESS undeclared (first use in this function)
ecore_exe.c:486:27: note: each undeclared identifier is reported only once for each function it appears in
make[6]: *** [ecore_exe.lo] Error 1
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
---
From a0df6712b6afcd07facd32e5a66809170277bdf3 Mon Sep 17 00:00:00 2001
From: caro <caro>
Date: Fri, 22 Jun 2012 05:36:00 +0000
Subject: [PATCH] ecore_exe: fix compilation on fedora 18.
setpriority needs sys/resource.h. See:
http://linux.die.net/man/2/setpriority
I let sys/time.h, it does not hurt on linux and is anyway needed for BSD systems.
git-svn-id: http://svn.enlightenment.org/svn/e@72684 7cbeb6ba-43b4-40fd-8cce-4c39aea84d33
---
ChangeLog | 4 ++++
src/lib/ecore/ecore_exe.c | 7 ++-----
2 files changed, 6 insertions(+), 5 deletions(-)
diff --git a/ChangeLog b/ChangeLog
index a306f75..549ad19 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -763,3 +763,7 @@
2011-11-29 Mike McCormack
* Allow quitting before entering the glib version of the main loop
+
+2012-06-22 Vincent Torri
+
+ * ecore_exe: fix compilation on fedora 18.
diff --git a/src/lib/ecore/ecore_exe.c b/src/lib/ecore/ecore_exe.c
index 7931a96..6db32a9 100644
--- a/src/lib/ecore/ecore_exe.c
+++ b/src/lib/ecore/ecore_exe.c
@@ -2,11 +2,6 @@
# include <config.h>
#endif
-#if defined (__FreeBSD__) || defined (__OpenBSD__) || defined (__NetBSD__)
-# include <sys/time.h>
-# include <sys/resource.h>
-#endif
-
#include <stdlib.h>
#include <stdio.h>
#include <string.h>
@@ -14,6 +9,8 @@
#include <sys/types.h>
#include <unistd.h>
#include <fcntl.h>
+#include <sys/time.h>
+#include <sys/resource.h>
#ifdef HAVE_SYS_PRCTL_H
# include <sys/prctl.h>
--
1.7.12.2

View File

@ -4,7 +4,7 @@
#
#############################################################
LIBECORE_VERSION = 1.1.0
LIBECORE_VERSION = 1.7.4
LIBECORE_SOURCE = ecore-$(LIBECORE_VERSION).tar.bz2
LIBECORE_SITE = http://download.enlightenment.org/releases/
LIBECORE_LICENSE = BSD-2c

View File

@ -4,7 +4,7 @@
#
#############################################################
LIBEDBUS_VERSION = 1.1.0
LIBEDBUS_VERSION = 1.7.4
LIBEDBUS_SOURCE = e_dbus-$(LIBEDBUS_VERSION).tar.bz2
LIBEDBUS_SITE = http://download.enlightenment.org/releases/
LIBEDBUS_LICENSE = BSD-2c

View File

@ -4,7 +4,7 @@
#
#############################################################
LIBEDJE_VERSION = 1.1.0
LIBEDJE_VERSION = 1.7.4
LIBEDJE_SOURCE = edje-$(LIBEDJE_VERSION).tar.bz2
LIBEDJE_SITE = http://download.enlightenment.org/releases/
LIBEDJE_LICENSE = GPLv2+ (epp binary), BSD-2c (everything else)

View File

@ -4,7 +4,7 @@
#
#############################################################
LIBEET_VERSION = 1.5.0
LIBEET_VERSION = 1.7.4
LIBEET_SOURCE = eet-$(LIBEET_VERSION).tar.bz2
LIBEET_SITE = http://download.enlightenment.org/releases/
LIBEET_LICENSE = BSD-2c

View File

@ -4,7 +4,7 @@
#
################################################################################
LIBEFREET_VERSION = 1.1.0
LIBEFREET_VERSION = 1.7.4
LIBEFREET_SOURCE = efreet-$(LIBEFREET_VERSION).tar.bz2
LIBEFREET_SITE = http://download.enlightenment.org/releases/
LIBEFREET_LICENSE = BSD-2c

View File

@ -4,7 +4,7 @@
#
#############################################################
LIBEINA_VERSION = 1.1.0
LIBEINA_VERSION = 1.7.4
LIBEINA_SOURCE = eina-$(LIBEINA_VERSION).tar.bz2
LIBEINA_SITE = http://download.enlightenment.org/releases/
LIBEINA_LICENSE = LGPLv2.1+

View File

@ -0,0 +1,18 @@
config BR2_PACKAGE_LIBEIO
bool "libeio"
select BR2_PACKAGE_LIBEET
select BR2_PACKAGE_LIBEINA
select BR2_PACKAGE_LIBECORE
help
Eio integrates with EFL (Ecore, Eina) to provide efficient
filesystem Input/Output (I/O). It use the best techniques to
achieve such purpose, like using at-variants, splice,
properly handling errors and doing it in an asynchronous
fashion by means of worker threads. It is also ported to
Windows, so multi-platform.
Whenever you need to list a directory, copy, move or delete
files, Eio will do that task better than you'd achieve with
naive implementations, and it is easy to use.
http://trac.enlightenment.org/e/wiki/Eio

View File

@ -0,0 +1,16 @@
#############################################################
#
# libeio
#
#############################################################
LIBEIO_VERSION = 1.7.4
LIBEIO_SOURCE = eio-$(LIBEIO_VERSION).tar.bz2
LIBEIO_SITE = http://download.enlightenment.org/releases/
LIBEIO_LICENSE = LGPLv2.1
LIBEIO_LICENSE_FILES = COPYING
LIBEIO_INSTALL_STAGING = YES
LIBEIO_DEPENDENCIES = libeina libeet libecore
$(eval $(autotools-package))

View File

@ -4,9 +4,9 @@
#
################################################################################
LIBELEMENTARY_VERSION = 0.8.0.65643
LIBELEMENTARY_VERSION = 1.7.4
LIBELEMENTARY_SOURCE = elementary-$(LIBELEMENTARY_VERSION).tar.bz2
LIBELEMENTARY_SITE = http://download.enlightenment.org/snapshots/2011-11-28
LIBELEMENTARY_SITE = http://download.enlightenment.org/releases/
LIBELEMENTARY_LICENSE = LGPLv2.1
LIBELEMENTARY_LICENSE_FILES = COPYING

View File

@ -4,7 +4,7 @@
#
#############################################################
LIBEMBRYO_VERSION = 1.1.0
LIBEMBRYO_VERSION = 1.7.4
LIBEMBRYO_SOURCE = embryo-$(LIBEMBRYO_VERSION).tar.bz2
LIBEMBRYO_SITE = http://download.enlightenment.org/releases/
LIBEMBRYO_LICENSE = BSD-2c, Embryo license

View File

@ -4,9 +4,9 @@
#
################################################################################
LIBETHUMB_VERSION = 0.1.1.65643
LIBETHUMB_VERSION = 1.7.4
LIBETHUMB_SOURCE = ethumb-$(LIBETHUMB_VERSION).tar.bz2
LIBETHUMB_SITE = http://download.enlightenment.org/snapshots/2011-11-28
LIBETHUMB_SITE = http://download.enlightenment.org/releases/
LIBETHUMB_LICENSE = LGPLv2.1+
LIBETHUMB_LICENSE_FILES = COPYING

View File

@ -0,0 +1,21 @@
config BR2_PACKAGE_LIBEVAS_GENERIC_LOADERS
bool "libevas generic loaders"
select BR2_PACKAGE_LIBEINA
help
These are additional "generic" loaders for Evas that are
stand-alone executables that evas may run from its generic
loader module.
http://trac.enlightenment.org/e/wiki/Evas_Generic_Loaders
if BR2_PACKAGE_LIBEVAS_GENERIC_LOADERS
config BR2_PACKAGE_LIBEVAS_GENERIC_LOADERS_SVG
bool "SVG loader"
select BR2_PACKAGE_LIBRSVG
select BR2_PACKAGE_CAIRO
depends on BR2_USE_WCHAR # librsvg -> glib2
help
This option enables the Evas generic SVG loader
endif

View File

@ -0,0 +1,31 @@
#############################################################
#
# libevas-generic-loaders
#
#############################################################
LIBEVAS_GENERIC_LOADERS_VERSION = 1.7.4
LIBEVAS_GENERIC_LOADERS_SOURCE = evas_generic_loaders-$(LIBEVAS_GENERIC_LOADERS_VERSION).tar.bz2
LIBEVAS_GENERIC_LOADERS_SITE = http://download.enlightenment.org/releases/
LIBEVAS_GENERIC_LOADERS_LICENSE = GPLv2
LIBEVAS_GENERIC_LOADERS_LICENSE_FILES = COPYING
LIBEVAS_GENERIC_LOADERS_INSTALL_STAGING = YES
LIBEVAS_GENERIC_LOADERS_DEPENDENCIES = libeina
# For now, we only support the SVG loader
LIBEVAS_GENERIC_LOADERS_CONF_OPT += \
--disable-poppler \
--disable-spectre \
--disable-libraw \
--disable-gstreamer
ifeq ($(BR2_PACKAGE_LIBEVAS_GENERIC_LOADERS_SVG),y)
LIBEVAS_GENERIC_LOADERS_DEPENDENCIES += librsvg cairo
LIBEVAS_GENERIC_LOADERS_CONF_OPT += --enable-svg
else
LIBEVAS_GENERIC_LOADERS_CONF_OPT += --disable-svg
endif
$(eval $(autotools-package))

View File

@ -91,6 +91,7 @@ config BR2_PACKAGE_LIBEVAS_X11
bool "libevas X11 backend"
depends on BR2_PACKAGE_XORG7
select BR2_PACKAGE_XLIB_LIBX11
select BR2_PACKAGE_XLIB_LIBXEXT
help
This enables the software X11 rendering engine that renders
to X drawable targets using highly optimised software
@ -181,11 +182,6 @@ config BR2_PACKAGE_LIBEVAS_TIFF
help
This enables the loader code that loads tiff files.
config BR2_PACKAGE_LIBEVAS_SVG
bool "libevas svg loader"
help
This enables the loader code that loads svg files.
config BR2_PACKAGE_LIBEVAS_XPM
bool "libevas xpm loader"
help

View File

@ -4,7 +4,7 @@
#
#############################################################
LIBEVAS_VERSION = 1.1.0
LIBEVAS_VERSION = 1.7.4
LIBEVAS_SOURCE = evas-$(LIBEVAS_VERSION).tar.bz2
LIBEVAS_SITE = http://download.enlightenment.org/releases/
LIBEVAS_LICENSE = BSD-2c
@ -63,7 +63,7 @@ endif
ifeq ($(BR2_PACKAGE_LIBEVAS_X11),y)
LIBEVAS_CONF_OPT += --enable-software-xlib
LIBEVAS_DEPENDENCIES += xproto_xproto
LIBEVAS_DEPENDENCIES += xlib_libX11 xlib_libXext
endif
ifeq ($(BR2_PACKAGE_LIBEVAS_X11_GLX),y)
@ -176,12 +176,6 @@ else
LIBEVAS_CONF_OPT += --disable-image-loader-pmaps
endif
ifeq ($(BR2_PACKAGE_LIBEVAS_SVG),y)
LIBEVAS_CONF_OPT += --enable-image-loader-svg
else
LIBEVAS_CONF_OPT += --disable-image-loader-svg
endif
ifeq ($(BR2_PACKAGE_LIBEVAS_TIFF),y)
LIBEVAS_CONF_OPT += --enable-image-loader-tiff
LIBEVAS_DEPENDENCIES += tiff
@ -209,5 +203,13 @@ else
LIBEVAS_CONF_OPT += --disable-font-loader-eet
endif
# libevas installs the source code of examples on the target, which
# are generally not useful.
define LIBEVAS_REMOVE_EXAMPLES
rm -rf $(TARGET_DIR)/usr/share/evas/examples/
endef
LIBEVAS_POST_INSTALL_TARGET_HOOKS += LIBEVAS_REMOVE_EXAMPLES
$(eval $(autotools-package))
$(eval $(host-autotools-package))

View File

@ -0,0 +1,37 @@
config BR2_PACKAGE_ENLIGHTENMENT
bool "enlightenment"
select BR2_PACKAGE_LIBECORE
select BR2_PACKAGE_LIBECORE_X
select BR2_PACKAGE_LIBEINA
select BR2_PACKAGE_LIBEET
select BR2_PACKAGE_LIBEVAS
select BR2_PACKAGE_LIBEVAS_JPEG
select BR2_PACKAGE_LIBEVAS_PNG
select BR2_PACKAGE_LIBEVAS_EET
select BR2_PACKAGE_LIBECORE_EVAS
select BR2_PACKAGE_LIBEDJE
select BR2_PACKAGE_LIBEFREET
select BR2_PACKAGE_LIBEDBUS
select BR2_PACKAGE_LIBEIO
select BR2_PACKAGE_XCB_UTIL_KEYSYMS
select BR2_PACKAGE_LIBEVAS_GENERIC_LOADERS
select BR2_PACKAGE_LIBEVAS_GENERIC_LOADERS_SVG
# libevas-generic-loaders-svg -> librsvg -> glib2
depends on BR2_USE_WCHAR
# libedbus -> dbus
depends on BR2_TOOLCHAIN_HAS_THREADS
# libedbus -> dbus
depends on BR2_USE_MMU
depends on BR2_PACKAGE_XORG7
help
Enlightenment, also known simply as E, is a stacking window
manager for the X Window System which can be used alone or
in conjunction with a desktop environment such as GNOME or
KDE. Enlightenment can be used as a substitute for a full
desktop environment.
http://www.enlightenment.org/
comment "enlightenment requires WCHAR and thread support in toolchain"
depends on BR2_PACKAGE_XORG7
depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS

View File

@ -0,0 +1,27 @@
Do not include <execinfo.h> when not available
On uClibc, <execinfo.h> is not necessarily installed, depending on the
configuration. Enlightenment properly makes <execinfo.h> optional, but
uses __GLIBC__ to check if it is available or not. Unfortunately,
uClibc defines __GLIBC__, so it is not the right way to decide if
<execinfo.h> is available.
Instead, Enlightenment already has a configure.ac check for
execinfo.h, so we simply use the result of this configure.ac check to
decide whether execinfo.h is to be included or not.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/src/bin/e.h
===================================================================
--- a/src/bin/e.h
+++ b/src/bin/e.h
@@ -92,7 +92,7 @@
# include <memcheck.h>
# endif
-# ifdef __GLIBC__
+# ifdef HAVE_EXECINFO_H
# include <execinfo.h>
# endif

View File

@ -0,0 +1,40 @@
#############################################################
#
# enlightenment
#
#############################################################
ENLIGHTENMENT_VERSION = 0.17.0-omega
ENLIGHTENMENT_SITE = http://download.enlightenment.org/releases/
ENLIGHTENMENT_LICENSE = BSD-2c
ENLIGHTENMENT_LICENSE_FILES = COPYING
ENLIGHTENMENT_DEPENDENCIES = \
host-pkgconf \
libecore \
libeet \
libeina \
libevas \
libevas-generic-loaders \
libedje \
libefreet \
libedbus \
libeio \
host-libedje \
host-libeet \
xcb-util-keysyms
ENLIGHTENMENT_CONF_OPT = --with-edje-cc=$(HOST_DIR)/usr/bin/edje_cc \
--with-eet-eet=$(HOST_DIR)/usr/bin/eet \
--disable-rpath
ifeq ($(BR2_HAVE_DOCUMENTATION),)
define ENLIGHTENMENT_REMOVE_DOCUMENTATION
rm -rf $(TARGET_DIR)/usr/share/enlightenment/doc/
rm -f $(TARGET_DIR)/usr/share/enlightenment/COPYING
rm -f $(TARGET_DIR)/usr/share/enlightenment/AUTHORS
endef
ENLIGHTENMENT_POST_INSTALL_TARGET_HOOKS += ENLIGHTENMENT_REMOVE_DOCUMENTATION
endif
$(eval $(autotools-package))

View File

@ -5,7 +5,7 @@ config BR2_PACKAGE_LIBRSVG
select BR2_PACKAGE_CAIRO_PNG
select BR2_PACKAGE_PANGO
select BR2_PACKAGE_LIBGLIB2
depends on BR2_PACKAGE_LIBGTK2
select BR2_PACKAGE_GDK_PIXBUF
depends on BR2_USE_WCHAR # glib2
help
The rsvg library is an efficient renderer for Scalable

View File

@ -11,6 +11,12 @@ LIBRSVG_SOURCE:=librsvg-$(LIBRSVG_VERSION).tar.gz
LIBRSVG_SITE:=http://ftp.gnome.org/pub/GNOME/sources/librsvg/$(LIBRSVG_VERSION_MAJOR)/
LIBRSVG_INSTALL_STAGING = YES
LIBRSVG_CONF_OPT = --disable-tools
LIBRSVG_DEPENDENCIES = libxml2 cairo pango libglib2 libgtk2
LIBRSVG_DEPENDENCIES = libxml2 cairo pango libglib2 gdk-pixbuf
# If we have Gtk2, let's build it first to benefit from librsvg Gtk
# support.
ifeq ($(BR2_PACKAGE_LIBGTK2),y)
LIBRSVG_DEPENDENCIES += libgtk2
endif
$(eval $(autotools-package))

View File

@ -39,6 +39,7 @@ endmenu
source package/x11r7/mesa3d/Config.in
source package/x11r7/pthread-stubs/Config.in
source package/x11r7/xcb-util/Config.in
source package/x11r7/xcb-util-keysyms/Config.in
source package/x11r7/xlib_libFS/Config.in
source package/x11r7/xlib_libICE/Config.in
source package/x11r7/xlib_libSM/Config.in

View File

@ -0,0 +1,14 @@
config BR2_PACKAGE_XCB_UTIL_KEYSYMS
bool "xcb-util-keysyms"
help
The XCB util modules provides a number of libraries which sit on top
of libxcb, the core X protocol library, and some of the extension
libraries. These experimental libraries provide convenience functions
and interfaces which make the raw X protocol more usable. Some of the
libraries also provide client-side code which is not strictly part of
the X protocol but which have traditionally been provided by Xlib.
XCB util-keysyms module provides the following library: keysyms:
Standard X key constants and conversion to/from keycodes.
http://xcb.freedesktop.org/

View File

@ -0,0 +1,12 @@
#############################################################
#
# xcb-util-keysyms
#
#############################################################
XCB_UTIL_KEYSYMS_VERSION = 0.3.9
XCB_UTIL_KEYSYMS_SOURCE = xcb-util-keysyms-$(XCB_UTIL_KEYSYMS_VERSION).tar.bz2
XCB_UTIL_KEYSYMS_SITE = http://xcb.freedesktop.org/dist/
XCB_UTIL_KEYSYMS_INSTALL_STAGING = YES
$(eval $(autotools-package))