package/grantlee: bump to 5.2.0, use github upstream, remove obsolete patch
Signed-off-by: Zoltan Gyarmati <zgyarmati@zgyarmati.de> [yann.morin.1998@free.fr: two spaces in hash file] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
parent
40b4d243f7
commit
e64ba18060
@ -1,27 +0,0 @@
|
||||
From c989fcf192d01d26866faf6405a28ba4fdce64c3 Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Kelly <steveire@gmail.com>
|
||||
Date: Sun, 21 Jul 2019 16:00:41 +0100
|
||||
Subject: [PATCH] Remove vestigial -ansi flag
|
||||
|
||||
This causes the compiler to not operate in C++11 mode, meaning that
|
||||
headers such as <type_traits> issue errors.
|
||||
[Retrieved from:
|
||||
https://github.com/steveire/grantlee/commit/c989fcf192d01d26866faf6405a28ba4fdce64c3]
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 6d51110..9172213 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -59,7 +59,7 @@ endif()
|
||||
|
||||
if (CMAKE_COMPILER_IS_GNUCXX)
|
||||
set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align -Werror-implicit-function-declaration -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-common")
|
||||
- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-check-new -fno-common ")
|
||||
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Wno-long-long -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-check-new -fno-common ")
|
||||
|
||||
if (CMAKE_BUILD_TYPE MATCHES TestCocoon)
|
||||
# Needed on 64 bit
|
@ -1,5 +1,5 @@
|
||||
# Locally calculated after checking pgp signature
|
||||
sha256 ea2e402466c74bb533eee2c7252209ec61cd93a5d236fecd625b4a0eb13a1478 grantlee-5.1.0.tar.gz
|
||||
# Locally calculated
|
||||
sha256 139acee5746b957bdf1327ec0d97c604d4c0b9be42aec5d584297cb5ed6a990a grantlee-5.2.0.tar.gz
|
||||
|
||||
# Hash for license file
|
||||
sha256 a9bdde5616ecdd1e980b44f360600ee8783b1f99b8cc83a2beb163a0a390e861 COPYING.LIB
|
||||
sha256 a9bdde5616ecdd1e980b44f360600ee8783b1f99b8cc83a2beb163a0a390e861 COPYING.LIB
|
||||
|
@ -4,8 +4,8 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
GRANTLEE_VERSION = 5.1.0
|
||||
GRANTLEE_SITE = http://downloads.grantlee.org
|
||||
GRANTLEE_VERSION = 5.2.0
|
||||
GRANTLEE_SITE = $(call github,steveire,grantlee,v$(GRANTLEE_VERSION))
|
||||
GRANTLEE_INSTALL_STAGING = YES
|
||||
GRANTLEE_LICENSE = LGPL-2.1+
|
||||
GRANTLEE_LICENSE_FILES = COPYING.LIB
|
||||
|
Loading…
Reference in New Issue
Block a user