diff --git a/CHANGES b/CHANGES index 010aa5a1dc..cf764e86db 100644 --- a/CHANGES +++ b/CHANGES @@ -10,6 +10,8 @@ removed mandatory dependency on useless libraries such as libXt or libXaw. + New QT-based configurator, usable using 'make xconfig'. + Issues resolved (http://bugs.uclibc.org): #83: liblockfile fails to compile due to eaccess redefinition diff --git a/Makefile b/Makefile index e61f995b95..182853ce9c 100644 --- a/Makefile +++ b/Makefile @@ -561,6 +561,7 @@ help: @echo @echo 'Configuration:' @echo ' menuconfig - interactive curses-based configurator' + @echo ' xconfig - interactive Qt-based configurator' @echo ' oldconfig - resolve any unresolved symbols in .config' @echo ' configured - make {uclibc/busybox/linux26}-config' @echo ' saveconfig - save current configuration under local/' diff --git a/docs/buildroot.html b/docs/buildroot.html index b49208c273..8cd705df44 100644 --- a/docs/buildroot.html +++ b/docs/buildroot.html @@ -155,6 +155,17 @@ $ make menuconfig +

to run the curses-based configurator, or

+ +
+ $ make xconfig
+
+ +

to run the Qt3-based configurator. On Debian-like systems, the + libncurses5-dev package is required to use the + menuconfig interface, and the libqt3-mt-dev is + required to use the xconfig interface.

+

For each entry of the configuration tool, you can find associated help that describes the purpose of the entry.

@@ -219,9 +230,9 @@

Offline builds

-

If you intend to do an offline-build and just want to download all - sources that you previously selected in "make menuconfig" then - issue:

+

If you intend to do an offline-build and just want to download + all sources that you previously selected in the configurator + (menuconfig or xconfig) then issue:

  $ make source
 
@@ -340,9 +351,10 @@ $ make me<TAB> is made. So simply rebuilding the image by running make should propagate any new changes to the image. -
  • When configuring the build system, using make menuconfig, - you can specify the contents of the /etc/hostname and /etc/issue - (the welcome banner) in the PROJECT section
  • +
  • When configuring the build system, using make + menuconfig or make xconfig, you can specify + the contents of the /etc/hostname and /etc/issue (the welcome + banner) in the PROJECT section
  • Customizing the