package/openocd: fix uclinux build

Fixes
http://autobuild.buildroot.net/results/cd3/cd3f5b7329f45c2b75ed319caef3c6aa0e94ee2e/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Bernd Kuhls 2017-08-17 06:37:39 +02:00 committed by Thomas Petazzoni
parent eb7e07702c
commit e5e4d4710e
2 changed files with 28 additions and 1 deletions

View File

@ -0,0 +1,26 @@
From 11ea78c4d253bb90296e2dd8c3f7fbf59ba397b6 Mon Sep 17 00:00:00 2001
From: Bernd Kuhls <bernd.kuhls@t-online.de>
Date: Thu, 17 Aug 2017 06:30:31 +0200
Subject: [PATCH] configure: enable build on uclinux
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index c680bda7..1a7980a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -327,7 +327,7 @@ AC_ARG_ENABLE([sysfsgpio],
[build_sysfsgpio=$enableval], [build_sysfsgpio=no])
AS_CASE([$host_os],
- [linux*], [],
+ [linux*|uclinux*], [],
[
AS_IF([test "x$build_sysfsgpio" = "xyes"], [
AC_MSG_ERROR([sysfsgpio is only available on linux])
--
2.11.0

View File

@ -7,7 +7,8 @@
OPENOCD_VERSION = 0.10.0
OPENOCD_SOURCE = openocd-$(OPENOCD_VERSION).tar.bz2
OPENOCD_SITE = http://sourceforge.net/projects/openocd/files/openocd/$(OPENOCD_VERSION)
# 0002-configure-enable-build-on-uclinux.patch patches configure.ac
OPENOCD_AUTORECONF = YES
OPENOCD_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -std=gnu99"
OPENOCD_CONF_OPTS = \