package/postgresql: fix pkg-config without openssl
Fix the following build failure with libdbi-drivers raised since bump to
version 14.1 in commit c9bd029115
and
https://git.postgresql.org/gitweb/?p=postgresql.git;a=commit;h=beff361bc1edc24ee5f8b2073a1e5e4c92ea66eb:
configure: error: Package requirements (libpq) were not met:
Package 'libssl', required by 'libpq', not found
Package 'libcrypto', required by 'libpq', not found
Fixes:
- http://autobuild.buildroot.org/results/415cb61a58b928a42623ed90b0b60c59032f0a4e
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
e4b62f6308
commit
e3b8d098e4
@ -0,0 +1,34 @@
|
||||
From 465ab24296c27502c81c8c197725cba728b9b057 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Eisentraut <peter@eisentraut.org>
|
||||
Date: Fri, 1 Apr 2022 17:12:56 +0200
|
||||
Subject: [PATCH] libpq: Fix pkg-config without OpenSSL
|
||||
|
||||
Do not add OpenSSL dependencies to libpq pkg-config file if OpenSSL is
|
||||
not enabled. Oversight in beff361bc1edc24ee5f8b2073a1e5e4c92ea66eb.
|
||||
|
||||
Author: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Discussion: https://www.postgresql.org/message-id/flat/20220331163759.32665-1-fontaine.fabrice%40gmail.com
|
||||
[Retrieved from:
|
||||
https://git.postgresql.org/gitweb/?p=postgresql.git;a=commit;h=465ab24296c27502c81c8c197725cba728b9b057]
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
src/interfaces/libpq/Makefile | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/interfaces/libpq/Makefile b/src/interfaces/libpq/Makefile
|
||||
index 89bf5e0126..b5fd72a4ac 100644
|
||||
--- a/src/interfaces/libpq/Makefile
|
||||
+++ b/src/interfaces/libpq/Makefile
|
||||
@@ -95,7 +95,9 @@ SHLIB_PREREQS = submake-libpgport
|
||||
|
||||
SHLIB_EXPORTS = exports.txt
|
||||
|
||||
+ifeq ($(with_ssl),openssl)
|
||||
PKG_CONFIG_REQUIRES_PRIVATE = libssl libcrypto
|
||||
+endif
|
||||
|
||||
all: all-lib libpq-refs-stamp
|
||||
|
||||
--
|
||||
2.30.2
|
||||
|
Loading…
Reference in New Issue
Block a user