From e3556c886203636c2339c439ddfda0c0207798cd Mon Sep 17 00:00:00 2001
From: Peter Korsgaard <jacmet@sunsite.dk>
Date: Tue, 16 Sep 2008 20:53:45 +0000
Subject: [PATCH] Makefile: support relative paths for out of tree builds

And complain if the output directory cannot be created.
---
 project/Makefile.in | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/project/Makefile.in b/project/Makefile.in
index 034b1fa6c9..6aa1d43e92 100644
--- a/project/Makefile.in
+++ b/project/Makefile.in
@@ -30,7 +30,8 @@ TAR_OPTIONS=$(subst ",, $(BR2_TAR_OPTIONS)) -xf
 BASE_DIR:=$(shell pwd)
 ifdef O
 ifeq ("$(origin O)", "command line")
-BASE_DIR := $(O)
+BASE_DIR := $(shell mkdir -p $(O) && cd $(O) && pwd)
+$(if $(BASE_DIR),, $(error output directory "$(O)" does not exist))
 endif
 endif