perl: remove useless hacks
Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
fad24172f1
commit
dfb40e9446
@ -1,8 +1,6 @@
|
||||
config BR2_PACKAGE_PERL_GD
|
||||
bool "perl-gd"
|
||||
depends on !BR2_PREFER_STATIC_LIB
|
||||
# Does not build on machines having a old host perl
|
||||
depends on BR2_BROKEN
|
||||
select BR2_PACKAGE_ZLIB
|
||||
select BR2_PACKAGE_LIBPNG
|
||||
select BR2_PACKAGE_FREETYPE
|
||||
|
@ -1,7 +1,6 @@
|
||||
config BR2_PACKAGE_PERL_GDGRAPH
|
||||
bool "perl-gdgraph"
|
||||
depends on !BR2_PREFER_STATIC_LIB
|
||||
depends on BR2_BROKEN # perl-gd
|
||||
select BR2_PACKAGE_PERL_GD
|
||||
select BR2_PACKAGE_PERL_GDTEXTUTIL
|
||||
help
|
||||
|
@ -1,24 +0,0 @@
|
||||
partial revert to 1.47 in order to work with an old perl 5.10.1
|
||||
|
||||
With old ExtUtils::MakeMaker, AUTHOR takes a string/number not a ARRAY reference.
|
||||
See http://api.metacpan.org/source/RUZ/GDGraph-1.48/CHANGES
|
||||
|
||||
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
|
||||
|
||||
Index: b/Makefile.PL
|
||||
===================================================================
|
||||
--- a/Makefile.PL
|
||||
+++ b/Makefile.PL
|
||||
@@ -19,11 +19,7 @@
|
||||
|
||||
($] >= 5.005 ?
|
||||
('ABSTRACT' => 'Produces charts with GD',
|
||||
- 'AUTHOR' => [
|
||||
- 'Martien Verbruggen <mgjv@tradingpost.com.au>',
|
||||
- 'Benjamin Warfield <bwarfield@cpan.org>',
|
||||
- 'Ruslan Zakirov <Ruslan.Zakirov@gmail.com>',
|
||||
- ]
|
||||
+ 'AUTHOR' => 'Martien Verbruggen <mgjv@tradingpost.com.au>',
|
||||
):()
|
||||
),
|
||||
|
@ -100,32 +100,6 @@ define PERL_INSTALL_TARGET_CMDS
|
||||
$(MAKE1) -C $(@D) DESTDIR="$(TARGET_DIR)" install.perl
|
||||
endef
|
||||
|
||||
# perl infra: fix for Perl XS packages configured by Makefile.PL
|
||||
#
|
||||
# ExtUtils::MakeMaker adds all the header files used by the perl as
|
||||
# dependencies to the generated Makefile. This means that the generated
|
||||
# Makefile will depend on the system's header files.
|
||||
#
|
||||
# Usually this is not a problem, because when building the target package,
|
||||
# these header files will indeed be found in $(STAGING_DIR). However, some
|
||||
# distro's add an extra header file to the system's perl. This header is
|
||||
# also included in the generated Makefile, which makes the build fail
|
||||
# because it doesn't exist in $(STAGING_DIR).
|
||||
#
|
||||
# As a work-around, explicitly create this header file in $(STAGING_DIR).
|
||||
# It doesn't hurt to create it even if the system perl doesn't need it.
|
||||
#
|
||||
define PERL_ADD_CORE_H
|
||||
touch $(STAGING_DIR)/usr/lib/perl5/$(PERL_VERSION)/$(PERL_ARCHNAME)/CORE/patchlevel-debian.h
|
||||
touch $(STAGING_DIR)/usr/lib/perl5/$(PERL_VERSION)/$(PERL_ARCHNAME)/CORE/patchlevel-gentoo.h
|
||||
touch $(STAGING_DIR)/usr/lib/perl5/$(PERL_VERSION)/$(PERL_ARCHNAME)/CORE/cc_runtime.h
|
||||
touch $(STAGING_DIR)/usr/lib/perl5/$(PERL_VERSION)/$(PERL_ARCHNAME)/CORE/fakethr.h
|
||||
touch $(STAGING_DIR)/usr/lib/perl5/$(PERL_VERSION)/$(PERL_ARCHNAME)/CORE/perlsfio.h
|
||||
touch $(STAGING_DIR)/usr/lib/perl5/$(PERL_VERSION)/$(PERL_ARCHNAME)/CORE/vutil.h
|
||||
endef
|
||||
|
||||
PERL_POST_INSTALL_STAGING_HOOKS += PERL_ADD_CORE_H
|
||||
|
||||
HOST_PERL_CONF_OPTS = \
|
||||
-des \
|
||||
-Dprefix="$(HOST_DIR)/usr" \
|
||||
|
Loading…
Reference in New Issue
Block a user