diff --git a/target/Makefile.in b/target/Makefile.in
index 7ec139db98..d00442d10a 100644
--- a/target/Makefile.in
+++ b/target/Makefile.in
@@ -1,13 +1,15 @@
 # make sure to put everything that is board-specific before the tarroot targets
 include target/generic/Makefile.in
+
+# this eventually adds the kernel target to TARGETS:
 include target/device/Makefile.in
 include target/x86/Makefile.in
 include target/arm/Makefile.in
 include target/powerpc/Makefile.in
 # and finally build the filesystems/tarballs
 include target/*/*.mk
+
 # kernel rules
-ifeq ($(BR2_PACKAGE_LINUX),y)
-TARGETS+=linux26
-endif
+# We already did add the kernel target to TARGETS and now just pull in the rules
+# to actually build this target.
 include target/linux*.mk
diff --git a/target/device/Makefile.in b/target/device/Makefile.in
index c2d04a97a9..be23fc7bb1 100644
--- a/target/device/Makefile.in
+++ b/target/device/Makefile.in
@@ -1,3 +1,8 @@
 TARGET_DEVICE_DEPMOD:=target/device/x86/depmod.pl
 
 -include target/device/*/Makefile.in
+
+ifeq ($(BR2_PACKAGE_LINUX),y)
+TARGETS+=linux26
+endif
+