kompexsqlite: new package
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
d54751e2d4
commit
ddfd700a02
@ -768,6 +768,7 @@ menu "Database"
|
||||
source "package/berkeleydb/Config.in"
|
||||
source "package/cppdb/Config.in"
|
||||
source "package/gdbm/Config.in"
|
||||
source "package/kompexsqlite/Config.in"
|
||||
source "package/leveldb/Config.in"
|
||||
source "package/mysql/Config.in"
|
||||
source "package/postgresql/Config.in"
|
||||
|
@ -0,0 +1,27 @@
|
||||
From 769693d9ddf63b04dd4aad6cad080f3cee3f997e Mon Sep 17 00:00:00 2001
|
||||
From: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||
Date: Thu, 11 Jun 2015 14:08:38 -0300
|
||||
Subject: [PATCH] Makefile: use autoconf CXX for proper builds
|
||||
|
||||
Status: applied upstream.
|
||||
|
||||
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||
---
|
||||
Makefile.in | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/Makefile.in b/Makefile.in
|
||||
index 91fb8b2..fe862cd 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -23,6 +23,7 @@ mandir = $(prefix)/share/man/man3
|
||||
headerdir = $(prefix)/include/kompex
|
||||
|
||||
CC = @CC@
|
||||
+CXX = @CXX@
|
||||
CFLAGS = @CFLAGS@
|
||||
CPPFLAGS = $(CFLAGS) @CPPFLAGS@
|
||||
LDFLAGS = @LDFLAGS@
|
||||
--
|
||||
2.3.6
|
||||
|
12
package/kompexsqlite/Config.in
Normal file
12
package/kompexsqlite/Config.in
Normal file
@ -0,0 +1,12 @@
|
||||
config BR2_PACKAGE_KOMPEXSQLITE
|
||||
bool "kompexsqlite"
|
||||
depends on BR2_INSTALL_LIBSTDCPP
|
||||
depends on !BR2_STATIC_LIBS
|
||||
help
|
||||
The Kompex SQLite Wrapper is an open source C++ wrapper
|
||||
library for SQLite.
|
||||
|
||||
http://sqlitewrapper.kompex-online.com/index.php
|
||||
|
||||
comment "kompexsqlite needs a toolchain w/ C++, dynamic library"
|
||||
depends on !BR2_INSTALL_LIBSTDCPP || BR2_STATIC_LIBS
|
2
package/kompexsqlite/kompexsqlite.hash
Normal file
2
package/kompexsqlite/kompexsqlite.hash
Normal file
@ -0,0 +1,2 @@
|
||||
# Locally calculated
|
||||
sha256 73bec94fe5dd3a24bd8668b3a131a84dbe39a992579eebab1236aa0e73b2c9cc v1.10.12-1.tar.gz
|
14
package/kompexsqlite/kompexsqlite.mk
Normal file
14
package/kompexsqlite/kompexsqlite.mk
Normal file
@ -0,0 +1,14 @@
|
||||
################################################################################
|
||||
#
|
||||
# kompexsqlite
|
||||
#
|
||||
################################################################################
|
||||
|
||||
KOMPEXSQLITE_VERSION = v1.10.12-1
|
||||
KOMPEXSQLITE_SOURCE = $(KOMPEXSQLITE_VERSION).tar.gz
|
||||
KOMPEXSQLITE_SITE = https://github.com/Aethelflaed/kompex-sqlite-wrapper/archive
|
||||
KOMPEXSQLITE_INSTALL_STAGING = YES
|
||||
KOMPEXSQLITE_LICENSE = LGPLv3+ (wrapper), Public Domain (bundled sqlite)
|
||||
KOMPEXSQLITE_LICENSE_FILES = LICENSE.txt
|
||||
|
||||
$(eval $(autotools-package))
|
Loading…
Reference in New Issue
Block a user