uclibc: add locale/iconv related bugfixes

- do not remove iconv.h when UCLIBC_HAS_LOCALE enabled
- select UCLIBC_HAS_LIBICONV when UCLIBC_HAS_LOCALE enabled

Fixes:
   http://autobuild.buildroot.net/?reason=libglib2-2.50.2&step=250

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Waldemar Brodkorb 2016-12-29 17:21:40 +01:00 committed by Peter Korsgaard
parent c78f24301c
commit dcef07e652
2 changed files with 51 additions and 0 deletions

View File

@ -0,0 +1,26 @@
From 0d80d5a235af1a12b606dea6380dc91f755546fe Mon Sep 17 00:00:00 2001
From: Waldemar Brodkorb <wbx@openadk.org>
Date: Wed, 28 Dec 2016 19:08:15 +0100
Subject: [PATCH] do not remove iconv.h when UCLIBC_HAS_LOCALE is not set
Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
---
Makefile.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile.in b/Makefile.in
index 9acf76c..c8afe1c 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -282,7 +282,7 @@ HEADERS_RM-$(UCLIBC_HAS_IPV6) += netinet/ip6.h netinet/icmp6.h
HEADERS_RM-$(UCLIBC_HAS_BACKTRACE) += execinfo.h
HEADERS_RM-$(UCLIBC_HAS_LIBICONV) += iconv.h
HEADERS_RM-$(UCLIBC_HAS_LIBINTL) += intl.h
-HEADERS_RM-$(UCLIBC_HAS_LOCALE) += iconv.h bits/uClibc_ctype.h
+HEADERS_RM-$(UCLIBC_HAS_LOCALE) += bits/uClibc_ctype.h
HEADERS_RM-$(UCLIBC_HAS_PTY) += pty.h
HEADERS_RM-$(UCLIBC_HAS_REALTIME) += mqueue.h bits/mqueue.h sched.h \
bits/sched.h \
--
2.1.4

View File

@ -0,0 +1,25 @@
From a2c56ee4fbff7af9128d630299d81fb46582673d Mon Sep 17 00:00:00 2001
From: Waldemar Brodkorb <wbx@openadk.org>
Date: Thu, 29 Dec 2016 13:38:09 +0100
Subject: [PATCH] locale: needs libiconv
Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
---
extra/Configs/Config.in | 1 +
1 file changed, 1 insertion(+)
diff --git a/extra/Configs/Config.in b/extra/Configs/Config.in
index 6b0985e..b02054c 100644
--- a/extra/Configs/Config.in
+++ b/extra/Configs/Config.in
@@ -1442,6 +1442,7 @@ config UCLIBC_HAS_LOCALE
bool "Locale Support"
select UCLIBC_HAS_WCHAR
select UCLIBC_HAS_CTYPE_TABLES
+ select UCLIBC_HAS_LIBICONV
help
uClibc now has full ANSI/ISO C99 locale support (except for
wcsftime() and collating items in regex). Be aware that enabling
--
2.1.4