lttng-libust: new package
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
16891da22d
commit
dc77b0824e
@ -378,6 +378,7 @@ source "package/libical/Config.in"
|
||||
source "package/libnspr/Config.in"
|
||||
source "package/libsigc/Config.in"
|
||||
source "package/liburcu/Config.in"
|
||||
source "package/lttng-libust/Config.in"
|
||||
source "package/orc/Config.in"
|
||||
source "package/poco/Config.in"
|
||||
source "package/startup-notification/Config.in"
|
||||
|
10
package/lttng-libust/Config.in
Normal file
10
package/lttng-libust/Config.in
Normal file
@ -0,0 +1,10 @@
|
||||
config BR2_PACKAGE_LTTNG_LIBUST
|
||||
bool "lttng-libust"
|
||||
select BR2_PACKAGE_LIBURCU
|
||||
help
|
||||
Userspace tracing library for the Lttng tracing
|
||||
infrastructure. It allows userspace programs to create
|
||||
custom trace events that are integrated with all other
|
||||
events gathered by LTTng.
|
||||
|
||||
http://lttng.org
|
26
package/lttng-libust/lttng-libust-fix-overflow-32-bits.patch
Normal file
26
package/lttng-libust/lttng-libust-fix-overflow-32-bits.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From dc190cc1f8ddccfa7b0b8323ed157afb29a0ebb7 Mon Sep 17 00:00:00 2001
|
||||
From: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
|
||||
Date: Wed, 21 Dec 2011 16:24:48 -0500
|
||||
Subject: [PATCH] Fix clock source overflow on 32-bit archs
|
||||
|
||||
Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
|
||||
---
|
||||
liblttng-ust/clock.h | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/liblttng-ust/clock.h b/liblttng-ust/clock.h
|
||||
index b5d3e77..23294d2 100644
|
||||
--- a/liblttng-ust/clock.h
|
||||
+++ b/liblttng-ust/clock.h
|
||||
@@ -39,7 +39,7 @@ static __inline__ uint64_t trace_clock_read64(void)
|
||||
struct timespec ts;
|
||||
|
||||
clock_gettime(CLOCK_MONOTONIC, &ts);
|
||||
- return (ts.tv_sec * 1000000000) + ts.tv_nsec;
|
||||
+ return ((uint64_t) ts.tv_sec * 1000000000ULL) + ts.tv_nsec;
|
||||
}
|
||||
|
||||
static __inline__ uint32_t trace_clock_freq_scale(void)
|
||||
--
|
||||
1.7.2.5
|
||||
|
8
package/lttng-libust/lttng-libust.mk
Normal file
8
package/lttng-libust/lttng-libust.mk
Normal file
@ -0,0 +1,8 @@
|
||||
LTTNG_LIBUST_SITE = http://lttng.org/files/bundles/20111214/
|
||||
LTTNG_LIBUST_VERSION = 1.9.2
|
||||
LTTNG_LIBUST_SOURCE = lttng-ust-$(LTTNG_LIBUST_VERSION).tar.gz
|
||||
|
||||
LTTNG_LIBUST_INSTALL_STAGING = YES
|
||||
LTTNG_LIBUST_DEPENDENCIES = liburcu
|
||||
|
||||
$(eval $(call AUTOTARGETS))
|
Loading…
Reference in New Issue
Block a user