package/iputils: bump version to 20211215
tftp and traceroute6 has been removed in this release [1][2]. Due that LICENSE file has been changed. Also remove patch from this release. [1] https://github.com/iputils/iputils/pull/369 [2] https://github.com/iputils/iputils/pull/362 Signed-off-by: Petr Vorel <petr.vorel@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
966f8187c6
commit
db0c2a2879
@ -146,6 +146,18 @@ endif
|
||||
|
||||
comment "Legacy options removed in 2022.02"
|
||||
|
||||
config BR2_PACKAGE_IPUTILS_TFTPD
|
||||
bool "tftpd"
|
||||
select BR2_LEGACY
|
||||
help
|
||||
tftpd has been removed from upstream.
|
||||
|
||||
config BR2_PACKAGE_IPUTILS_TRACEROUTE6
|
||||
bool "traceroute6"
|
||||
select BR2_LEGACY
|
||||
help
|
||||
traceroute6 has been removed from upstream.
|
||||
|
||||
config BR2_PACKAGE_LIBMEDIAART_BACKEND_NONE
|
||||
bool "libmediaart 'none' backend removed"
|
||||
select BR2_LEGACY
|
||||
|
@ -1,218 +0,0 @@
|
||||
From 3163c49f9f4ad473a00d8a345ee334a028376011 Mon Sep 17 00:00:00 2001
|
||||
From: Heiko Becker <heirecka@exherbo.org>
|
||||
Date: Fri, 23 Jul 2021 16:32:46 +0200
|
||||
Subject: [PATCH] meson: Make tests optional
|
||||
|
||||
Now can be disabled with -DSKIP_TESTS=true.
|
||||
|
||||
It allows to avoid meson error during build when ip isn't installed.
|
||||
|
||||
Closes: #359
|
||||
|
||||
Reviewed-by: Petr Vorel <petr.vorel@gmail.com>
|
||||
Signed-off-by: Heiko Becker <heirecka@exherbo.org>
|
||||
[ pvorel: Rename variable TEST => SKIP_TESTS, default false, adjust
|
||||
the description ]
|
||||
Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
|
||||
|
||||
[Retrieved from:
|
||||
https://github.com/iputils/iputils/commit/3163c49f9f4ad473a00d8a345ee334a028376011]
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
meson_options.txt | 3 ++
|
||||
ping/meson.build | 84 ++-----------------------------------------
|
||||
ping/test/meson.build | 81 +++++++++++++++++++++++++++++++++++++++++
|
||||
3 files changed, 86 insertions(+), 82 deletions(-)
|
||||
create mode 100644 ping/test/meson.build
|
||||
|
||||
diff --git a/meson_options.txt b/meson_options.txt
|
||||
index ac5f5d98..517667f4 100644
|
||||
--- a/meson_options.txt
|
||||
+++ b/meson_options.txt
|
||||
@@ -72,3 +72,6 @@ option('INSTALL_SYSTEMD_UNITS', type: 'boolean', value: false,
|
||||
|
||||
option('USE_GETTEXT', type: 'boolean', value: true,
|
||||
description: 'Enable I18N')
|
||||
+
|
||||
+option('SKIP_TESTS', type: 'boolean', value: false,
|
||||
+ description: 'Skip tests during build')
|
||||
diff --git a/ping/meson.build b/ping/meson.build
|
||||
index 1e678ec8..83ea353c 100644
|
||||
--- a/ping/meson.build
|
||||
+++ b/ping/meson.build
|
||||
@@ -27,86 +27,6 @@ if (setcap_ping)
|
||||
)
|
||||
endif
|
||||
|
||||
-##### TESTS #####
|
||||
-
|
||||
-# TODO: ::1 generates DEPRECATION: ":" is not allowed in test name "ping -c1 ::1", it has been replaced with "_"
|
||||
-
|
||||
-# GitHub CI does not have working IPv6
|
||||
-# https://github.com/actions/virtual-environments/issues/668
|
||||
-ipv6_dst = []
|
||||
-ipv6_switch = []
|
||||
-r = run_command('ip', '-6', 'a')
|
||||
-if r.stdout().strip().contains('::1')
|
||||
- message('IPv6 enabled')
|
||||
- ipv6_dst = [ '::1' ]
|
||||
- ipv6_switch = [ '-6' ]
|
||||
-else
|
||||
- message('WARNING: IPv6 disabled')
|
||||
+if not get_option('SKIP_TESTS')
|
||||
+ subdir('test')
|
||||
endif
|
||||
-
|
||||
-run_as_root = false
|
||||
-r = run_command('id', '-u')
|
||||
-if r.stdout().strip().to_int() == 0
|
||||
- message('running as root')
|
||||
- run_as_root = true
|
||||
-else
|
||||
- message('running as normal user')
|
||||
-endif
|
||||
-
|
||||
-foreach dst : [ 'localhost', '127.0.0.1' ] + ipv6_dst
|
||||
- foreach switch : [ '', '-4' ] + ipv6_switch
|
||||
- args = [ '-c1', dst ]
|
||||
- should_fail = false
|
||||
-
|
||||
- if switch != ''
|
||||
- args = [switch] + args
|
||||
- if (switch == '-4' and dst == '::1') or (switch == '-6' and dst == '127.0.0.1')
|
||||
- should_fail = true
|
||||
- endif
|
||||
- endif
|
||||
-
|
||||
- name = 'ping ' + ' '.join(args)
|
||||
- test(name, ping, args : args, should_fail : should_fail)
|
||||
- endforeach
|
||||
-endforeach
|
||||
-
|
||||
-ping_tests_opt = [
|
||||
- [ '-c1' ],
|
||||
- [ '-c5', '-i0.1' ],
|
||||
- [ '-c1', '-I', 'lo' ],
|
||||
- [ '-c1', '-w1' ],
|
||||
- [ '-c1', '-W1' ],
|
||||
- [ '-c1', '-W1.1' ],
|
||||
-]
|
||||
-foreach dst : [ '127.0.0.1' ] + ipv6_dst
|
||||
- foreach args : ping_tests_opt
|
||||
- args += [ dst ]
|
||||
- name = 'ping ' + ' '.join(args)
|
||||
- test(name, ping, args : args)
|
||||
- endforeach
|
||||
-endforeach
|
||||
-
|
||||
-ping_tests_opt_fail = [
|
||||
- [ '-c1.1' ],
|
||||
- [ '-I', 'nonexisting' ],
|
||||
- [ '-w0.1' ],
|
||||
- [ '-w0,1' ],
|
||||
-]
|
||||
-foreach dst : [ '127.0.0.1' ] + ipv6_dst
|
||||
- foreach args : ping_tests_opt_fail
|
||||
- args += [ dst ]
|
||||
- name = 'ping ' + ' '.join(args)
|
||||
- test(name, ping, args : args, should_fail : true)
|
||||
- endforeach
|
||||
-endforeach
|
||||
-
|
||||
-ping_tests_user_fail = [
|
||||
- [ '-c1', '-i0.001' ], # -c1 required to quit ping when running as root
|
||||
-]
|
||||
-foreach dst : [ '127.0.0.1' ] + ipv6_dst
|
||||
- foreach args : ping_tests_user_fail
|
||||
- args += [ dst ]
|
||||
- name = 'ping ' + ' '.join(args)
|
||||
- test(name, ping, args : args, should_fail : not run_as_root)
|
||||
- endforeach
|
||||
-endforeach
|
||||
diff --git a/ping/test/meson.build b/ping/test/meson.build
|
||||
new file mode 100644
|
||||
index 00000000..43aed758
|
||||
--- /dev/null
|
||||
+++ b/ping/test/meson.build
|
||||
@@ -0,0 +1,81 @@
|
||||
+# TODO: ::1 generates DEPRECATION: ":" is not allowed in test name "ping -c1 ::1", it has been replaced with "_"
|
||||
+
|
||||
+# GitHub CI does not have working IPv6
|
||||
+# https://github.com/actions/virtual-environments/issues/668
|
||||
+ipv6_dst = []
|
||||
+ipv6_switch = []
|
||||
+r = run_command('ip', '-6', 'a')
|
||||
+if r.stdout().strip().contains('::1')
|
||||
+ message('IPv6 enabled')
|
||||
+ ipv6_dst = [ '::1' ]
|
||||
+ ipv6_switch = [ '-6' ]
|
||||
+else
|
||||
+ message('WARNING: IPv6 disabled')
|
||||
+endif
|
||||
+
|
||||
+run_as_root = false
|
||||
+r = run_command('id', '-u')
|
||||
+if r.stdout().strip().to_int() == 0
|
||||
+ message('running as root')
|
||||
+ run_as_root = true
|
||||
+else
|
||||
+ message('running as normal user')
|
||||
+endif
|
||||
+
|
||||
+foreach dst : [ 'localhost', '127.0.0.1' ] + ipv6_dst
|
||||
+ foreach switch : [ '', '-4' ] + ipv6_switch
|
||||
+ args = [ '-c1', dst ]
|
||||
+ should_fail = false
|
||||
+
|
||||
+ if switch != ''
|
||||
+ args = [switch] + args
|
||||
+ if (switch == '-4' and dst == '::1') or (switch == '-6' and dst == '127.0.0.1')
|
||||
+ should_fail = true
|
||||
+ endif
|
||||
+ endif
|
||||
+
|
||||
+ name = 'ping ' + ' '.join(args)
|
||||
+ test(name, ping, args : args, should_fail : should_fail)
|
||||
+ endforeach
|
||||
+endforeach
|
||||
+
|
||||
+ping_tests_opt = [
|
||||
+ [ '-c1' ],
|
||||
+ [ '-c5', '-i0.1' ],
|
||||
+ [ '-c1', '-I', 'lo' ],
|
||||
+ [ '-c1', '-w1' ],
|
||||
+ [ '-c1', '-W1' ],
|
||||
+ [ '-c1', '-W1.1' ],
|
||||
+]
|
||||
+foreach dst : [ '127.0.0.1' ] + ipv6_dst
|
||||
+ foreach args : ping_tests_opt
|
||||
+ args += [ dst ]
|
||||
+ name = 'ping ' + ' '.join(args)
|
||||
+ test(name, ping, args : args)
|
||||
+ endforeach
|
||||
+endforeach
|
||||
+
|
||||
+ping_tests_opt_fail = [
|
||||
+ [ '-c1.1' ],
|
||||
+ [ '-I', 'nonexisting' ],
|
||||
+ [ '-w0.1' ],
|
||||
+ [ '-w0,1' ],
|
||||
+]
|
||||
+foreach dst : [ '127.0.0.1' ] + ipv6_dst
|
||||
+ foreach args : ping_tests_opt_fail
|
||||
+ args += [ dst ]
|
||||
+ name = 'ping ' + ' '.join(args)
|
||||
+ test(name, ping, args : args, should_fail : true)
|
||||
+ endforeach
|
||||
+endforeach
|
||||
+
|
||||
+ping_tests_user_fail = [
|
||||
+ [ '-c1', '-i0.001' ], # -c1 required to quit ping when running as root
|
||||
+]
|
||||
+foreach dst : [ '127.0.0.1' ] + ipv6_dst
|
||||
+ foreach args : ping_tests_user_fail
|
||||
+ args += [ dst ]
|
||||
+ name = 'ping ' + ' '.join(args)
|
||||
+ test(name, ping, args : args, should_fail : not run_as_root)
|
||||
+ endforeach
|
||||
+endforeach
|
@ -3,7 +3,7 @@ config BR2_PACKAGE_IPUTILS
|
||||
depends on BR2_USE_MMU # fork()
|
||||
help
|
||||
This package is set of small useful utilities for Linux
|
||||
networking. It includes complete versions of ping, traceroute,
|
||||
networking. It includes complete versions of ping, arping,
|
||||
etc.
|
||||
|
||||
https://github.com/iputils/iputils
|
||||
@ -46,23 +46,12 @@ config BR2_PACKAGE_IPUTILS_RDISC_SERVER
|
||||
help
|
||||
Builds rdisc with server code.
|
||||
|
||||
config BR2_PACKAGE_IPUTILS_TFTPD
|
||||
bool "tftpd"
|
||||
help
|
||||
Installs tftpd.
|
||||
|
||||
config BR2_PACKAGE_IPUTILS_TRACEPATH
|
||||
bool "tracepath"
|
||||
default y
|
||||
help
|
||||
Installs tracepath.
|
||||
|
||||
config BR2_PACKAGE_IPUTILS_TRACEROUTE6
|
||||
bool "traceroute6"
|
||||
default y
|
||||
help
|
||||
Installs traceroute6.
|
||||
|
||||
config BR2_PACKAGE_IPUTILS_NINFOD
|
||||
bool "ninfod"
|
||||
default y
|
||||
|
@ -1,6 +1,6 @@
|
||||
# https://github.com/iputils/iputils/releases/download/20210722/sha256sum.asc
|
||||
sha256 6d1a44b0682d3d4b64586dbaebe61dd61ae16d6e2f4dc0c43336d0e47a9db323 iputils-20210722.tar.gz
|
||||
# https://github.com/iputils/iputils/releases/download/20211215/sha256sum.asc
|
||||
sha256 b6f67fc705490673ff4471d006221b4a2f1b1180b929d9fefd771352621ccedf iputils-20211215.tar.gz
|
||||
# Locally computed
|
||||
sha256 b8ea785d12fa6a44916601104dd746216957e93f13a26d3eb858b3b5a4ad66ab LICENSE
|
||||
sha256 973281334c2da6364fa6bdc44c1f0f8d60d80d73c782982ffc5d53b0a31aa042 LICENSE
|
||||
sha256 9acc4bc871a4742550158e3696dcb381953172ef808d04ca248184f9f6322712 Documentation/LICENSE.BSD3
|
||||
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 Documentation/LICENSE.GPL2
|
||||
|
@ -11,7 +11,7 @@
|
||||
# and IPv6 updates.
|
||||
# http://www.spinics.net/lists/netdev/msg279881.html
|
||||
|
||||
IPUTILS_VERSION = 20210722
|
||||
IPUTILS_VERSION = 20211215
|
||||
IPUTILS_SITE = $(call github,iputils,iputils,$(IPUTILS_VERSION))
|
||||
IPUTILS_LICENSE = GPL-2.0+, BSD-3-Clause
|
||||
IPUTILS_LICENSE_FILES = LICENSE Documentation/LICENSE.BSD3 Documentation/LICENSE.GPL2
|
||||
@ -25,7 +25,6 @@ IPUTILS_CONF_OPTS += \
|
||||
-DBUILD_RDISC=$(if $(BR2_PACKAGE_IPUTILS_RDISC),true,false) \
|
||||
-DENABLE_RDISC_SERVER=$(if $(BR2_PACKAGE_IPUTILS_RDISC_SERVER),true,false) \
|
||||
-DBUILD_TRACEPATH=$(if $(BR2_PACKAGE_IPUTILS_TRACEPATH),true,false) \
|
||||
-DBUILD_TRACEROUTE6=$(if $(BR2_PACKAGE_IPUTILS_TRACEROUTE6),true,false) \
|
||||
-DBUILD_NINFOD=$(if $(BR2_PACKAGE_IPUTILS_NINFOD),true,false) \
|
||||
-DSKIP_TESTS=true
|
||||
|
||||
@ -34,9 +33,7 @@ IPUTILS_SELINUX_MODULES = \
|
||||
$(if $(BR2_PACKAGE_IPUTILS_ARPING),netutils) \
|
||||
$(if $(BR2_PACKAGE_IPUTILS_PING),netutils) \
|
||||
$(if $(BR2_PACKAGE_IPUTILS_TRACEPATH),netutils) \
|
||||
$(if $(BR2_PACKAGE_IPUTILS_TRACEROUTE6),netutils) \
|
||||
$(if $(BR2_PACKAGE_IPUTILS_RDISC),rdisc) \
|
||||
$(if $(BR2_PACKAGE_IPUTILS_TFTPD),tftp)
|
||||
$(if $(BR2_PACKAGE_IPUTILS_RDISC),rdisc)
|
||||
|
||||
#
|
||||
# arping
|
||||
@ -80,16 +77,6 @@ else
|
||||
IPUTILS_CONF_OPTS += -DBUILD_PING=false
|
||||
endif
|
||||
|
||||
#
|
||||
# tftpd
|
||||
#
|
||||
ifeq ($(BR2_PACKAGE_IPUTILS_TFTPD),y)
|
||||
IPUTILS_CONF_OPTS += -DBUILD_TFTPD=true
|
||||
|
||||
else
|
||||
IPUTILS_CONF_OPTS += -DBUILD_TFTPD=false
|
||||
endif
|
||||
|
||||
# Handle libraries
|
||||
ifeq ($(BR2_PACKAGE_LIBCAP),y)
|
||||
IPUTILS_CONF_OPTS += -DUSE_CAP=true
|
||||
@ -130,9 +117,6 @@ define IPUTILS_PERMISSIONS
|
||||
$(if $(BR2_PACKAGE_IPUTILS_PING),\
|
||||
/bin/ping f 755 0 0 - - - - -
|
||||
|xattr cap_net_raw+p,)
|
||||
$(if $(BR2_PACKAGE_IPUTILS_TRACEROUTE6),\
|
||||
/usr/bin/traceroute6 f 755 0 0 - - - - -
|
||||
|xattr cap_net_raw+p,)
|
||||
endef
|
||||
else
|
||||
define IPUTILS_PERMISSIONS
|
||||
@ -142,8 +126,6 @@ define IPUTILS_PERMISSIONS
|
||||
/usr/bin/clockdiff f 4755 0 0 - - - - -,)
|
||||
$(if $(BR2_PACKAGE_IPUTILS_PING),\
|
||||
/bin/ping f 4755 0 0 - - - - -,)
|
||||
$(if $(BR2_PACKAGE_IPUTILS_TRACEROUTE6),\
|
||||
/usr/bin/traceroute6 f 4755 0 0 - - - - -,)
|
||||
endef
|
||||
endif
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user