added gnuchess
This commit is contained in:
parent
70d3331748
commit
dab3cd675c
7
package/gnuchess/Config.in
Normal file
7
package/gnuchess/Config.in
Normal file
@ -0,0 +1,7 @@
|
||||
config BR2_PACKAGE_GNUCHESS
|
||||
bool "gnuchess"
|
||||
default n
|
||||
help
|
||||
GNU Chess lets most modern computers play a full game of chess.
|
||||
|
||||
http://ftp.gnu.org/pub/gnu/chess
|
11
package/gnuchess/gnuchess-5.07.patch
Normal file
11
package/gnuchess/gnuchess-5.07.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/src/input.c 2003-07-01 13:06:43.000000000 -0400
|
||||
+++ a/src/input.c 2008-02-13 12:24:43.000000000 -0500
|
||||
@@ -92,7 +92,7 @@ void getline_standard(char *p)
|
||||
fgets(inputstr, MAXSTR, stdin);
|
||||
}
|
||||
|
||||
-static pthread_t input_thread;
|
||||
+pthread_t input_thread;
|
||||
|
||||
/* Mutex and condition variable for thread communication */
|
||||
|
18
package/gnuchess/gnuchess.mk
Normal file
18
package/gnuchess/gnuchess.mk
Normal file
@ -0,0 +1,18 @@
|
||||
#############################################################
|
||||
#
|
||||
# gnuchess
|
||||
#
|
||||
#############################################################
|
||||
GNUCHESS_VERSION = 5.07
|
||||
GNUCHESS_SOURCE = gnuchess-$(GNUCHESS_VERSION).tar.gz
|
||||
GNUCHESS_SITE = http://ftp.gnu.org/pub/gnu/chess
|
||||
GNUCHESS_AUTORECONF = NO
|
||||
GNUCHESS_INSTALL_STAGING = NO
|
||||
GNUCHESS_INSTALL_TARGET = YES
|
||||
|
||||
GNUCHESS_CONF_ENV = ac_cv_func_realloc_0_nonnull=yes ac_cv_func_malloc_0_nonnull=yes
|
||||
|
||||
GNUCHESS_DEPENDENCIES = uclibc
|
||||
|
||||
$(eval $(call AUTOTARGETS,package,gnuchess))
|
||||
|
Loading…
Reference in New Issue
Block a user