package/mesa3d: fix 002-vc4-add-meson-option-to-disable-optional-neon-suppor.patch
Update 002-vc4-add-meson-option-to-disable-optional-neon-suppor.patch to fix an syntax error introduced by commit 'package/{mesa3d, mesa3d-headers}: bump version to 23.1.0' ([1]) Fixes: .../build/mesa3d-23.1.2/src/gallium/drivers/vc4/meson.build:87:76: ERROR: Trying to compare values of different types (UserFeatureOption, str) using !=. This was deprecated and undefined behavior previously and is as of 0.60.0 a hard error. [1] https://git.buildroot.net/buildroot/commit/?id=e6203db11ed40122a2d9f29012db5683a7eb10d0 Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
parent
d521d6b756
commit
da19c18af2
@ -1,4 +1,4 @@
|
||||
From e3b47c1b84964c62b3e1fa782f1ffa4be0ae62f9 Mon Sep 17 00:00:00 2001
|
||||
From f719e942dde0a46a9ff0080001cb3466012ffcc0 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Seiderer <ps.report@gmx.net>
|
||||
Date: Mon, 9 Mar 2020 13:01:14 +0100
|
||||
Subject: [PATCH] vc4: add meson option to disable optional neon support
|
||||
@ -11,6 +11,8 @@ Upstream: https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4114
|
||||
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
[rebased for 20.2.0, 20.3.0, 21.1.0 & 23.1.0]
|
||||
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
||||
[fix syntax error after previous rebases]
|
||||
---
|
||||
meson_options.txt | 7 +++++++
|
||||
src/gallium/drivers/vc4/meson.build | 4 ++--
|
||||
@ -18,25 +20,25 @@ Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
3 files changed, 11 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/meson_options.txt b/meson_options.txt
|
||||
index a39596a6f19..0f6b6c62b55 100644
|
||||
index 8e0bf2a..1cf0e07 100644
|
||||
--- a/meson_options.txt
|
||||
+++ b/meson_options.txt
|
||||
@@ -117,6 +117,13 @@
|
||||
@@ -116,6 +116,13 @@ option(
|
||||
description : 'enable gallium va frontend.',
|
||||
)
|
||||
|
||||
option(
|
||||
+option(
|
||||
+ 'gallium-vc4-neon',
|
||||
+ type : 'feature',
|
||||
+ deprecated: {'true': 'enabled', 'false': 'disabled'},
|
||||
+ description : 'enable gallium vc4 optional neon support.',
|
||||
+)
|
||||
+
|
||||
+option(
|
||||
option(
|
||||
'va-libs-path',
|
||||
type : 'string',
|
||||
value : '',
|
||||
diff --git a/src/gallium/drivers/vc4/meson.build b/src/gallium/drivers/vc4/meson.build
|
||||
index 5ce5af5f6b4..e3f7d8d62ae 100644
|
||||
index 84da951..7f950de 100644
|
||||
--- a/src/gallium/drivers/vc4/meson.build
|
||||
+++ b/src/gallium/drivers/vc4/meson.build
|
||||
@@ -84,7 +84,7 @@ files_libvc4 = files(
|
||||
@ -44,7 +46,7 @@ index 5ce5af5f6b4..e3f7d8d62ae 100644
|
||||
|
||||
libvc4_neon = []
|
||||
-if host_machine.cpu_family() == 'arm'
|
||||
+if host_machine.cpu_family() == 'arm' and get_option('gallium-vc4-neon') != 'disabled'
|
||||
+if host_machine.cpu_family() == 'arm' and not get_option('gallium-vc4-neon').disabled()
|
||||
libvc4_neon = static_library(
|
||||
'vc4_neon',
|
||||
'vc4_tiling_lt_neon.c',
|
||||
@ -58,7 +60,7 @@ index 5ce5af5f6b4..e3f7d8d62ae 100644
|
||||
|
||||
if dep_simpenrose.found()
|
||||
diff --git a/src/gallium/drivers/vc4/vc4_tiling.h b/src/gallium/drivers/vc4/vc4_tiling.h
|
||||
index 66767e7f1f8..7446f1c3d0c 100644
|
||||
index 5afe329..919b299 100644
|
||||
--- a/src/gallium/drivers/vc4/vc4_tiling.h
|
||||
+++ b/src/gallium/drivers/vc4/vc4_tiling.h
|
||||
@@ -89,7 +89,7 @@ vc4_load_lt_image(void *dst, uint32_t dst_stride,
|
||||
@ -80,5 +82,5 @@ index 66767e7f1f8..7446f1c3d0c 100644
|
||||
vc4_store_lt_image_neon(dst, dst_stride, src, src_stride,
|
||||
cpp, box);
|
||||
--
|
||||
2.25.1
|
||||
2.41.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user