package/rng-tools: fix musl build

Fix the following musl build failure raised since bump to version 6.14
in commit 5292d1cf9a:

/home/buildroot/autobuild/instance-0/output-1/host/opt/ext-toolchain/bin/../lib/gcc/i586-buildroot-linux-musl/9.3.0/../../../../i586-buildroot-linux-musl/bin/ld: rngd-rngd_jitter.o: in function `rngd_notime_start':
rngd_jitter.c:(.text+0xdc2): undefined reference to `pthread_attr_setaffinity_np'

Fixes:
 - http://autobuild.buildroot.org/results/3ec7df86856aa9bee2f18a8faa44fd58bc8a6657

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Fabrice Fontaine 2021-12-28 14:39:59 +01:00 committed by Thomas Petazzoni
parent 72de4a84fb
commit d94e2b6dd4
2 changed files with 92 additions and 0 deletions

View File

@ -0,0 +1,43 @@
From d1840e54a15fc454936cada10cce7fd91d06232b Mon Sep 17 00:00:00 2001
From: Neil Horman <nhorman@gmail.com>
Date: Thu, 15 Jul 2021 08:43:01 -0400
Subject: [PATCH] Adding ability to detect non-posix extensions for pthreads
Theres a desire to build rngd with musl, which doesn't have all the gnu
extensions (but it has some). So test for those. Note, this requires
the addition of the USE_EXTENSIONS macro to enable -d_GNU_SOURCE
Signed-off-by: Neil Horman <nhorman@tuxdriver.com>
[Retrieved from:
https://github.com/nhorman/rng-tools/commit/d1840e54a15fc454936cada10cce7fd91d06232b]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
configure.ac | 7 +++++++
1 file changed, 7 insertions(+)
diff --git a/configure.ac b/configure.ac
index 0fe06fc..de7dca3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,7 @@ AC_CANONICAL_TARGET dnl required for broken AX_PTHREAD
AM_INIT_AUTOMAKE([foreign])
AC_CONFIG_HEADERS([rng-tools-config.h])
AC_CONFIG_MACRO_DIRS([m4])
+AC_USE_SYSTEM_EXTENSIONS
dnl Parse options
@@ -100,6 +101,12 @@ AS_IF(
], [AC_MSG_NOTICE([Disabling JITTER entropy source])]
)
+AC_CHECK_DECL(pthread_attr_setaffinity_np,
+ [AC_DEFINE([HAVE_PTHREAD_ATTR_SETAFFINITY], 1,[Set ATTR_SETAFFINITY])],
+ [ AC_CHECK_DECL(pthread_setaffinity_np,
+ [AC_DEFINE([HAVE_PTHREAD_SETAFFINITY],1, [Set PTHREAD_SETAFFINITY])], [ AC_MSG_ERROR([Neither pthread_setaffinity_np nor pthread_attr_setaffinity_np found])],[[#include <pthread.h>]])
+ ], [[#include <pthread.h>]])
+
AS_IF(
[ test "x$with_nistbeacon" != "xno"],
[

View File

@ -0,0 +1,49 @@
From 5caa086dc14cecf68d1a5c31e87ba1efb2c00893 Mon Sep 17 00:00:00 2001
From: Neil Horman <nhorman@gmail.com>
Date: Thu, 15 Jul 2021 08:48:10 -0400
Subject: [PATCH] Allow for use of either pthread affinity set methods
musl has support for pthread_setaffinity_np, but not
pthread_attr_setaffinity_np. so check for hte existence of either
function in configure, and use the appropriate one.
Signed-off-by: Neil Horman <nhorman@tuxdriver.com>
[Retrieved from:
https://github.com/nhorman/rng-tools/commit/5caa086dc14cecf68d1a5c31e87ba1efb2c00893]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
rngd_jitter.c | 15 ++++++++++++++-
1 file changed, 14 insertions(+), 1 deletion(-)
diff --git a/rngd_jitter.c b/rngd_jitter.c
index ea29436..5c7e09e 100644
--- a/rngd_jitter.c
+++ b/rngd_jitter.c
@@ -67,12 +67,25 @@ static int rngd_notime_start(void *ctx,
for(i=i-1;i>=0;i--) {
CPU_SET(i,cpus);
}
- pthread_attr_setaffinity_np(&thread_ctx->notime_pthread_attr, cpusize, cpus);
+ /*
+ * Note that only one of:
+ * HAVE_PTHREAD_ATTR_SETAFFINITY
+ * and
+ * HAVE_PTHREAD_SETAFFINITY
+ * Will ever be set, as per the configure.ac logic
+ */
+#ifdef HAVE_PTHREAD_ATTR_SETAFFINITY
+ pthread_attr_setaffinity_np(&thread_ctx->notime_pthread_attr, cpusize, cpus);
+#endif
ret = -pthread_create(&thread_ctx->notime_thread_id,
&thread_ctx->notime_pthread_attr,
start_routine, arg);
+#ifdef HAVE_PTHREAD_SETAFFINITY
+ pthread_setaffinity_np(&thread_ctx->notime_thread_id, cpusize, cpus);
+#endif
+
CPU_FREE(cpus);
return ret;
}