Update gcc to version 3.2.3. Fix the openssh patch
This commit is contained in:
parent
1c8e0b4771
commit
d906413ad9
6
Makefile
6
Makefile
@ -46,7 +46,7 @@ GCC_2_95_TOOLCHAIN:=false
|
|||||||
# Enable this to use the uClibc daily snapshot instead of a released
|
# Enable this to use the uClibc daily snapshot instead of a released
|
||||||
# version. Daily snapshots may contain new features and bugfixes. Or
|
# version. Daily snapshots may contain new features and bugfixes. Or
|
||||||
# they may not even compile at all, depending on what Erik is doing...
|
# they may not even compile at all, depending on what Erik is doing...
|
||||||
USE_UCLIBC_SNAPSHOT:=false
|
USE_UCLIBC_SNAPSHOT:=true
|
||||||
|
|
||||||
# Enable this to use the busybox daily snapshot instead of a released
|
# Enable this to use the busybox daily snapshot instead of a released
|
||||||
# version. Daily snapshots may contain new features and bugfixes. Or
|
# version. Daily snapshots may contain new features and bugfixes. Or
|
||||||
@ -143,10 +143,10 @@ BASE_DIR:=${shell pwd}
|
|||||||
SOURCE_DIR:=$(BASE_DIR)/sources
|
SOURCE_DIR:=$(BASE_DIR)/sources
|
||||||
DL_DIR:=$(SOURCE_DIR)/dl
|
DL_DIR:=$(SOURCE_DIR)/dl
|
||||||
PATCH_DIR=$(SOURCE_DIR)/patches
|
PATCH_DIR=$(SOURCE_DIR)/patches
|
||||||
BUILD_DIR:=$(BASE_DIR)/build
|
BUILD_DIR:=$(BASE_DIR)/build_$(ARCH)
|
||||||
TARGET_DIR:=$(BUILD_DIR)/root
|
TARGET_DIR:=$(BUILD_DIR)/root
|
||||||
STAGING_DIR=$(BUILD_DIR)/staging_dir
|
STAGING_DIR=$(BUILD_DIR)/staging_dir
|
||||||
TOOL_BUILD_DIR=$(BASE_DIR)/build
|
TOOL_BUILD_DIR=$(BASE_DIR)/toolchain_build_$(ARCH)
|
||||||
TARGET_PATH=$(STAGING_DIR)/bin:/bin:/sbin:/usr/bin:/usr/sbin
|
TARGET_PATH=$(STAGING_DIR)/bin:/bin:/sbin:/usr/bin:/usr/sbin
|
||||||
TARGET_CROSS=$(STAGING_DIR)/bin/$(ARCH)-uclibc-
|
TARGET_CROSS=$(STAGING_DIR)/bin/$(ARCH)-uclibc-
|
||||||
TARGET_CC=$(TARGET_CROSS)gcc
|
TARGET_CC=$(TARGET_CROSS)gcc
|
||||||
|
@ -26,7 +26,7 @@ ifeq ($(GCC_2_95_TOOLCHAIN),false)
|
|||||||
#
|
#
|
||||||
#############################################################
|
#############################################################
|
||||||
#Directory in which to build the toolchain
|
#Directory in which to build the toolchain
|
||||||
TOOL_BUILD_DIR=$(BASE_DIR)/toolchain_build
|
TOOL_BUILD_DIR=$(BASE_DIR)/toolchain_build_$(ARCH)
|
||||||
|
|
||||||
TARGET_LANGUAGES:=c,c++
|
TARGET_LANGUAGES:=c,c++
|
||||||
|
|
||||||
@ -62,8 +62,8 @@ UCLIBC_SITE:=http://www.uclibc.org/downloads
|
|||||||
endif
|
endif
|
||||||
|
|
||||||
GCC_SITE:=ftp://ftp.gnu.org/gnu/gcc/
|
GCC_SITE:=ftp://ftp.gnu.org/gnu/gcc/
|
||||||
GCC_SOURCE:=gcc-3.2.2.tar.gz
|
GCC_SOURCE:=gcc-3.2.3.tar.gz
|
||||||
GCC_DIR:=$(TOOL_BUILD_DIR)/gcc-3.2.2
|
GCC_DIR:=$(TOOL_BUILD_DIR)/gcc-3.2.3
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
@ -26,7 +26,7 @@ ifeq ($(GCC_2_95_TOOLCHAIN),true)
|
|||||||
#
|
#
|
||||||
#############################################################
|
#############################################################
|
||||||
#Directory in which to build the toolchain
|
#Directory in which to build the toolchain
|
||||||
TOOL_BUILD_DIR=$(BASE_DIR)/toolchain_build
|
TOOL_BUILD_DIR=$(BASE_DIR)/toolchain_build_$(ARCH)
|
||||||
|
|
||||||
TARGET_LANGUAGES:=c,c++
|
TARGET_LANGUAGES:=c,c++
|
||||||
|
|
||||||
|
@ -1,38 +1,14 @@
|
|||||||
diff -uNr openssh-3.5p1.orig/Makefile.in openssh-3.5p1/Makefile.in
|
--- openssh-3.6.1p1/Makefile.in.orig 2003-03-20 17:34:34.000000000 -0700
|
||||||
--- openssh-3.5p1.orig/Makefile.in Sun Jul 14 19:02:21 2002
|
+++ openssh-3.6.1p1/Makefile.in 2003-04-25 17:09:00.000000000 -0600
|
||||||
+++ openssh-3.5p1/Makefile.in Mon Mar 17 14:54:20 2003
|
@@ -27,7 +27,7 @@
|
||||||
@@ -217,19 +217,19 @@
|
RAND_HELPER=$(libexecdir)/ssh-rand-helper
|
||||||
$(srcdir)/mkinstalldirs $(DESTDIR)$(mandir)/$(mansubdir)8
|
PRIVSEP_PATH=@PRIVSEP_PATH@
|
||||||
$(srcdir)/mkinstalldirs $(DESTDIR)$(libexecdir)
|
SSH_PRIVSEP_USER=@SSH_PRIVSEP_USER@
|
||||||
(umask 022 ; $(srcdir)/mkinstalldirs $(DESTDIR)$(PRIVSEP_PATH))
|
-STRIP_OPT=@STRIP_OPT@
|
||||||
- $(INSTALL) -m 0755 -s ssh $(DESTDIR)$(bindir)/ssh
|
+STRIP_OPT=
|
||||||
- $(INSTALL) -m 0755 -s scp $(DESTDIR)$(bindir)/scp
|
|
||||||
- $(INSTALL) -m 0755 -s ssh-add $(DESTDIR)$(bindir)/ssh-add
|
PATHS= -DSSHDIR=\"$(sysconfdir)\" \
|
||||||
- $(INSTALL) -m 0755 -s ssh-agent $(DESTDIR)$(bindir)/ssh-agent
|
-D_PATH_SSH_PROGRAM=\"$(SSH_PROGRAM)\" \
|
||||||
- $(INSTALL) -m 0755 -s ssh-keygen $(DESTDIR)$(bindir)/ssh-keygen
|
|
||||||
- $(INSTALL) -m 0755 -s ssh-keyscan $(DESTDIR)$(bindir)/ssh-keyscan
|
|
||||||
- $(INSTALL) -m 0755 -s sshd $(DESTDIR)$(sbindir)/sshd
|
|
||||||
+ $(INSTALL) -m 0755 ssh $(DESTDIR)$(bindir)/ssh
|
|
||||||
+ $(INSTALL) -m 0755 scp $(DESTDIR)$(bindir)/scp
|
|
||||||
+ $(INSTALL) -m 0755 ssh-add $(DESTDIR)$(bindir)/ssh-add
|
|
||||||
+ $(INSTALL) -m 0755 ssh-agent $(DESTDIR)$(bindir)/ssh-agent
|
|
||||||
+ $(INSTALL) -m 0755 ssh-keygen $(DESTDIR)$(bindir)/ssh-keygen
|
|
||||||
+ $(INSTALL) -m 0755 ssh-keyscan $(DESTDIR)$(bindir)/ssh-keyscan
|
|
||||||
+ $(INSTALL) -m 0755 sshd $(DESTDIR)$(sbindir)/sshd
|
|
||||||
if test ! -z "$(INSTALL_SSH_RAND_HELPER)" ; then \
|
|
||||||
- $(INSTALL) -m 0755 -s ssh-rand-helper $(DESTDIR)$(libexecdir)/ssh-rand-helper ; \
|
|
||||||
+ $(INSTALL) -m 0755 ssh-rand-helper $(DESTDIR)$(libexecdir)/ssh-rand-helper ; \
|
|
||||||
fi
|
|
||||||
- $(INSTALL) -m 4711 -s ssh-keysign $(DESTDIR)$(SSH_KEYSIGN)
|
|
||||||
- @NO_SFTP@$(INSTALL) -m 0755 -s sftp $(DESTDIR)$(bindir)/sftp
|
|
||||||
- @NO_SFTP@$(INSTALL) -m 0755 -s sftp-server $(DESTDIR)$(SFTP_SERVER)
|
|
||||||
+ $(INSTALL) -m 4711 ssh-keysign $(DESTDIR)$(SSH_KEYSIGN)
|
|
||||||
+ @NO_SFTP@$(INSTALL) -m 0755 sftp $(DESTDIR)$(bindir)/sftp
|
|
||||||
+ @NO_SFTP@$(INSTALL) -m 0755 sftp-server $(DESTDIR)$(SFTP_SERVER)
|
|
||||||
$(INSTALL) -m 644 ssh.1.out $(DESTDIR)$(mandir)/$(mansubdir)1/ssh.1
|
|
||||||
$(INSTALL) -m 644 scp.1.out $(DESTDIR)$(mandir)/$(mansubdir)1/scp.1
|
|
||||||
$(INSTALL) -m 644 ssh-add.1.out $(DESTDIR)$(mandir)/$(mansubdir)1/ssh-add.1
|
|
||||||
diff -uNr openssh-3.5p1.orig/configure.ac openssh-3.5p1/configure.ac
|
|
||||||
--- openssh-3.5p1.orig/configure.ac Thu Sep 26 02:38:47 2002
|
--- openssh-3.5p1.orig/configure.ac Thu Sep 26 02:38:47 2002
|
||||||
+++ openssh-3.5p1/configure.ac Mon Mar 17 14:55:00 2003
|
+++ openssh-3.5p1/configure.ac Mon Mar 17 14:55:00 2003
|
||||||
@@ -504,6 +504,9 @@
|
@@ -504,6 +504,9 @@
|
||||||
@ -154,7 +130,6 @@ diff -uNr openssh-3.5p1.orig/configure.ac openssh-3.5p1/configure.ac
|
|||||||
# Options from here on. Some of these are preset by platform above
|
# Options from here on. Some of these are preset by platform above
|
||||||
AC_ARG_WITH(mantype,
|
AC_ARG_WITH(mantype,
|
||||||
[ --with-mantype=man|cat|doc Set man page type],
|
[ --with-mantype=man|cat|doc Set man page type],
|
||||||
diff -uNr openssh-3.5p1.orig/sshd_config openssh-3.5p1/sshd_config
|
|
||||||
--- openssh-3.5p1.orig/sshd_config Fri Sep 27 05:21:58 2002
|
--- openssh-3.5p1.orig/sshd_config Fri Sep 27 05:21:58 2002
|
||||||
+++ openssh-3.5p1/sshd_config Mon Mar 17 14:55:00 2003
|
+++ openssh-3.5p1/sshd_config Mon Mar 17 14:55:00 2003
|
||||||
@@ -89,5 +89,8 @@
|
@@ -89,5 +89,8 @@
|
||||||
|
Loading…
Reference in New Issue
Block a user