package/libraw: bump to version 0.21.0
- Drop patch (already in version) - Drop autoreconf - Update hash of README.md (year updated with4c954948ba
and licensing terms slightly reworded with2a9a4de21e
) https://www.libraw.org/news/libraw-0-21-release Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
0627cb0e8a
commit
d668cd0b29
@ -1,67 +0,0 @@
|
||||
From ad911cbc3c16397cf9d326c30571a4d1edaaa03f Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Wed, 2 Jun 2021 07:45:40 +0200
|
||||
Subject: [PATCH] Add Libs.private to libraw.pc
|
||||
|
||||
Add Libs.private to libraw.pc to avoid the following static build
|
||||
failure when enabling libraw with jasper support in imagemagick:
|
||||
|
||||
/home/giuliobenetti/autobuild/run/instance-1/output-1/host/opt/ext-toolchain/bin/../lib/gcc/arm-buildroot-linux-uclibcgnueabi/9.3.0/../../../../arm-buildroot-linux-uclibcgnueabi/bin/ld: /home/giuliobenetti/autobuild/run/instance-1/output-1/host/bin/../arm-buildroot-linux-uclibcgnueabi/sysroot/usr/lib/libjasper.a(jpg_enc.c.o): in function `jpg_encode':
|
||||
jpg_enc.c:(.text+0x1f4): undefined reference to `jpeg_stdio_dest'
|
||||
|
||||
-ljpeg must be added after -ljasper because jasper depends on jpeg
|
||||
|
||||
Fixes:
|
||||
- http://autobuild.buildroot.org/results/88e43a1ea2059a684e50b0f5f2af407e8c6df2e1
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Upstream status: https://github.com/LibRaw/LibRaw/pull/406]
|
||||
---
|
||||
configure.ac | 2 ++
|
||||
libraw.pc.in | 1 +
|
||||
libraw_r.pc.in | 1 +
|
||||
3 files changed, 4 insertions(+)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 4ab2f313..7bf5fdfd 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -57,6 +57,7 @@ if test x$jpeg = xtrue; then
|
||||
AC_CHECK_HEADERS([jpeglib.h], [
|
||||
CPPFLAGS="$CPPFLAGS -DUSE_JPEG -DUSE_JPEG8"
|
||||
LIBS="$LIBS -ljpeg"
|
||||
+ AC_SUBST([PACKAGE_LIBS_PRIVATE],"-ljpeg $PACKAGE_LIBS_PRIVATE")
|
||||
], AC_MSG_WARN([no jpeg headers found]))
|
||||
],
|
||||
AC_MSG_WARN([libjpeg not found])
|
||||
@@ -78,6 +79,7 @@ if test x$jasper = xtrue; then
|
||||
AC_CHECK_HEADERS([jasper/jasper.h], [
|
||||
CPPFLAGS="$CPPFLAGS -DUSE_JASPER"
|
||||
LIBS="$LIBS -ljasper"
|
||||
+ AC_SUBST([PACKAGE_LIBS_PRIVATE],"-ljasper $PACKAGE_LIBS_PRIVATE")
|
||||
], AC_MSG_WARN([no jasper headers found]))
|
||||
],
|
||||
AC_MSG_WARN([libjasper not found])
|
||||
diff --git a/libraw.pc.in b/libraw.pc.in
|
||||
index 1bab18b8..c95fbc48 100644
|
||||
--- a/libraw.pc.in
|
||||
+++ b/libraw.pc.in
|
||||
@@ -8,4 +8,5 @@ Description: Raw image decoder library (non-thread-safe)
|
||||
Requires: @PACKAGE_REQUIRES@
|
||||
Version: @PACKAGE_VERSION@
|
||||
Libs: -L${libdir} -lraw -lstdc++@PC_OPENMP@
|
||||
+Libs.private: @PACKAGE_LIBS_PRIVATE@
|
||||
Cflags: -I${includedir}/libraw -I${includedir}
|
||||
diff --git a/libraw_r.pc.in b/libraw_r.pc.in
|
||||
index e8427271..92bbbffa 100644
|
||||
--- a/libraw_r.pc.in
|
||||
+++ b/libraw_r.pc.in
|
||||
@@ -8,4 +8,5 @@ Description: Raw image decoder library (thread-safe)
|
||||
Requires: @PACKAGE_REQUIRES@
|
||||
Version: @PACKAGE_VERSION@
|
||||
Libs: -L${libdir} -lraw_r -lstdc++@PC_OPENMP@
|
||||
+Libs.private: @PACKAGE_LIBS_PRIVATE@
|
||||
Cflags: -I${includedir}/libraw -I${includedir}
|
||||
--
|
||||
2.30.2
|
||||
|
@ -1,5 +1,5 @@
|
||||
# Locally calculated
|
||||
sha256 dc1b486c2003435733043e4e05273477326e51c3ea554c6864a4eafaff1004a6 LibRaw-0.20.2.tar.gz
|
||||
sha256 8747b34e8534cc2dd7ef8c92c436414b3578904fd4bf9b87ea60f17aa99fb0bd LibRaw-0.21.0.tar.gz
|
||||
sha256 eea173a556abac0370461e57e12aab266894ea6be3874c2be05fd87871f75449 LICENSE.LGPL
|
||||
sha256 0e3098d2d54a12434715f6679ea408d57da5e8d613c385c58ecc6fe5d30cc81f LICENSE.CDDL
|
||||
sha256 313415f7f48f6cd3cc78856626aab4bbe97dbb1e9a11db9c25396ca8d0e76cd9 README.md
|
||||
sha256 7d6650cef6cf892abe95e55a6bda1e1c42f221fd411b807deb2fc0b805b868d4 README.md
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
LIBRAW_VERSION = 0.20.2
|
||||
LIBRAW_VERSION = 0.21.0
|
||||
LIBRAW_SOURCE = LibRaw-$(LIBRAW_VERSION).tar.gz
|
||||
LIBRAW_SITE = http://www.libraw.org/data
|
||||
LIBRAW_INSTALL_STAGING = YES
|
||||
@ -15,8 +15,6 @@ LIBRAW_LICENSE = LGPL-2.1 or CDDL-1.0
|
||||
LIBRAW_LICENSE_FILES = LICENSE.LGPL LICENSE.CDDL README.md
|
||||
LIBRAW_CPE_ID_VENDOR = libraw
|
||||
LIBRAW_DEPENDENCIES = host-pkgconf
|
||||
# https://github.com/LibRaw/LibRaw/issues/353
|
||||
LIBRAW_AUTORECONF = YES
|
||||
LIBRAW_CXXFLAGS = $(TARGET_CXXFLAGS)
|
||||
LIBRAW_CONF_ENV = CXXFLAGS="$(LIBRAW_CXXFLAGS)"
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user