package/libnss: bump version to 3.80

Let's drop local patch that has been upstreamed:
190801f7f1

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Giulio Benetti 2022-06-24 02:02:16 +02:00 committed by Thomas Petazzoni
parent 0d566b8cc7
commit d594c16123
3 changed files with 3 additions and 40 deletions

View File

@ -1,37 +0,0 @@
From 9d5900c1ee9000906a90923e861b0fd7f1061cde Mon Sep 17 00:00:00 2001
From: Giulio Benetti <giulio.benetti@benettiengineering.com>
Date: Tue, 24 May 2022 23:40:45 +0200
Subject: [PATCH] Bug 1771036 - Fix build failure on Aarch64 host
If trying to build on Aarch64 host for powerpc64 target we can't override
the LDFLAGS leading to this build failure:
gcc: error: unrecognized command-line option '-m64'
So let's add NATIVE_LDFLAGS check and use it to link nsinstall. This way
any build environment can pass LDFLAGS that fits better for host
architecture.
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
[upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1771036]
---
coreconf/nsinstall/Makefile | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/nss/coreconf/nsinstall/Makefile b/nss/coreconf/nsinstall/Makefile
index 08dfbc2fe..5061789ff 100644
--- a/nss/coreconf/nsinstall/Makefile
+++ b/nss/coreconf/nsinstall/Makefile
@@ -34,6 +34,10 @@ ifdef NATIVE_FLAGS
OS_CFLAGS=$(NATIVE_FLAGS)
endif
+ifdef NATIVE_LDFLAGS
+LDFLAGS=$(NATIVE_LDFLAGS)
+endif
+
include $(DEPTH)/coreconf/rules.mk
# Redefine MAKE_OBJDIR for just this directory
--
2.34.1

View File

@ -1,4 +1,4 @@
# From https://ftp.mozilla.org/pub/security/nss/releases/NSS_3_79_RTM/src/SHA256SUMS
sha256 ebdf2d6a96613b6fe70ad579e9f983e0e94e0110171cfb2999db633d3394a514 nss-3.79.tar.gz
# From https://ftp.mozilla.org/pub/security/nss/releases/NSS_3_80_RTM/src/SHA256SUMS
sha256 c0bf1fd2c7e29a6b02b309622baafc443eec90c8934bb155da4bb98988784b6a nss-3.80.tar.gz
# Locally calculated
sha256 a20c1a32d1f8102432360b42e932869f7c11c7cdbacf9cac554c422132af47f4 nss/COPYING

View File

@ -4,7 +4,7 @@
#
################################################################################
LIBNSS_VERSION = 3.79
LIBNSS_VERSION = 3.80
LIBNSS_SOURCE = nss-$(LIBNSS_VERSION).tar.gz
LIBNSS_SITE = https://ftp.mozilla.org/pub/mozilla.org/security/nss/releases/NSS_$(subst .,_,$(LIBNSS_VERSION))_RTM/src
LIBNSS_DISTDIR = dist