Update to openssh-3.8p1
This commit is contained in:
parent
c845910178
commit
d5696cdc4e
@ -5,8 +5,8 @@
|
||||
#############################################################
|
||||
|
||||
OPENSSH_SITE:=ftp://ftp.tux.org/bsd/openbsd/OpenSSH/portable/
|
||||
OPENSSH_DIR:=$(BUILD_DIR)/openssh-3.6.1p1
|
||||
OPENSSH_SOURCE:=openssh-3.6.1p1.tar.gz
|
||||
OPENSSH_DIR:=$(BUILD_DIR)/openssh-3.8p1
|
||||
OPENSSH_SOURCE:=openssh-3.8p1.tar.gz
|
||||
OPENSSH_PATCH:=$(SOURCE_DIR)/openssh.patch
|
||||
|
||||
$(DL_DIR)/$(OPENSSH_SOURCE):
|
||||
|
@ -9,9 +9,29 @@
|
||||
|
||||
PATHS= -DSSHDIR=\"$(sysconfdir)\" \
|
||||
-D_PATH_SSH_PROGRAM=\"$(SSH_PROGRAM)\" \
|
||||
--- openssh-3.5p1.orig/configure.ac Thu Sep 26 02:38:47 2002
|
||||
+++ openssh-3.5p1/configure.ac Mon Mar 17 14:55:00 2003
|
||||
@@ -504,6 +504,9 @@
|
||||
--- openssh-3.8p1/configure.ac.orig 2004-02-23 22:47:04.000000000 -0700
|
||||
+++ openssh-3.8p1/configure.ac 2004-03-19 01:41:47.000000000 -0700
|
||||
@@ -481,6 +481,9 @@
|
||||
[
|
||||
AC_MSG_RESULT(no)
|
||||
AC_MSG_ERROR([*** compiler cannot create working executables, check config.log ***])
|
||||
+ ],
|
||||
+ [AC_MSG_RESULT(yes)
|
||||
+ AC_MSG_WARN([Cannot run test when crosscompiling, defaulted to yes.])
|
||||
]
|
||||
)
|
||||
|
||||
@@ -632,6 +635,9 @@
|
||||
else
|
||||
AC_MSG_WARN([zlib version may have security problems])
|
||||
fi
|
||||
+ ],
|
||||
+ [AC_MSG_RESULT(yes)
|
||||
+ AC_MSG_WARN([Cannot run test when crosscompiling, defaulted to yes.])
|
||||
]
|
||||
)
|
||||
|
||||
@@ -696,6 +702,9 @@
|
||||
[
|
||||
AC_MSG_RESULT(no)
|
||||
AC_DEFINE(BROKEN_ONE_BYTE_DIRENT_D_NAME)
|
||||
@ -21,7 +41,7 @@
|
||||
]
|
||||
)
|
||||
|
||||
@@ -535,6 +538,9 @@
|
||||
@@ -727,6 +736,9 @@
|
||||
[
|
||||
AC_MSG_RESULT(no)
|
||||
AC_MSG_ERROR([** Incomplete or missing s/key libraries.])
|
||||
@ -31,7 +51,33 @@
|
||||
])
|
||||
fi
|
||||
]
|
||||
@@ -676,6 +682,9 @@
|
||||
@@ -840,7 +852,11 @@
|
||||
],
|
||||
[AC_MSG_RESULT(yes)],
|
||||
[AC_DEFINE(BROKEN_SETRESUID)
|
||||
- AC_MSG_RESULT(not implemented)]
|
||||
+ AC_MSG_RESULT(not implemented)
|
||||
+ ],
|
||||
+ [AC_MSG_RESULT(yes)
|
||||
+ AC_MSG_WARN([Cannot run test when crosscompiling, defaulted to yes.])
|
||||
+ ]
|
||||
)
|
||||
])
|
||||
|
||||
@@ -854,7 +870,11 @@
|
||||
],
|
||||
[AC_MSG_RESULT(yes)],
|
||||
[AC_DEFINE(BROKEN_SETRESGID)
|
||||
- AC_MSG_RESULT(not implemented)]
|
||||
+ AC_MSG_RESULT(not implemented)
|
||||
+ ],
|
||||
+ [AC_MSG_RESULT(yes)
|
||||
+ AC_MSG_WARN([Cannot run test when crosscompiling, defaulted to yes.])
|
||||
+ ]
|
||||
)
|
||||
])
|
||||
|
||||
@@ -890,6 +910,9 @@
|
||||
AC_MSG_RESULT(no)
|
||||
AC_DEFINE(BROKEN_SNPRINTF)
|
||||
AC_MSG_WARN([****** Your snprintf() function is broken, complain to your vendor])
|
||||
@ -41,40 +87,54 @@
|
||||
]
|
||||
)
|
||||
fi
|
||||
@@ -810,6 +819,10 @@
|
||||
@@ -963,7 +986,10 @@
|
||||
[
|
||||
AC_MSG_RESULT(no)
|
||||
AC_DEFINE(SSHD_ACQUIRES_CTTY)
|
||||
- ]
|
||||
+ ],
|
||||
+ [AC_MSG_RESULT(yes)
|
||||
+ AC_MSG_WARN([Cannot run test when crosscompiling, defaulted to yes.])
|
||||
+ ]
|
||||
)
|
||||
fi
|
||||
|
||||
@@ -1096,6 +1122,10 @@
|
||||
[
|
||||
AC_MSG_RESULT(not found)
|
||||
AC_MSG_ERROR(OpenSSL version header not found.)
|
||||
+ ],
|
||||
+ [
|
||||
+ ssl_header_ver="90700f (OpenSSL 0.9.7a 19 Feb 2003)"
|
||||
+ ssl_header_ver="0x0090704fL (OpenSSL 0.9.7d 17 Mar 2004)"
|
||||
+ AC_MSG_WARN([Cannot run test when crosscompiling, defaulted to $ssl_header_ver])
|
||||
]
|
||||
)
|
||||
|
||||
@@ -843,6 +856,10 @@
|
||||
@@ -1129,6 +1159,10 @@
|
||||
[
|
||||
AC_MSG_RESULT(not found)
|
||||
AC_MSG_ERROR(OpenSSL library not found.)
|
||||
+ ],
|
||||
+ [
|
||||
+ ssl_library_ver="90700f (OpenSSL 0.9.7a 19 Feb 2003)"
|
||||
+ ssl_header_ver="0x0090704fL (OpenSSL 0.9.7d 17 Mar 2004)"
|
||||
+ AC_MSG_WARN([Cannot run test when crosscompiling, defaulted to $ssl_library_ver])
|
||||
]
|
||||
)
|
||||
|
||||
@@ -860,6 +877,10 @@
|
||||
[
|
||||
AC_MSG_RESULT(no)
|
||||
AC_MSG_ERROR(Your OpenSSL headers do not match your library)
|
||||
@@ -1148,7 +1182,11 @@
|
||||
AC_MSG_ERROR([Your OpenSSL headers do not match your library.
|
||||
Check config.log for details.
|
||||
Also see contrib/findssl.sh for help identifying header/library mismatches.])
|
||||
- ]
|
||||
+ ],
|
||||
+ [
|
||||
+ AC_MSG_RESULT(yes)
|
||||
+ AC_MSG_WARN([Cannot run test when crosscompiling, defaulted to yes.])
|
||||
]
|
||||
+ ]
|
||||
)
|
||||
|
||||
@@ -889,6 +910,11 @@
|
||||
# Some systems want crypt() from libcrypt, *not* the version in OpenSSL,
|
||||
@@ -1183,6 +1221,11 @@
|
||||
# Default to use of the rand helper if OpenSSL doesn't
|
||||
# seed itself
|
||||
USE_RAND_HELPER=yes
|
||||
@ -86,7 +146,7 @@
|
||||
]
|
||||
)
|
||||
|
||||
@@ -1475,7 +1501,8 @@
|
||||
@@ -1773,7 +1816,8 @@
|
||||
#else
|
||||
main() { exit(0); }
|
||||
#endif
|
||||
@ -95,8 +155,8 @@
|
||||
+ [ true ]
|
||||
)
|
||||
fi
|
||||
AC_SUBST(NO_SFTP)
|
||||
@@ -1596,6 +1623,7 @@
|
||||
|
||||
@@ -1893,6 +1937,7 @@
|
||||
}
|
||||
],
|
||||
[ ac_cv_have_accrights_in_msghdr="yes" ],
|
||||
@ -104,7 +164,7 @@
|
||||
[ ac_cv_have_accrights_in_msghdr="no" ]
|
||||
)
|
||||
])
|
||||
@@ -1620,7 +1648,8 @@
|
||||
@@ -1917,7 +1962,8 @@
|
||||
}
|
||||
],
|
||||
[ ac_cv_have_control_in_msghdr="yes" ],
|
||||
@ -114,24 +174,42 @@
|
||||
)
|
||||
])
|
||||
if test "x$ac_cv_have_control_in_msghdr" = "xyes" ; then
|
||||
@@ -1931,13 +1960,14 @@
|
||||
@@ -2229,12 +2275,9 @@
|
||||
)
|
||||
fi
|
||||
fi
|
||||
+if test "$cross_compiling" != yes; then
|
||||
AC_CHECK_FILE("/dev/ptc",
|
||||
[
|
||||
AC_DEFINE_UNQUOTED(HAVE_DEV_PTS_AND_PTC)
|
||||
have_dev_ptc=1
|
||||
]
|
||||
)
|
||||
-
|
||||
+fi
|
||||
-AC_CHECK_FILE("/dev/ptc",
|
||||
- [
|
||||
- AC_DEFINE_UNQUOTED(HAVE_DEV_PTS_AND_PTC)
|
||||
- have_dev_ptc=1
|
||||
- ]
|
||||
-)
|
||||
+AC_MSG_CHECKING([for "/dev/ptc"])
|
||||
+AC_MSG_RESULT(no)
|
||||
+have_dev_ptc=0
|
||||
|
||||
# Options from here on. Some of these are preset by platform above
|
||||
AC_ARG_WITH(mantype,
|
||||
[ --with-mantype=man|cat|doc Set man page type],
|
||||
--- openssh-3.5p1.orig/sshd_config Fri Sep 27 05:21:58 2002
|
||||
+++ openssh-3.5p1/sshd_config Mon Mar 17 14:55:00 2003
|
||||
@@ -2329,15 +2372,8 @@
|
||||
fi
|
||||
|
||||
# check for /etc/default/login and use it if present.
|
||||
-AC_ARG_ENABLE(etc-default-login,
|
||||
- [ --disable-etc-default-login Disable using PATH from /etc/default/login [no]],,
|
||||
-[
|
||||
-AC_CHECK_FILE("/etc/default/login", [ external_path_file=/etc/default/login ])
|
||||
-
|
||||
-if test "x$external_path_file" = "x/etc/default/login"; then
|
||||
- AC_DEFINE(HAVE_ETC_DEFAULT_LOGIN)
|
||||
-fi
|
||||
-])
|
||||
+AC_MSG_CHECKING([for "/etc/default/login"])
|
||||
+AC_MSG_RESULT(no)
|
||||
|
||||
dnl BSD systems use /etc/login.conf so --with-default-path= has no effect
|
||||
if test $ac_cv_func_login_getcapbool = "yes" -a \
|
||||
--- openssh-3.8p1.orig/sshd_config Fri Sep 27 05:21:58 2002
|
||||
+++ openssh-3.8p1/sshd_config Mon Mar 17 14:55:00 2003
|
||||
@@ -89,5 +89,8 @@
|
||||
#Banner /some/path
|
||||
#VerifyReverseMapping no
|
||||
|
Loading…
Reference in New Issue
Block a user