paho-mqtt-c: bump to version 1.2.0

Add a patch fixing compilation on the systems without C++ compiler.

Also add licence hashes.

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Yegor Yefremov 2017-09-13 08:07:18 +02:00 committed by Peter Korsgaard
parent 10e998e7cc
commit d3a0be5538
3 changed files with 31 additions and 2 deletions

View File

@ -0,0 +1,27 @@
From 6556e62a07972eafccaefdcdf32bd0d386c64ca2 Mon Sep 17 00:00:00 2001
From: Yegor Yefremov <yegorslists@googlemail.com>
Date: Wed, 13 Sep 2017 07:59:50 +0200
Subject: [PATCH] Declare mqtt-tests as a C-only project
This way CMake doesn't break the build on the systems without
C++ compiler.
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Reported-by: Marcus Hoffmann <m.hoffmann@cartelsol.com>
---
test/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 5c88c44..3aca80f 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,4 +1,4 @@
-PROJECT(mqtt-tests)
+PROJECT(mqtt-tests C)
IF (WIN32)
SET(MQTT_TEST_BROKER "tcp://mqtt.iotree.co.uk:1883" CACHE STRING "Hostname of a test MQTT broker to use")
--
2.1.4

View File

@ -1,2 +1,4 @@
# Locally computed:
sha256 970b9621efc24251441d386274cd0a90cf6ad52b64031f3c8cb53fdd5526f5f3 paho-mqtt-c-v1.1.0.tar.gz
sha256 0cb0396554ebe0e8ac6b0de1cbc16601ef169b6a63baf6f0f3ddeb405f5471a5 paho-mqtt-c-v1.2.0.tar.gz
sha256 83bbba033dc985487e321b6dfde111772affb73460be48726299fed3da684b1c edl-v10
sha256 44277b2bec6093e4ac313afec251a4de599d24c4e768f8574d95b13a9d2d97b5 epl-v10

View File

@ -4,7 +4,7 @@
#
################################################################################
PAHO_MQTT_C_VERSION = v1.1.0
PAHO_MQTT_C_VERSION = v1.2.0
PAHO_MQTT_C_SITE = $(call github,eclipse,paho.mqtt.c,$(PAHO_MQTT_C_VERSION))
PAHO_MQTT_C_LICENSE = EPL-1.0 or BSD-3-Clause
PAHO_MQTT_C_LICENSE_FILES = epl-v10 edl-v10