package/python-daphne: bump to version 4.0.0

Fixup remove pytest runner patch.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
James Hilliard 2022-11-02 13:44:09 -06:00 committed by Thomas Petazzoni
parent 2f4b2e8fb6
commit d2ccca7470
3 changed files with 10 additions and 10 deletions

View File

@ -15,13 +15,13 @@ index 64e94f1..4e3abb0 100755
--- a/setup.py
+++ b/setup.py
@@ -23,7 +23,6 @@ setup(
packages=find_packages() + ["twisted.plugins"],
include_package_data=True,
install_requires=["twisted[tls]>=18.7", "autobahn>=0.18", "asgiref~=3.2"],
install_requires=["twisted[tls]>=22.4", "autobahn>=22.4.2", "asgiref>=3.5.2,<4"],
python_requires=">=3.7",
- setup_requires=["pytest-runner"],
extras_require={
"tests": ["hypothesis~=3.88", "pytest~=3.10", "pytest-asyncio~=0.8"]
},
extras_require={"tests": ["hypothesis", "pytest", "pytest-asyncio", "django"]},
entry_points={
"console_scripts": ["daphne = daphne.cli:CommandLineInterface.entrypoint"]
--
2.21.0

View File

@ -1,5 +1,5 @@
# md5, sha256 from https://pypi.org/pypi/daphne/json
md5 564353eaed92659e3b113d966a0288f2 daphne-2.4.1.tar.gz0
sha256 1e41d02d78da373c1f8504835cdca6d447b5d64c2941661d4bd968d412b6c383 daphne-2.4.1.tar.gz
# Locally computed sha256
md5 f0dcc0618459ad7d25508704f9505b56 daphne-4.0.0.tar.gz
sha256 cce9afc8f49a4f15d4270b8cfb0e0fe811b770a5cc795474e97e4da287497666 daphne-4.0.0.tar.gz
# Locally computed sha256 checksums
sha256 b846415d1b514e9c1dff14a22deb906d794bc546ca6129f950a18cd091e2a669 LICENSE

View File

@ -4,9 +4,9 @@
#
################################################################################
PYTHON_DAPHNE_VERSION = 2.4.1
PYTHON_DAPHNE_VERSION = 4.0.0
PYTHON_DAPHNE_SOURCE = daphne-$(PYTHON_DAPHNE_VERSION).tar.gz
PYTHON_DAPHNE_SITE = https://files.pythonhosted.org/packages/03/6c/847d1c962f8c45aa2ab0791583c4a41669d158e28fd6369ce940b8ea8417
PYTHON_DAPHNE_SITE = https://files.pythonhosted.org/packages/d7/77/57b19d5caabf8537879aa4cf3a017b99d0b727f2521ffca7fd9140573509
PYTHON_DAPHNE_SETUP_TYPE = setuptools
# https://github.com/django/daphne/blob/master/LICENSE
PYTHON_DAPHNE_LICENSE = BSD-3-Clause