package/perl-gd: needs perl-extutils-pkgconfig

Commit 3a291be2e8 forgot to add
perl-extutils-pkgconfig dependency

Fixes:
 - http://autobuild.buildroot.org/results/e590f1990180eae21512b23b884755e105a4c588

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Acked-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
Fabrice Fontaine 2021-02-12 07:39:43 +01:00 committed by Arnout Vandecappelle (Essensium/Mind)
parent d48e5e82ac
commit d172644274
2 changed files with 39 additions and 1 deletions

View File

@ -0,0 +1,34 @@
From 11dc017e902397c452331425eb6101b3315572fa Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Sun, 24 Jan 2021 10:59:31 +0100
Subject: [PATCH] Makefile.PL: fix cross-compilation with gdlib.pc
Cross-compilation will fail if gdlib.pc does not contain any cflags.
Indeed, if cflags is empty, Makefile.PL will use the default value for
INC (i.e. -I/usr/include -I/usr/include/gd)
It should be noted that gdlib-config has been dropped from gd since
version 2.3.0
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: probably not upstreamable]
---
Makefile.PL | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile.PL b/Makefile.PL
index 25f2f93..7da3651 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -47,7 +47,7 @@ If you want to try to compile anyway, please rerun this script with the option -
END
}
-@INC = qw(-I/usr/include -I/usr/include/gd) unless @INC;
+#@INC = qw(-I/usr/include -I/usr/include/gd) unless @INC;
@LIBPATH = qw(-L/usr/lib/X11 -L/usr/X11R6/lib -L/usr/X11/lib -L/usr/lib) unless @LIBPATH;
@LIBS = qw(-lgd) unless @LIBS;
--
2.29.2

View File

@ -7,11 +7,15 @@
PERL_GD_VERSION = 2.73 PERL_GD_VERSION = 2.73
PERL_GD_SOURCE = GD-$(PERL_GD_VERSION).tar.gz PERL_GD_SOURCE = GD-$(PERL_GD_VERSION).tar.gz
PERL_GD_SITE = $(BR2_CPAN_MIRROR)/authors/id/R/RU/RURBAN PERL_GD_SITE = $(BR2_CPAN_MIRROR)/authors/id/R/RU/RURBAN
PERL_GD_DEPENDENCIES = host-pkgconf zlib libpng freetype gd PERL_GD_DEPENDENCIES = host-perl-extutils-pkgconfig zlib libpng freetype gd
PERL_GD_LICENSE = Artistic or GPL-1.0+ PERL_GD_LICENSE = Artistic or GPL-1.0+
PERL_GD_LICENSE_FILES = LICENSE PERL_GD_LICENSE_FILES = LICENSE
PERL_GD_DISTNAME = GD PERL_GD_DISTNAME = GD
PERL_GD_CONF_ENV = \
PATH=$(BR_PATH) \
PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig"
PERL_GD_CONF_OPTS = \ PERL_GD_CONF_OPTS = \
-lib_gd_path=$(STAGING_DIR)/usr \ -lib_gd_path=$(STAGING_DIR)/usr \
-lib_ft_path=$(STAGING_DIR)/usr \ -lib_ft_path=$(STAGING_DIR)/usr \