package/wayland: fix build with gcc 4.8
Fix the following build failure with gcc 4.8 raised since bump to version 1.20.0 in commitf94ba5c31c
and80164ef300
: ../src/wayland-util.c: In function 'for_each_helper': ../src/wayland-util.c:373:2: error: 'for' loop initial declarations are only allowed in C99 mode for (size_t idx = 0; idx < count; idx++) { ^ ../src/wayland-util.c:373:2: note: use option -std=c99 or -std=gnu99 to compile your code Fixes: - http://autobuild.buildroot.org/results/3040c9a8cf08415a7f4338185f6dc7245c68c64c Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
5a96dbad7e
commit
d0b467436c
34
package/wayland/0001-build-set-c_std-c99.patch
Normal file
34
package/wayland/0001-build-set-c_std-c99.patch
Normal file
@ -0,0 +1,34 @@
|
||||
From 40c275f642e3895aeb748403fcdfd92d7d875d65 Mon Sep 17 00:00:00 2001
|
||||
From: Simon Ser <contact@emersion.fr>
|
||||
Date: Mon, 10 Jan 2022 14:54:02 +0100
|
||||
Subject: [PATCH] build: set c_std=c99
|
||||
|
||||
Set explicitly the C standard to use to make sure we don't use
|
||||
features not available on our target platforms.
|
||||
|
||||
Signed-off-by: Simon Ser <contact@emersion.fr>
|
||||
|
||||
[Retrieved from:
|
||||
https://gitlab.freedesktop.org/wayland/wayland/-/commit/40c275f642e3895aeb748403fcdfd92d7d875d65]
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
meson.build | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index cab267e9..e9691ffe 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -5,7 +5,8 @@ project(
|
||||
meson_version: '>= 0.52.1',
|
||||
default_options: [
|
||||
'warning_level=2',
|
||||
- 'buildtype=debugoptimized'
|
||||
+ 'buildtype=debugoptimized',
|
||||
+ 'c_std=c99',
|
||||
]
|
||||
)
|
||||
wayland_version = meson.project_version().split('.')
|
||||
--
|
||||
GitLab
|
||||
|
Loading…
Reference in New Issue
Block a user