package/iperf: bump to version 2.1.9
- Update site to use https instead of http because of HSTS - Drop patch (already in version) https://sourceforge.net/projects/iperf2/files/ Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
3a10a8bf45
commit
d0a27c030a
@ -564,7 +564,6 @@ package/intel-mediasdk/0001-Don-t-force-fstack-protector.patch Upstream
|
|||||||
package/intltool/0001-perl-5.26-compatibility.patch Upstream
|
package/intltool/0001-perl-5.26-compatibility.patch Upstream
|
||||||
package/iotop/0001-Fix-build-error-with-Python-3.patch Upstream
|
package/iotop/0001-Fix-build-error-with-Python-3.patch Upstream
|
||||||
package/iozone/0001-Add-new-targets-for-iozone.patch Upstream
|
package/iozone/0001-Add-new-targets-for-iozone.patch Upstream
|
||||||
package/iperf/0001-fix-single-threaded-compile-breakage.patch Upstream
|
|
||||||
package/ipmitool/0001-configure.ac-fix-readline-static-build.patch Upstream
|
package/ipmitool/0001-configure.ac-fix-readline-static-build.patch Upstream
|
||||||
package/ipmitool/0002-Fix-enterprise-numbers-URL.patch Upstream
|
package/ipmitool/0002-Fix-enterprise-numbers-URL.patch Upstream
|
||||||
package/ipmitool/0003-Do-not-require-the-IANA-PEN-registry-file.patch Upstream
|
package/ipmitool/0003-Do-not-require-the-IANA-PEN-registry-file.patch Upstream
|
||||||
|
@ -1,32 +0,0 @@
|
|||||||
From 6405b7a005bb2364466b56f480d50af0be423d76 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Robert McMahon <rjmcmahon@rjmcmahon.com>
|
|
||||||
Date: Tue, 27 Sep 2022 20:31:04 -0700
|
|
||||||
Subject: [PATCH] fix single threaded compile breakage
|
|
||||||
|
|
||||||
[Retrieved (and backported) from:
|
|
||||||
https://sourceforge.net/p/iperf2/code/ci/6405b7a005bb2364466b56f480d50af0be423d76]
|
|
||||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
||||||
---
|
|
||||||
include/version.h | 2 +-
|
|
||||||
src/Settings.cpp | 2 +-
|
|
||||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/Settings.cpp b/src/Settings.cpp
|
|
||||||
index aac1b5f..fc5a181 100644
|
|
||||||
--- a/src/Settings.cpp
|
|
||||||
+++ b/src/Settings.cpp
|
|
||||||
@@ -1160,10 +1160,10 @@ void Settings_Interpret (char option, const char *optarg, struct thread_Settings
|
|
||||||
delete [] tmp;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
+ }
|
|
||||||
#else
|
|
||||||
fprintf(stderr, "bounceback-congest option requires a platform that supports threads\n");
|
|
||||||
#endif
|
|
||||||
- }
|
|
||||||
}
|
|
||||||
if (bouncebackdelaystart) {
|
|
||||||
bouncebackdelaystart = 0;
|
|
||||||
--
|
|
||||||
2.35.1
|
|
||||||
|
|
@ -1,6 +1,6 @@
|
|||||||
# From https://sourceforge.net/projects/iperf2/files/
|
# From https://sourceforge.net/projects/iperf2/files/
|
||||||
sha1 7725efffc6ef46fe5247ee326c39e5fa2eadf1eb iperf-2.1.8.tar.gz
|
sha1 e7b669c2e8747df95b59956e83ff53d3971d7a5f iperf-2.1.9.tar.gz
|
||||||
|
|
||||||
# Locally computed:
|
# Locally computed:
|
||||||
sha256 8e2cf2fbc9d0d4d1cf9d109b1e328459f9622993dc9a4c5a7dc8a2088fb7beaf iperf-2.1.8.tar.gz
|
sha256 5c0771aab00ef14520013aef01675977816e23bb8f5d9fde016f90eb2f1be788 iperf-2.1.9.tar.gz
|
||||||
sha256 5f9f5c4feca3347c3b3c0ada8b16b4e6b698aac4e6f016a24adf61a5915336d1 COPYING
|
sha256 5f9f5c4feca3347c3b3c0ada8b16b4e6b698aac4e6f016a24adf61a5915336d1 COPYING
|
||||||
|
@ -4,8 +4,8 @@
|
|||||||
#
|
#
|
||||||
################################################################################
|
################################################################################
|
||||||
|
|
||||||
IPERF_VERSION = 2.1.8
|
IPERF_VERSION = 2.1.9
|
||||||
IPERF_SITE = http://downloads.sourceforge.net/project/iperf2
|
IPERF_SITE = https://downloads.sourceforge.net/project/iperf2
|
||||||
IPERF_LICENSE = MIT-like
|
IPERF_LICENSE = MIT-like
|
||||||
IPERF_LICENSE_FILES = COPYING
|
IPERF_LICENSE_FILES = COPYING
|
||||||
IPERF_CPE_ID_VENDOR = iperf2_project
|
IPERF_CPE_ID_VENDOR = iperf2_project
|
||||||
|
Loading…
Reference in New Issue
Block a user