package/ncmpc: bump to version 0.47
- C++20 is mandatory since776e97b7a1
- iconv is an optional dependency since68c04f925d
- Second patch is not needed sincec264db04dd
https://github.com/MusicPlayerDaemon/ncmpc/blob/v0.47/NEWS Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
parent
b35ee9bace
commit
d07edd1e4f
@ -1,38 +0,0 @@
|
||||
From 21ad6bf2bcb0745c25a28637449a72eee883a8e2 Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Sun, 21 Apr 2019 19:19:10 +0200
|
||||
Subject: [PATCH] meson.build: link with lintl if needed
|
||||
|
||||
Fixes:
|
||||
- http://autobuild.buildroot.org/results/d53978fb30d77cb4d10921bf721eff3d066567ce
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Upstream status: not sent as upstream already rejected the first patch
|
||||
on atomic: https://github.com/MusicPlayerDaemon/ncmpc/pull/45]
|
||||
---
|
||||
meson.build | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 2e6defc..28e9d29 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -42,6 +42,7 @@ else
|
||||
error('libintl.h not found')
|
||||
endif
|
||||
conf.set('ENABLE_NLS', enable_nls)
|
||||
+intl_dep = cc.find_library('intl', required: false)
|
||||
if enable_nls
|
||||
conf.set_quoted('GETTEXT_PACKAGE', meson.project_name())
|
||||
subdir('po')
|
||||
@@ -356,6 +357,7 @@ ncmpc = executable('ncmpc',
|
||||
boost_dep,
|
||||
pcre_dep,
|
||||
curses_dep,
|
||||
+ intl_dep,
|
||||
lirc_dep,
|
||||
libmpdclient_dep,
|
||||
],
|
||||
--
|
||||
2.20.1
|
||||
|
@ -4,7 +4,7 @@ config BR2_PACKAGE_NCMPC
|
||||
depends on BR2_INSTALL_LIBSTDCPP
|
||||
depends on BR2_USE_WCHAR
|
||||
depends on BR2_TOOLCHAIN_HAS_THREADS
|
||||
depends on BR2_TOOLCHAIN_GCC_AT_LEAST_7 # C++17
|
||||
depends on BR2_TOOLCHAIN_GCC_AT_LEAST_10 # C++20
|
||||
select BR2_PACKAGE_LIBMPDCLIENT
|
||||
select BR2_PACKAGE_NCURSES
|
||||
help
|
||||
@ -14,7 +14,8 @@ config BR2_PACKAGE_NCMPC
|
||||
|
||||
http://www.musicpd.org/clients/ncmpc/
|
||||
|
||||
comment "ncmpc needs a toolchain w/ C++, wchar, threads, gcc >= 7"
|
||||
comment "ncmpc needs a toolchain w/ C++, wchar, threads, gcc >= 10"
|
||||
depends on BR2_USE_MMU
|
||||
depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
|
||||
!BR2_TOOLCHAIN_HAS_THREADS || !BR2_TOOLCHAIN_GCC_AT_LEAST_7
|
||||
!BR2_TOOLCHAIN_HAS_THREADS || \
|
||||
!BR2_TOOLCHAIN_GCC_AT_LEAST_10
|
||||
|
@ -1,5 +1,5 @@
|
||||
# Locally calculated after checking pgp signature
|
||||
sha256 177f77cf09dd4ab914e8438be399cdd5d83c9aa992abc8d9abac006bb092934e ncmpc-0.46.tar.xz
|
||||
sha256 61da23b1bc6c7a593fdc28611932cd7a30fcf6803830e01764c29b8abed2249c ncmpc-0.47.tar.xz
|
||||
|
||||
# Hash for license file:
|
||||
sha256 ab15fd526bd8dd18a9e77ebc139656bf4d33e97fc7238cd11bf60e2b9b8666c6 COPYING
|
||||
|
@ -5,13 +5,14 @@
|
||||
################################################################################
|
||||
|
||||
NCMPC_VERSION_MAJOR = 0
|
||||
NCMPC_VERSION = $(NCMPC_VERSION_MAJOR).46
|
||||
NCMPC_VERSION = $(NCMPC_VERSION_MAJOR).47
|
||||
NCMPC_SOURCE = ncmpc-$(NCMPC_VERSION).tar.xz
|
||||
NCMPC_SITE = http://www.musicpd.org/download/ncmpc/$(NCMPC_VERSION_MAJOR)
|
||||
NCMPC_DEPENDENCIES = \
|
||||
host-pkgconf \
|
||||
libmpdclient \
|
||||
ncurses \
|
||||
$(if $(BR2_PACKAGE_LIBICONV),libiconv) \
|
||||
$(TARGET_NLS_DEPENDENCIES)
|
||||
NCMPC_LICENSE = GPL-2.0+
|
||||
NCMPC_LICENSE_FILES = COPYING
|
||||
|
Loading…
Reference in New Issue
Block a user