lft: new package

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
[Thomas: use complete license name in <pkg>_LICENSE, i.e "VOSTROM Public
License for Open Source".]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Gustavo Zacarias 2016-05-03 15:30:14 -03:00 committed by Thomas Petazzoni
parent 35a24c6f0f
commit d033022f59
6 changed files with 78 additions and 0 deletions

View File

@ -1426,6 +1426,7 @@ endif
source "package/kismet/Config.in"
source "package/knock/Config.in"
source "package/leafnode2/Config.in"
source "package/lft/Config.in"
source "package/lftp/Config.in"
source "package/lighttpd/Config.in"
source "package/linknx/Config.in"

View File

@ -0,0 +1,19 @@
Don't forcibly strip binaries, we do so on our own.
Also using strip rather than $(STRIP) is bad when cross-compiling.
Patch status: notified upstream.
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
diff -Nura lft-3.74.orig/Makefile.in lft-3.74/Makefile.in
--- lft-3.74.orig/Makefile.in 2016-05-03 14:11:30.965530923 -0300
+++ lft-3.74/Makefile.in 2016-05-03 14:11:42.120918849 -0300
@@ -50,8 +50,6 @@
install: lft lft.8 whob whob.8
@echo "LFT and WhoB"
- @echo " \_Stripping binaries"
- @strip lft whob
@echo " \_Copying files to their intended destinations"
@test -d $(DESTDIR)$(bindir)/. || $(MKDIR) $(DESTDIR)$(bindir)
$(INSTALL) lft $(DESTDIR)$(bindir)/lft

View File

@ -0,0 +1,27 @@
Don't pollute incdir with absolute directories, it's bad when
cross-compiling.
Patch configure directly since autoreconf isn't clean.
Patch status: notified upstream.
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
diff -Nura lft-3.74.orig/configure lft-3.74/configure
--- lft-3.74.orig/configure 2016-05-03 14:11:30.964530888 -0300
+++ lft-3.74/configure 2016-05-03 14:12:45.038106775 -0300
@@ -5732,15 +5732,6 @@
-for incdir in /usr/local/include /usr/include
-do
- if test -d $incdir/pcap
- then
- CFLAGS="$CFLAGS -I$incdir/pcap"
- CPPFLAGS="$CFLAGS -I$incdir/pcap"
- fi
-done
-
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF

10
package/lft/Config.in Normal file
View File

@ -0,0 +1,10 @@
config BR2_PACKAGE_LFT
bool "lft"
select BR2_PACKAGE_LIBPCAP
help
LFT, short for Layer Four Traceroute, is a sort of
'traceroute' that often works much faster (than the
commonly-used Van Jacobson method) and goes through many
configurations of packet-filters (firewalls).
http://pwhois.org/lft/

2
package/lft/lft.hash Normal file
View File

@ -0,0 +1,2 @@
# Locally calculated, matches download from fossies.org and pwhois.org
sha256 d7f142b9198162a48dd41261f5982e5189b951e7746e171d6b2c5b9581f26000 lft-3.74.tar.gz

19
package/lft/lft.mk Normal file
View File

@ -0,0 +1,19 @@
################################################################################
#
# lft
#
################################################################################
LFT_VERSION = 3.74
# Download from pwhois.org is form-wrapped resulting in ugly filename
LFT_SITE = https://fossies.org/linux/privat
LFT_DEPENDENCIES = libpcap
LFT_LICENSE = VOSTROM Public License for Open Source
LFT_LICENSE_FILES = COPYING
LFT_CONF_OPTS = --with-pcap=$(STAGING_DIR)/usr
ifeq ($(BR2_STATIC_LIBS),y)
LFT_CONF_OPTS += LIBS="`$(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs`"
endif
$(eval $(autotools-package))